[solved] HSI-88 RS232 not responding

Moderator: Moderators

[solved] HSI-88 RS232 not responding

Postby fraser55 » 06.02.2017, 18:30

Hi all,

I did a test with Rocrail a few years ago with an LDT HSI-88 RS232 interface with a FTDI chip USB2serial converter under WinXP and it worked fine.

Now i have finished my "Schattenbahnhof" and want to put my interfaces to work with a Windows 7 PC. But the HSI-88 does not start properly and the communication gives every second the following error:
"r9999W hsi88fb OHSI88 0562 Init response expecting 0x73, length 3 but got 0x69, length 3 r0000W hsi88fb (null) *trace dump( 0x0545FB5E: length=3 )"

I have searched the forum and the internet for this type of problem, but did not find anything (apart a problem in old build of rocrail), nor did i find information on how to eventually configure the COM port in combination with the HSI-88.

Thank you for your help.




HSI88 RS232 Problem.trc
You do not have the required permissions to view the files attached to this post.

Re: HSI-88 RS232 not responding

Postby LDG » 06.02.2017, 19:22


I'm noot sure, but you should configure at least 1 module on one of the lines (left, middle or right).
Any change in responses?

Site Admin

Re: HSI-88 RS232 not responding

Postby fraser55 » 06.02.2017, 20:16


Pfff..., i had the opinion that HSI-88 detects the number of modules by himself, i gave the number of modules on the left string and now it works. :lol:

It was a dumb mistake, since i did not remember my experience some years ago.

Thanks a lot for the hint!


Return to HSI88