HSI-88 USB with windows

Post Reply
applor
Posts: 50
Joined: 10.06.2016, 00:30

HSI-88 USB with windows

Post by applor » 10.12.2018, 00:58

Hello everyone,

First, I acknowledge that USB is no longer support with Rocrail. I understand this is because LDT does not have a USB driver for Linux but that the USB version was/should work with Windows.
Unfortunately it was a couple of years ago and I mistakenly ordered the USB version, though I run windows so I hope I should be able to get it working.

I believe I have everything configured correctly, though I get no feedback on my layout plan for occupancy - therefore I am just asking for experienced users to advise if I have left anything out.
The log file leads me to believe Rocrail is talking to the LST HSI S88. Therefore I am not sure if the problem is with my S88 bus or modules or something else.


1) I have configured the module in Rocrail properties as per attached screenshot (S88.jpg) - you can also see my configured Marklin CS2 which works

2) I added the code to the ini file as per the wiki:

Code: Select all

<digint iid="HSI S88" lib="hsi88" device="\\.\HsiUsb1" bps="9600" flow="cts" restricted="false" stress="false" guid="50E549EDA0A420181210093626937000" libpath="D:\Rocrail" desc="" ignorepowercmds="false" ignorepoweroffonghost="false">
    <hsi88 usb="true" fbleft="4" fbmiddle="4" fbright="4" smooth="false" triggertime="100"/>
  </digint>
3) the S88 is wired as per LDT instructions. I have 4 modules per bus using S88-N adaptor. AC input direct from transformer that is also wired to CS2.

4) the required USB and Dico station drivers are installed in Windows and state they are working correctly (windows device.jpg)

5) The sensors are configured in Rocrail with the correct sequential addressing from L to M to R (Address = ( Module - 1 ) * 16 + Port ) from 1 to 192.

I have attached my plan and ini and there is also a screenshot (S88_log.jpg) showing the Rocrail log when I launch.

You can see that it says for the OHSI88fb: got init response



Can anyone assist? I have also inquired with LDT if I send them the USB version if they can exchange it for the serial but I purchased the module 2 years ago so this is unlikely.

Thanks!
You do not have the required permissions to view the files attached to this post.

applor
Posts: 50
Joined: 10.06.2016, 00:30

Re: HSI-88 USB with windows

Post by applor » 15.12.2018, 04:52

I've found I may need to run a separate earth for my S88 modules so this may be the cause, I'll post my results after I'm done.

idlemarvel
Posts: 89
Joined: 22.10.2014, 09:11

Re: HSI-88 USB with windows

Post by idlemarvel » 18.12.2018, 17:36

I used to run LDT HSI-s88 module with Windows (XP) with a RS232 to USB convertor (Digitus DA-70156). It worked very well for years.
When you plug the HSI module in, does it not appear as a COMn device? If so that is the device name you should use not \\.\etc

LDG
Site Admin
Posts: 2701
Joined: 18.10.2010, 00:03
Location: near Karlsruhe/Germany

Re: HSI-88 USB with windows

Post by LDG » 18.12.2018, 18:12

Hi,

the HSI-88-USB by Litfinski is using a "human interface device (HID)" implementation. This is supported with older Windows versions.
This device is not compatible with the (much cheaper) HSI-88-rs232 serial version using an additional rs232-USB adapter (like Dave and I) that use the serial protocol.

In the log we can see that the "init" sequence is completed successfully: "S88 connected modules: 12"

You may try to use the sensor monitor (Rocview/Control/Sensor monitor...) to see if (and how!) sensor events are transferred to Rocrail.

Lothar

applor
Posts: 50
Joined: 10.06.2016, 00:30

Re: HSI-88 USB with windows

Post by applor » 19.12.2018, 05:49

Hi and thanks for responding.

Marvel, as advised I am using the USB version not the serial version. I have a friend using the serial version with USB converter in windows however, so he has been able to help with some things.

I have done some further investigation and changes and I am relieved to announce that I do have the HSI-88 USB version working with Rocrail in windows. I have a lot of work to do however:

Currently only my middle bus is responding - the right bus for some reason when connected causes all modules from all 12 modules to show as occupied. When I isolated the right bus I found that the middle bus was working.
It is not a problem with the HSI-88 however as the HSI-88 right bus links works when I connect the middle bus cable over to the right - it appears at this stage to be a problem with the first S88 module in the right bus chain.
and on the other side none of my left bus modules give feedback, they always show unoccupied. At least it does not impact the other bus like the right one does.

So yes it does work but I need to go and test individual S88 modules to try and determine what is faulty and so forth but at least I can actually test modules now that I found that weird problem with the right bus module.

Post Reply

Return to “HSI88”