Issue with S88

http://www.opendcc.de
http://www.bidib.org
Post Reply
gcorbaz

Issue with S88

Post by gcorbaz » 19.02.2012, 19:59

Hello

I'm facing some issue with S88. I'm using reeds and magnets to detect the position of my trains. It works fine for a while, then the train are not detected leading to error messages and functionning errors.

I have two magnets below my Locos.

My settings are:

Linux Ubuntu
RocRail build 3239
OpenDCC 0.23

dac
Posts: 49
Joined: 02.09.2010, 11:03
Location: UK

Post by dac » 19.02.2012, 20:17

For better reliability try replace reeds with curent sensing detectors.

RocJan
Posts: 15
Joined: 12.11.2011, 13:53
Location: Groningen NL

Post by RocJan » 20.02.2012, 17:42

Hi gcorbaz,

If you use magnets and reed contact it may be that the time to read the sensor is ON is too short to detect it on the S88 system.
You can chack by testing it with slow speed and later with high speed passing of the train.
If this seems your problem you could try to delay the reed contact from opening with a RC network. (or Capacitor in parallel with the reedcontact)
Above can only be your problem if all other senors you are using have similar problems!
I asume you have checked the positioning of reed contacts to the magnets in your trains.

gcorbaz

Post by gcorbaz » 24.02.2012, 18:26

Hello,

Thank you for your comemnts.

You might be right. The magnets are correctly poitionned and I'm facing more issues when the speed of the train is high. At higher speed, the êrror rate is very high.

Is there a way to improve reliability is, for example, changing the refresh rate of the S88 devices ?

I'm usinf OpenDCC.

Bests regards, Guy.

RocJan
Posts: 15
Joined: 12.11.2011, 13:53
Location: Groningen NL

Post by RocJan » 25.02.2012, 15:47

Hello Guy,

You can check if your settings for the S88 bus is set for the correct numbers of S88 modules. (I use the DDX controller)
If you use 1 chain then chains should be set to 1.
If you have N modules then chain 0 should be set at N.
If you put more chains or modules then needed the s88 bus wil check them all and this takes more time.

I also used a 10 kilo Ohm resistor on the last module of a chain between pin 1 and pin 6 of the not used outgoing connector to let the S88 bus know that it was the last one to check.
To be honnest I don't know if this is necesarry for all S88 modules.

If you check above points then you have the fastest S88 settings.

Schorse
Posts: 5353
Joined: 12.09.2008, 19:38
Location: D - Niedersachsen

Post by Schorse » 25.02.2012, 23:18

Hi gcorbaz,

if you are using p50x protokoll with Opendcc, since Rocrail Rev. 3250 you can reduce sleep time for S88 bus in p50x Protokoll settings (it means more readings per second from Command Station).

Regards Gerd

opendcc
Posts: 137
Joined: 08.01.2009, 22:03

[solved] Issue with S88

Post by opendcc » 27.03.2012, 10:20

Hello,

as a summary - the problem had nothing to do with s88 or opendcc command station at all. The used detection routine was build for CNY70 reflective optocouplers and was unsuitable for hall sensor like the TLE. There is a new firmware for the detector, supporting hall sensors.

br Wolfgang, www.opendcc.de, www.bidib.org

gcorbaz

Post by gcorbaz » 08.04.2012, 18:38

Thank you to everyone for your help.

I did also some parallel investigation. My RocRail sever is running on Linux Ubuntu. If my machine is too loaded, it miss some feedback events. I reniced the rocrail process to try to improve and stopped unusefull other processes. This improve a bit the problem.

I will also upgrade the firmware.

Aleksey
Posts: 84
Joined: 07.01.2012, 18:35
Location: Russia

Post by Aleksey » 07.07.2013, 19:59

Hi!
I need your help.
I have such a problem. The control is made through OpenDCC station by P50X protocol. On the layout reed contacts are installed. Feedback S-88. Windows XP.
The problem is not all pulses of sensors are processed by the program as an event.
In the server RocRail can see that the station has transmitted information about the sensor is triggered, but the program has ignored this information. (see picture). Please tell me what to do.

P.S. I am sorry for my English. Use Google Translator.
You do not have the required permissions to view the files attached to this post.

LDG
Site Admin
Posts: 2701
Joined: 18.10.2010, 00:03
Location: near Karlsruhe/Germany

Post by LDG » 10.07.2013, 14:27

Hi Alex,

a screenshot is difficult to debug an possible malfunction :(

Please put the following files in a ZIP-archive and attach them to this thread:
rocrail.ini
plan.xml (or other if you use a different name for your plan)
rocrail.*.trc (traces that contain the logs of the moment the error occured)


If it is the same sensor where consecutive events are missed it might be the setting for Ignore events within...


Regards,
Lothar

Aleksey
Posts: 84
Joined: 07.01.2012, 18:35
Location: Russia

Post by Aleksey » 10.07.2013, 15:01

OK, I should prepare an archive.

Aleksey
Posts: 84
Joined: 07.01.2012, 18:35
Location: Russia

Post by Aleksey » 13.08.2013, 20:03

I solved the problem. Sensors connected to the feedback modules, via the expander pulses. Now when sensor is activated, the expander generates a pulse for 1-1.5 seconds.

Post Reply

Return to “OpenDCC & BiDiB”