Elite turnout addressing...

Elite turnout addressing...

Postby RAFHAAA96 » 05.02.2012, 10:15

Hi Rocrailers
I trust the bad weather in Europe is not causing you too many problems.

I have been playing with various addressing methods to see if I can get the Elite to switch points in both Classic and Standard modes with Rocrail and this is the result:

MADA - Rocrail will only switch points in Classic mode and the addressing has to be as follows to get the firing correct:
Turnout 1 = Addr 1 port 4, T2 = Addr 2 port 1, T3 = Addr 2 port 2, T4 = Addr 2 port 3, T5 = Addr 2 port 4, T6 = Addr 3 port 1, ... T10 = Addr 4 port 1, ... T14 = Addr 5 port 1, etc, etc.
Standard mode will not switch points, only control locos. :cry:

FADA - Rocrail switches points in both Standard and Classic modes.
Addresses were set from 1 to 15, ports were all set to 0.
As gates have to be taken account of as well as addresses I didn't persue this to correct these misfires: :?
Classic mode - T1-4 didnt fire, T6 & T7 fired T1, T8 fired T8, T9 fired T2, T10 & T11 fired T3, T12 & T13 fired T4, T14 & T15 fired T5.
Standard mode - T1 fired T1, T2 fired T2, T3 fired T2, T4 & T5 fired T3, etc, etc.

PADA - Rocrail switches points in both Standard and Classic modes.
Addresses were all set to 0 and ports set from 1 to 15.
Standard mode - all Turnouts fired correctly. :D
Classic mode - T1, T2 & T3 did not fire. T4 fired T1 ... etc ... T15 fired T12. So there is the old chestnut of -3 error between the modes.

Is it possible for the Elite sub-library to be amended so that 3 could be added to the port number only when Classic mode is in use.

If Expressnet does not support the Elite reporting back which mode it is using so that the sub-sub-library could be applied automatically, is it possible there could be a radio button choice (Standard or Classic mode) on the File - Rocrail Properties - Controller - Expressnet - Elite page, which would bring the +3 correction into use or not as required for the mode selected.

Regardless of that it would seem that putting the Elite into Standard mode and using the straightforward PADA addressing system is the easiest way for Elite users to overcome any points addressing problems.

As always - Rocrail is a fantastic piece of work.
Rob
Regards Rob.
Halton Brat
OO gauge - Hornby Elite & eLink CS & Accessory Decoders - Win 8 - 64 bit.
RAFHAAA96
 

Postby ron&bram » 05.02.2012, 11:23

Hi Rob,

Which firmware version of the Elite are you using? There could be a difference between 1.3 and 1.4 to make matters even more joyfull.
Best regards, Viele Grüsse, vriendelijke groeten, Ronald :rr_cap:
GCA85/50/93/145/146/153 Loconet, Twincenter+booster for locs, seperate booster for accessory decoders, dedicated laptop with XP and Ubuntu for Rocrail, AndRoc, LGB indoor OTF layout
ron&bram
 

Postby RAFHAAA96 » 05.02.2012, 12:01

Hi Ron
I'm using v 1.4, which makes several improvements over v 1.3, including more functions accessible direct from the Elite, quicker refuelling and setting up of auto-ops is simpler to do by way of menus, rather than fiddling with cvs. There are so many changes that Hornby issued an addendum to the Elite manual - I can't attach it even though .pdf as it is almost 4Mb. I could pm it to you.
Rob
Regards Rob.
Halton Brat
OO gauge - Hornby Elite & eLink CS & Accessory Decoders - Win 8 - 64 bit.
RAFHAAA96
 

Postby ron&bram » 05.02.2012, 13:51

Hi Rob,

I've the 1.4 update available on my pc, but haven't updated the Elite (the Elite is not in use at the moment). I think that when I have time I will check if your results with the different modes arealso valid for the 1.3 firmware.
Best regards, Viele Grüsse, vriendelijke groeten, Ronald :rr_cap:
GCA85/50/93/145/146/153 Loconet, Twincenter+booster for locs, seperate booster for accessory decoders, dedicated laptop with XP and Ubuntu for Rocrail, AndRoc, LGB indoor OTF layout
ron&bram
 

Postby RAFHAAA96 » 05.02.2012, 14:21

Hi Ron
If you have the v 1.4 download you have the manual addendum included in the zip. - the .pdf file is called Elite Notes.
Previously with v 1.3 then v 1.4 I had only used MADA addressing and that only worked in Classic mode. No turnouts fired in Standard mode as stated earlier.
I hadn't tried PADA then so it will be interesting to see if there is any change effect between the 2 revisions.
The problem is when Hornby releases a new firmware revision there is no record of the previous revision unless you have saved it on your pc. As my pc was a rebuild I didn't have any reversal handy to try it.
Rob
Regards Rob.
Halton Brat
OO gauge - Hornby Elite & eLink CS & Accessory Decoders - Win 8 - 64 bit.
RAFHAAA96
 


Return to Hornby Elite