Solved: Problem loading Rocview workspace

Solved: Problem loading Rocview workspace

Postby RAFHAAA96 » 06.02.2012, 11:40

Hi
Please see attached zip for trace, ini and plan files. The trace files lodge in my User/.../Rocrail area and the others lodge in Rocrail_Workspace which is also in this area.

I also attach an 'spare' ini file that appears in my top Trains folder.

I also get trace files appearing in the Rocrail location in Program Files, with the same date time group.

Rocrail is running V 3207, which I recently had problems with the unicode download not working properly so Rob asked me to use a different source file and that worked OK.

I'm using Win 7 Home Premium 32 bit, with 1.5Gb RAM, P4 3GHz.

All was running well until yesterday, then after I changed turnouts to PADA addressing, dragged and dropped all locs to blocks and I tried the Start of Day menu selection. I presume this s.o.d is much the same as Init Field was as all turnouts started clattering.

At next Rocrail start up the trace showed Rocrail setting turnouts endlessly. I had to use Ctrl-Alt-Del to kill the application.

Then I wiped the trace files and did a new start up with the same result.

All works fine direct from the Elite so we can rule out a bad CS.

Any help you can give is much appreciated.
Thanks, Rob
You do not have the required permissions to view the files attached to this post.
Regards Rob.
Halton Brat
OO gauge - Hornby Elite & eLink CS & Accessory Decoders - Win 8 - 64 bit.
RAFHAAA96
 

Postby rjversluis » 06.02.2012, 11:52

Hi Rob,

it seems that you have turned on the control option for all switches:
http://wiki.rocrail.net/doku.php?id=switch-ctrl-en
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Postby RAFHAAA96 » 06.02.2012, 12:06

Hi Rob
Yes I did that as I thought it set the delay between switching when setting a route. If not that how do I delay route switching to give CDU a chance to recharge.
So - how do I get back to the dialogue to de-activate the switches as I have no way to select anything on the Rocrail screen when this merry-go-round is going.
Which file can I edit (if possible) to turn it off please and what is the code looking like.
Thanks, Rob
Regards Rob.
Halton Brat
OO gauge - Hornby Elite & eLink CS & Accessory Decoders - Win 8 - 64 bit.
RAFHAAA96
 

Postby Besra » 06.02.2012, 12:28

Hi,

open your rocview.ini that's in your workspace with a text editor and search for the entry
Code: Select all
startdefaultworkspace="true"

change this to
Code: Select all
startdefaultworkspace="false"

and save the file.
Now open Rocview. Go to File / Open... and load your plan file.
Make your changes and select File / Save.
Close Rocview and start it again. Go to File / Open workspace... and select your workspace. If everything is OK now, go to File / Rocview properties... and activate the "Use Workspace at startup" option again.

To set the switch time in routes select File / Rocrail properties... / automatic and increase the value for "Route switch time". See http://wiki.rocrail.net/doku.php?id=rocrailini-automode-en for a description.

Best regards
Besra
Maerklin H0, DCC and MM, Intellibox (I) via ULNI, Booster Tams B4, Throttle Digitrax UT4, LocoNet.
Loco decoders: Zimo, Uhlenbrock, Maerklin & ESU.
Rocweb, Win10 32bit & 64bit
Besra
 

Postby RAFHAAA96 » 06.02.2012, 13:07

Hi Besra
I amended the ini file default workspace to false, saved, tried again. Same result, so I nulled the actual workspace reference in the ini file, saved and tried again.
Same result. I cant stop this merry-go-round.
To rule out my planfile I will now try to use Rocrail sample plan ref, the nreport back.
Rob
Regards Rob.
Halton Brat
OO gauge - Hornby Elite & eLink CS & Accessory Decoders - Win 8 - 64 bit.
RAFHAAA96
 

Postby rjversluis » 06.02.2012, 13:36

Hi Rob,

I deactivated all for you.
You do not have the required permissions to view the files attached to this post.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Postby RAFHAAA96 » 06.02.2012, 14:06

Thanks Rob
I had set the Rocrail planfile to get into Rocview, then reloaded my Moni file and deactivated all the switch delays and got it working again, but its nice to have you do it for me anyhow.
I will over-write with your version as it is more likely to be stable and correct than mine.
Rob
Regards Rob.
Halton Brat
OO gauge - Hornby Elite & eLink CS & Accessory Decoders - Win 8 - 64 bit.
RAFHAAA96
 

Postby RAFHAAA96 » 06.02.2012, 15:25

rjversluis wrote:Hi Rob,

Code: Select all
  /* when sending to elite we have to correct for elite (version 1.3) addressing fault
     address 1, port 1 does not exist in elite, address 1 port 2 becomes decoder 1 port 1,
     address 1 port 3 becomes decoder 1 port 2, address 2 port 1 becomes decoder 1 port 4
   */

I'm not sure what you want: Remove the fix?


Rob

Your code comment above is correct.

In Classic mode there always was an offset of -3 so that when using MADA addressing I had to address point 1 as addr 1 port 4, point 2 had to be set as addr 2 port 1, etc.

If you set them up as addr 1 port 1, etc then point 4 would fire point 1, which is what your fix was supposed to correct.

Except in MADA it didn't seem to work, I still had to make the address/port offset myself to get them to fire correctly.

But using PADA addressing with addr 0 (all) and ports 1 - 15 (matching the point numbers) it worked fine in Standard mode, but with the -3 offset still there in Classic mode.
Unfortunately now Standard mode seems to have stopped working again.
Edit - it seems to be to do with how you change modes on the Elite. If you power off at Rocrail, (Elite shows ERROR - so ESC to cancel it) then change Elite mode to Standard then power off/on again in Rocrail it works again. End Edit.

What I was looking for is using PADA addressing there is no need for a fix in Standard mode but keep the -3 fix in Classic mode.

I hope this makes it a little bit clearer.

Rob
Regards Rob.
Halton Brat
OO gauge - Hornby Elite & eLink CS & Accessory Decoders - Win 8 - 64 bit.
RAFHAAA96
 


Return to Hornby Elite

cron