Hornby Elite Classic/Standard Mode

Elite mode problem

Postby RAFHAAA96 » 28.04.2013, 15:10

Rob
I saved my plan file and images folder then deleted Rocrail.
I then installed vers 5094 and pasted my plan file (vers 5093) and images folder back into the Rocrail folder.
The problem stays the same - locs control but no switch control in Standard mode.
I notice there is no Workspace folder at reinstall, so I make that as an empty folder. There does not seem to be a Make Workspace menu item.
Rob
You do not have the required permissions to view the files attached to this post.
Regards Rob.
Halton Brat
OO gauge - Hornby Elite & eLink CS & Accessory Decoders - Win 8 - 64 bit.
RAFHAAA96
 

Postby rjversluis » 28.04.2013, 15:17

Hi Rob,

as I wrote before; I did not change anything in the Elite support.
But maybe another Elite user can help out... Ronald?
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Postby RAFHAAA96 » 28.04.2013, 15:32

Hi Rob
I just tried my spare Elite and the problem remains.
The Controller pane in the UI reports Switch [Tnn] will be set to turnout or straight but the addressing shown is [turnout, 0,0] or [straight, 0,0].
The Server pane reports not processing accessory [Tnn] commands: Power is Off.
The switch Interface tab shows the address / port as 0,nn - i.e. OK for that switch.
As you say maybe Ron can help confirm or refute the problem.
Thanks Rob
Regards Rob.
Halton Brat
OO gauge - Hornby Elite & eLink CS & Accessory Decoders - Win 8 - 64 bit.
RAFHAAA96
 

Postby ron&bram » 28.04.2013, 16:32

Hi Guys,

I'll test with my Elite as soon as I have access to my layout again (at work at the moment).
Best regards, Viele Grüsse, vriendelijke groeten, Ronald :rr_cap:
GCA85/50/93/145/146/153 Loconet, Twincenter+booster for locs, seperate booster for accessory decoders, dedicated laptop with XP and Ubuntu for Rocrail, AndRoc, LGB indoor OTF layout
ron&bram
 

Postby ron&bram » 29.04.2013, 20:48

Hello Holland, may we have your votes please:

Hornby in classic mode, V2 vunticked: correct switch address is reacting -> :okay:
Hornnby in standard mode, V2v ticked: correct switch address is reacting -> :okay:

BUT: I had to connect the Elite to an USB port on my laptop, via a hub did not work.
Best regards, Viele Grüsse, vriendelijke groeten, Ronald :rr_cap:
GCA85/50/93/145/146/153 Loconet, Twincenter+booster for locs, seperate booster for accessory decoders, dedicated laptop with XP and Ubuntu for Rocrail, AndRoc, LGB indoor OTF layout
ron&bram
 

Postby RAFHAAA96 » 30.04.2013, 07:12

Hi Ron
I thought you may have found the problem with the USB hub note as I have my Elite plugged into a USB 3.0 PCI-e expansion card in my pc.
I swapped it over to a standard back USB port and changed the COM port to suit. Unfortunately that didn't alter the outcome.
So I changed over to a front USB port with the same outcome - loc control but no switch control in Standard mode.
I even tried a different USB cable.
It looks as if its back to the drawing board, unless there is anyone else out there running Elite v1.41 on Win8 64 bit.
Many thanks for your help.
Rob
Regards Rob.
Halton Brat
OO gauge - Hornby Elite & eLink CS & Accessory Decoders - Win 8 - 64 bit.
RAFHAAA96
 

Postby ron&bram » 30.04.2013, 10:03

Hi Rob,

When connected via a hub, Rocrail had issues recognizing the Elite Power state, when operating tunrouts, I got these messages:
Code: Select all
OXpressN 0203 not processing accessory[T13] commands: Power is OFF
. When Rocrail does not see that power is on, the turnout command is not processed. @Rob Versluis: checking or unchechking the checkpowerstate flag in the digint ini made no difference.
Best regards, Viele Grüsse, vriendelijke groeten, Ronald :rr_cap:
GCA85/50/93/145/146/153 Loconet, Twincenter+booster for locs, seperate booster for accessory decoders, dedicated laptop with XP and Ubuntu for Rocrail, AndRoc, LGB indoor OTF layout
ron&bram
 

Postby rjversluis » 30.04.2013, 10:21

@Ronald Berkel:
Which Revision are you using?
Trace line 203 should be 298!!!
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Postby ron&bram » 30.04.2013, 10:33

Hi Rob,

The line was from Rob's trace in a post above, I use 5093.
Best regards, Viele Grüsse, vriendelijke groeten, Ronald :rr_cap:
GCA85/50/93/145/146/153 Loconet, Twincenter+booster for locs, seperate booster for accessory decoders, dedicated laptop with XP and Ubuntu for Rocrail, AndRoc, LGB indoor OTF layout
ron&bram
 

Postby rjversluis » 30.04.2013, 10:48

Hi Ronald,
ron&bram wrote:Hi Rob,

When connected via a hub, Rocrail had issues recognizing the Elite Power state, when operating tunrouts, I got these messages:
Code: Select all
OXpressN 0203 not processing accessory[T13] commands: Power is OFF
. When Rocrail does not see that power is on, the turnout command is not processed. @Rob Versluis: checking or unchechking the checkpowerstate flag in the digint ini made no difference.


I tested this with the head revision and this option does make difference:

Option activated:
Code: Select all
20130430.114413.691 r9999c cmdrC400 OSwitch  0988 Switch [sw1] will be set to [turnout,0,0]
20130430.114413.691 r9999W cmdrC400 OXpressN 0298 not processing accessory[sw1] commands: Power is OFF


Option deactivated:
Code: Select all
20130430.114456.779 r9999c cmdrC800 OSwitch  0988 Switch [sw1] will be set to [straight,0,0]
20130430.114456.779 r9999c cmdrC800 OXpressN 0372 switch 1-2 straight
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Postby ron&bram » 30.04.2013, 11:46

Hi Rob,

I rewired the layout again to run through the Elite. The chk4power flag for accessory commands is working OK.
Robbie: I think the issue is that the Elite (driver) is deaf, dumb and blind when connected through a hub (some motherboards use an on board hub for their USB connections). When I connect the Elite through a pcmcia USB card, I do not get any message from the Elite when turning on/off power. Neither can I operate turnouts. When connected directly to the laptop, I get an emergency break message when powering off the Elite in classic mode (in standard mode no power message is send, I would recommend that Elite users start complaining at Hornby's customer service about their crapppy XpressNet implementation, I did years ago with an extended report on what was wrong, but all I got was a thank you for your effort reply).
Best regards, Viele Grüsse, vriendelijke groeten, Ronald :rr_cap:
GCA85/50/93/145/146/153 Loconet, Twincenter+booster for locs, seperate booster for accessory decoders, dedicated laptop with XP and Ubuntu for Rocrail, AndRoc, LGB indoor OTF layout
ron&bram
 

Postby RAFHAAA96 » 30.04.2013, 12:35

Thanks Ron and Rob for chasing down this anomaly which seems to lie mostly at Hornby's door for poor XpressNet implementation, but also my cheapo HP pc is obviously not so good as it seems as though the USB portage arrangement may be odd. I will ask their forums about it.
Rob
Regards Rob.
Halton Brat
OO gauge - Hornby Elite & eLink CS & Accessory Decoders - Win 8 - 64 bit.
RAFHAAA96
 

Solved - Elite point switching problem

Postby RAFHAAA96 » 13.07.2013, 12:10

For the information of any other Hornby Elite users.
After loading version 5551 I had another look at why the points would not switch with Elite in Standard mode as reported above.
Ron had already pointed out about the check4power flag so I unticked the Power On State For Accessory Commands in the Controllers>Elite setup.
The points now switch correctly both in Standard mode with V2 unticked and in Classic mode with V2 ticked.
Rob
Regards Rob.
Halton Brat
OO gauge - Hornby Elite & eLink CS & Accessory Decoders - Win 8 - 64 bit.
RAFHAAA96
 

Previous

Return to Hornby Elite

cron