Page 2 of 3

Posted: 12.02.2012, 09:49
Hi guys

I re-ran the test with the Elite in Standard mode and Rocrail controller set as Hornby Elite @19200, but with the RxTx buffers set low in pc control panel\device manager\Elite port - advanced button .

I also had all the boxes not ticked in controller option frame and switch time @500ms.

I could control power on/off from Rocrail, the locos responded and the switches all worked as advertised using the PADA 0/1-15 method.
I checked switch operation using track plan clicks and switch control panel. All switches are getting double instructions as the relays rattle twice.

I have no idea why it worked this time and not before, except for the bufferring speed. Maybe this is the answer.

All the usual files attached for you to review.

Thanks, Rob

Posted: 12.02.2012, 13:00
by ron&bram
Hi Rob,

Can you please test revision 3253+ when it has become available in the nightly builds. With this version and the Elite in classic mode, you -once- need to manually edit the rocrail.ini file. Look for the line starting with <digint and add in that line the following:

Code: Select all

When the protver parameter is not defined or set to 0, the code corrects the switch address with 1 port (standard mode). If the parameter is set to 1, the code corrects the switch address with 1 address (classic mode).
The xpressnet code sends two commands in case a switch is operated, the first command to turn on power on the gate, the second command to turn the power off again. Some old accessory decoders require the turn off command, without it they leave the power on, which would fry the switch coil. Because I fear the wrath of people which such decoders I won't touch that part of the code.

Posted: 12.02.2012, 14:11
by rjversluis
Hi Ronald,

you can use the V2 checkbox in the dialog in case of elite; This will set protver="2" and will work too because your fix just checks if it is zero or not. ;-)

Posted: 12.02.2012, 14:14
Thank you Ron
I will test as soon as I can and report back.
So by setting protver as 0 or 1 I can choose my default Elite mode.

Posted: 12.02.2012, 14:29
by ron&bram
@ Rob Versluis,
you can use the V2 checkbox
But then the rest of the xpressnetcode will also use xpressnet V2 commands and not V3. I have no idea how this will effect the Elite's operation.

Yes, the protver 0/1 parameter switches between address correction for classic or for standard mode. Over here it works OK. I also augmented the wiki for the Elite.

Posted: 12.02.2012, 15:06
by rjversluis
Hi Ronald,

I changed the behaviour of the V2 option in revision 3256.
If "Elite" is selected and V2 is checked the protver is set to 1.

Posted: 12.02.2012, 15:27
by ron&bram
:thumb_up: I will change the wiki.

Posted: 13.02.2012, 10:08
Hi Ron/Rob
I loaded 3259 and tested again.

Manually selecting track power on/off/on is OK. The track powers up/down/up.

With Elite in Standard mode and V2 not selected the points operated to plan, 1 fires 1, 2 fires 2, 3 fires 3, etc, but no loco control, except for functions (lights work but no throttle response).

Of interest when Standard mode is selected and V2 is also selected, as expected the points operate offset, 4 fires 1, 5 fires 2, etc. This is to be expected.

With Elite in Classic mode and V2 selected the points operated to plan, 1 fires 1, 2 fires 2, 3 fires 3, etc, but again no loco control except for lights.

I checked each time that selecting/deselecting V2 echoed into the .ini file protver value OK

The usual files attached. You may see an error where the points fired wrong in Standard mode V2 not selected in the middle part of the test. This was because I forgot to save, stop and restart before that test.

So far so good, just the locos to fix.
Thanks, Rob

Posted: 13.02.2012, 15:44
by ron&bram
@Rob Versluis.

Rob, I checked the plan file, different locs do have different decoder addresses. But somehow, when sending a speed command, the trace in line 490 of xpressnet.c always gives address 0, regardless of the loc.

Code: Select all

OXpressN 0490 loc 0 velocity=0 direction=rev
At the moment I fail to see why.

Posted: 13.02.2012, 16:01
Is address 0 not the dc (analogue) address for a loco.

Posted: 13.02.2012, 16:13
by ron&bram
Hi Rob,

one the locs in the trace file has decoder address 2, another 56. I would have expected to see these addresses in the trace line and not 0 for both locs.

Posted: 13.02.2012, 16:25
Hi Ron
Addresses 2 and 56 were the 2 locs I was using, except they weren't answering throttle, but the Class 56 lights were working (F0) and direction changes were obviously effective as the lights swapped ends.

Solved - Hornby Elite Classic/Standard Modes

Posted: 15.02.2012, 14:30
Hi Ron/Rob
All fixed with rev 3265. :D :D :D
Locos and points operate correctly in either Classic or Standard modes using V2 option with controller set as Elite.
An excellent solution to my request.
Many thanks for your efforts.

Further problems with Elite Standard / Classic mode.

Posted: 28.04.2013, 12:07
I have been out of the Rocrail update loop for some time due to a dead train pc, but recently loaded rev 5093 onto Win8 - 64 bit.
Expecting Rocrail to recognise and use my workspace as with previous updates I started Rocrail up after the update using the Rocview.exe, but my plan didn't load and the application stalled. I got a trace file (000) of that event and aborted.
I then started Rocrail up using rocrail exe then rocview exe and after designating my workspace my plan loaded ok. Loco and switch tables, etc were all there.
I have the Elite in Standard mode and V2 is not ticked on the controller screen, but all I can control is loco direction and speed and functions. Switches do not work - same as the problem previously fixed by rev 3265.
If I change the Elite to Classic mode and tick V2 I can control locs and switches with no problems.
Plan, trace and ini files attached manually. (Issue reporting from the UI does not seem to do this for me).
Thanks Rob

Posted: 28.04.2013, 13:22
by rjversluis
Hi Rob,

both the workspaces and the Eleite v2 issue are unchanged.
Maybe your Rocrail install is mixed up.