MacOSX build instructions

rjversluis
Site Admin
Posts: 42383
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Post by rjversluis » 16.10.2010, 08:54

Hi Bernd,

the server is not gone but is started with a workspace:
http://wiki.rocrail.net/doku.php?id=workspaces-en

bernd68
Posts: 455
Joined: 07.09.2010, 17:34

Post by bernd68 » 16.10.2010, 16:18

Hi Rob,

I tested it with success :) And i switch "load workspace at program start" to "on" in Rocview preferences. Now both - Rocrail _and_ Rocview - starts together.

thanks Bernd

bernd68
Posts: 455
Joined: 07.09.2010, 17:34

Post by bernd68 » 22.10.2010, 20:34

I have a new question.
My testlayout runs with Rocrail 1.4.999 (Revision 1709) from juli 1. 2010. I try to run newer versions on my MAC, no one runs (opens and stop immediatly without any output on my screen). I have MACOSX 10.6.4. I tried rocrail 2.0.0 rev 1940 and rocrail 2.0.0. rev 2084 .
I'll use 1.4.999 - it runs until now without any problem for me :)

Gruß
Bernd

rjversluis
Site Admin
Posts: 42383
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Post by rjversluis » 22.10.2010, 21:06

Hi Bernd,

I'm using for my Plan-F always the latest revision of Rocrail on may Mac Mini because I'm a developer.
Besides the 64bit wxWidgets OS X problems I can not follow your depicted issues.
First you report success, and later you report disaster.
There are more Snow Leopard users in this forum so I will leave further replies to them.

bernd68
Posts: 455
Joined: 07.09.2010, 17:34

Post by bernd68 » 22.10.2010, 21:50

rjversluis wrote:Hi Bernd,

First you report success, and later you report disaster.
There are more Snow Leopard users in this forum so I will leave further replies to them.
Hi,
a vew days ago I install 1.4.999 and use it with success :D Than I read about later versions and I try to install and run 1940 and 2084. Install is ok, run doesn't work. A short reaction of the Programmsymbol but no window of Rocview. I'll try it on another MAC - I have an older (Mac OSX 10.6.4 - 1,83 GHz Intel Core Duo,Modell-Identifizierung: iMac4,1) one for my railroad (and Rocview) and a new one (Mac OSX 10.6.4 - 2.8 GHz Intel Core i7,Modell-Identifizierung: iMac11,1) for other things.
I will report ..

thanks
Bernd

bernd68
Posts: 455
Joined: 07.09.2010, 17:34

Post by bernd68 » 22.10.2010, 21:59

Hi Rob,
my old iMac is a 32 Bit and the new ist a 64 bit one :idea:

Could be this is the reason.

beste Grüße
Bernd

rjversluis
Site Admin
Posts: 42383
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Post by rjversluis » 23.10.2010, 07:27

Hi Bernd,

Snow Leopard is 64 bit.
I have no 32 bit system available to build a 32 bit Rocrail version, only a Mac Mini G4 PPC. On this system I could cross compile for 32 bit Intel, but this would need some investigation.

bernd68
Posts: 455
Joined: 07.09.2010, 17:34

Post by bernd68 » 23.10.2010, 08:45

Hi Rob,
I can use version 1.4.999 - no problem. May be I can (in the future) "make" a 32bit version. I haven't done this before ...

beste Grüße
Bernd

rjversluis
Site Admin
Posts: 42383
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Post by rjversluis » 23.10.2010, 08:58

Hi Bernd,

to build Rocrail on a Mac is easy.
I will support you if you start.

It is also documented:
http://wiki.rocrail.net/doku.php?id=cmac-en

bernd68
Posts: 455
Joined: 07.09.2010, 17:34

Post by bernd68 » 23.10.2010, 09:05

Hi Rob,

I think I have time to do this next week, I am a pensioner (Rentner). Today and tomorrow the family will be in the foreground :-)

nette Grüße
Bernd

bernd68
Posts: 455
Joined: 07.09.2010, 17:34

Post by bernd68 » 26.10.2010, 15:30

Hi Rob,
I start and install Xcode from MacOSX CD, Bazaar 2.2.1 and wxMac-2.8.11. Then I follow the instrucions
cd wxMac-2-8-11
mkdir macbuild
cd macbuild
../configure .....
make
sudo make install

and receive a lot of output.
I can send this messages to you or you give me a hint what to do (better). But I can continue tomorrow. Today I'll go to a friend in Dortmund playing with our Märklin-RR :D

Grüße
Bernd

rjversluis
Site Admin
Posts: 42383
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Post by rjversluis » 27.10.2010, 11:36

Hi Bernd,

looks promising. :)
The loads of output is normal.
Just proceed with the next steps.

bernd68
Posts: 455
Joined: 07.09.2010, 17:34

Post by bernd68 » 28.10.2010, 16:31

Hi Rob,
there are more questions than answers.
I need an directory "rocrail" or "Rocrail" ? In subdirectory macbuild or where ?
I must load "makemac.sh" from "http://bazaar.launchpad.net/~rocrail-pr ... makemac.sh" ?
I have to load the source from "https://code.launchpad.net/rocrail" ?

All (ore more) files had to store into macbuild or rocrail ?

To do this the first time is not easy - be patient (I'm willing)

edit
just I see bzr checkout will create "Rocrail". Do I call "bzr ..." from "macbuild"?
Grüße
Bernd

treinbert

Directory of Rocrail

Post by treinbert » 31.10.2010, 16:43

Hi Bernd,

I also just downloaded XCode, Bazaar and wxWidget. I am running a MacMini (Intel) with 10.6.4
I just created a directory Bazaar under my Documents. I started bazaar from that directory, which creates a directory rocrail. In that directory I started makemac.sh, wich created a directory package. There is the dmg-file, which can be opened and the contents be put into the proper place. I put it into /Applications/RocRail.

I only got the GUI and not the server. I am using the server on another machine at the moment. I have another small issue with the look of the blocks, but I think it is due to the fact, that I used wxWidget 2.9.1 rather than 2.8.1 As I recall 2.9.1 is not recommended by Rob.

Kind regards,
Bert

rjversluis
Site Admin
Posts: 42383
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Post by rjversluis » 31.10.2010, 17:13


Post Reply

Return to “Documentation”