Einstellung der Loks

Re: Einstellung der Loks

Postby rjversluis » 10.10.2018, 16:03

Moin,

Über Kontext Menüs kann man jeder Zeit die Platzierungslogic wechseln.
Also, wo liegt das Problem?
Ich kann ohne Probleme diese Flag wieder sichtbar machen in der Lokeigenschaften, aber dazu sollten sich die Benutzer Melden welche gefragt haben diese Flag dort zu entfernen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: Einstellung der Loks

Postby GeSchu » 10.10.2018, 17:43

Moin Jürgen,
polopoly wrote:Hallo Leute,
ich habe auch ein Problem mit der Fahrtrichtung.
........
Was kann man machen?

Hast Du die Vorgehensweise, so wie Peter und ich es beschrieben haben, gelesen? Bevor du die Loks in die Doppeltraktion gegeben hast, hast Du da die Fahrtrichtung jeder Lok einzeln korrekt eingestellt und überprüft? Stichwort von Rob: Plazierung ändern.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Einstellung der Loks

Postby AndKie » 10.10.2018, 18:05

GeSchu wrote:Moin Jürgen,
polopoly wrote:Hallo Leute,
ich habe auch ein Problem mit der Fahrtrichtung.
........
Was kann man machen?

Hast Du die Vorgehensweise, so wie Peter und ich es beschrieben haben, gelesen? Bevor du die Loks in die Doppeltraktion gegeben hast, hast Du da die Fahrtrichtung jeder Lok einzeln korrekt eingestellt und überprüft? Stichwort von Rob: Plazierung ändern.
Gruß
Gerd(GeSchu)



Hallo Gerd,
ich kann schon nachvollziehen und verstehen was er, bezogen auf Doppeltraktion meint, denn ich habe auch gerne wieder das Problem dass ich aufgrund der Erfahrungen die Platzierung vorher tausche, aber in dem Moment wo die Doppeltraktion aktiv wird, die Fahrtrichtung der einen Lok sich doch wieder ändert. Also im muss ich immer mal wieder probieren bis es dann klappt.
Wird die Spannung, Fahrspannung abgestellt und später wieder angestellt, geht alles von neuem los.

Gruß
Andreas
OpenSuse Leap 15.0, H0, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: Einstellung der Loks

Postby Schorse » 10.10.2018, 18:28

Hi Rob,

Ich kann ohne Probleme diese Flag wieder sichtbar machen in der Lokeigenschaften, aber dazu sollten sich die Benutzer Melden welche gefragt haben diese Flag dort zu entfernen.
Es sollte entfernt bleiben. Ich denke einem Einsteiger wird eine weitere Schaltstelle nicht weiterhelfen sondern mehr Verwirrung stiften.
Es ist ja entfernt worden weil User damit Probeme hatten.
Viele Grüße Gerd
Schorse
 

Re: Einstellung der Loks

Postby GeSchu » 10.10.2018, 18:30

Moin Andreas,
okay, dann muss man die Quelle des Ungemachs suchen. Ich gehe mal davon aus:
- Lok A und B sollen in Doppeltraktion fahren
- Die Decoder sind in beiden Loks richtig konfiguriert, will sagen: Lok A und B fahren in die richtige definierte Richtung.
- Lok A fährt in Rocrail in der richtige Richtung. Mit der Lokmaus gefahren fährt das Fahrzeug richtig in der gleichen Richtung.
- Lok B hat die gleichen Voraussetzungen.
- Beide Loks sind also korrekt eingestellt.
- Die Fahrzeuge werden jetzt in die Doppeltraktion gesetzt. Ein Fahrzeug fährt jetzt falsch.
Ich würde den Fehler jetzt in dieser (Doppeltraktion)Konfiguration suchen.
Gruß Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Einstellung der Loks

Postby AndKie » 10.10.2018, 18:49

Hallo Gerd,

ja ich habe da auch schon einiges durchprobiert, als das was du beschrieben hast hatte ich durch und berücksichtigt:
In der Vergangenheit hatte ich diesbezüglich auch schon mal ein Tread im Forum erzeugt.
Anfangs hatte die Probleme erst auf die Zentrale geschoben, canGC3, aber nein es kommt gerne immer wieder vor auch mit der DR5000, das auch durch den Trick mit Platzierung tauschen die Fahrtrichtung der zweiten Lok dann doch wieder nicht stimmt.

Gruß
Andreas
OpenSuse Leap 15.0, H0, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: Einstellung der Loks

Postby RainerK » 10.10.2018, 19:07

Hallo zusammen,

wenn die Hardware-Konfiguratiopn (Dekoder-Setup und/oder Motoranschlüsse) einer Lok falsch ist,
dann muss das dort korrigiert werden wo der Fehler ist.
Das habe ich weiter oben schon beschrieben: viewtopic.php?p=178747#p178747

Die Aufgabe des Setzens und Umschaltens der Platzierung ist ausschließlich während des Betriebs von Rocrail akzeptabel,
z.B. bei Fahrtrichtungs-Änderungen, Umsetzen der Lok usw.

Oben erwähnte Hardware-Fehler durch Verbiegen der Platzierung zu verschlimmbessern ist inakzeptabel.

Die Platzierungs-Option aus den Lok-Eigenschaften zu entfernen war die lange überfällige Konsequenz,
um zu verhindern, dass diese Option weiterhin als Krücke für das Kaschieren von Fehlern an anderer Stelle mißbraucht wird.
Platzierung ist keine Eigenschaft, sondern ein Status.

Wenn sich eine betrieblich eingestellte Platzierung bei der Bildung der Doppeltraktion von allein ändert, ist das IMHO nicht richtig.
Best Regards, es grüßt RainerK

Win10 64Bit / DCC++ with Arduino Uno / Motor shield and LocoNet GCA85, 50, 93 and 136.
Special interests: DIY electronic assemblies. http://www.rainermoba.blogspot.com
Planning replace the coincidence by the mistake
RainerK
 

Re: Einstellung der Loks

Postby GeSchu » 10.10.2018, 19:30

Moin zusammen,
RainerK wrote:wenn die Hardware-Konfiguratiopn (Dekoder-Setup und/oder Motoranschlüsse) einer Lok falsch ist,
dann muss das dort korrigiert werden wo der Fehler ist.

und
GeSchu wrote: - Die Decoder sind in beiden Loks richtig konfiguriert, will sagen: Lok A und B fahren in die richtige definierte Richtung.

bedeutet:
Stellt eure Decoder richtig ein und dann werden auch die Loks richtig fahren. Los gehts ....
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Einstellung der Loks

Postby polopoly » 10.10.2018, 21:06

Hallo alle,

beide Loks hatten dieselbe Richtung bevor ich sie in Mehrfachtraktion gepackt habe. Jetzt habe ich begriffen wo der haken hin muss. Jetzt bekomme ich weitere Probleme. Wenn ich die zweite Lok eingebe wird sie nicht mehr gespeichert. Nicht mit übernehmen nicht mit ok.
Wenn ich den Editor auf mache, dann schließe fragt er “ speichern?“ klick auf ja und die Lok fliegt raus. Pause bei Richtungswechsel gebe ich 4000 ein macht aber nichts 6000 auch nicht.
Wo lese ich denn das die Mehrfachtraktion eingegeben ist und müsst ich nicht auch im Editor die Zahl 4000 finden?

Jürgen
polopoly
 

Re: Einstellung der Loks

Postby GeSchu » 11.10.2018, 09:29

Moin Jürgen,
also für mich sprichst Du in Rätseln. Beschreibe doch bitte mal Schritt für Schritt, was genau du
erstens erreichen möchtest und zweitens welchen weg du genau nimmst, um Dein Ziel zu erreichen. Dazu gehört dann auch ein issue File, damit wir anhand Deiner Situation alles gut nachvollziehen können.
Vielleicht verstehe zumindest ich Dein Vorhaben dann besser.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Previous

Return to Allgemein (DE)