[erl] Forum HTTPS anstatt HTTP

Re: [erl] Forum HTTPS anstatt HTTP

Postby rjversluis » 19.06.2018, 10:58

Moin Experten,

wenn ich mittels ein Symbolische Link so das Wiki erreiche:
Code: Select all
https://forum.rocrail.net/wiki

Ist es nicht sicher. Probiere es mal.
Frage: Warum nicht? Es liegt doch unterhalb das sichere Forum...
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: [erl] Forum HTTPS anstatt HTTP

Postby minou65 » 19.06.2018, 11:16

Hallo Rob

rjversluis wrote:Moin Andy,

meinst du so was:
https://www.df.eu/forum/threads/68780-HTTPS-Verschlüsselung-Umleitung-des-Webaufrufes-von-http-auf-https-per-htaccess

Nachtrag: Ich habe es so angepasst und jetzt wird http automatisch umgeleitet auf https.


ja genau, klappt bei mir mit Edge wunderbar.


rjversluis wrote:Moin Experten,wenn ich mittels ein Symbolische Link so das Wiki erreiche:Code: Alles auswählenhttps://forum.rocrail.net/wikiIst es nicht sicher. Probiere es mal.Frage: Warum nicht? Es liegt doch unterhalb das sichere Forum...

Der Symbolische Link zeigt auf eine "externe" Adresse die in Wirklichkeit keine Subsite von forum.rocrail.net ist. Wenn das funktionieren würde könntest du das ganze Internet mit deinem Zertifikat sicher machen :mrgreen:

Eventuell muss man halt doch ein Zertifikat auf rocrail.net machen und dann wiki und forum als Subsites in diese Domain schieben. Aber wie schon geschrieben. Damit werden sämtliche Links nicht mehr funktionieren. Ausser man kann mit htaccess diese forwarding auch in einen neuen Namespace machen. Aber das habe ich noch nie gemacht.

Gruss
Andy
Märklin K-Gleis, OpenDCC Z1, DCC++, rocrail Server auf Raspi, 4x Rocnetnode, div. GCA Bausätze, Win10 Client, iPad Client
minou65
 

Re: [erl] Forum HTTPS anstatt HTTP

Postby rjversluis » 19.06.2018, 11:31

Hi Andy,

Chrome mein da zu folgendes:
chrome-wiki.png

Vielleicht reicht das schon für die Wiki Autoren?
You do not have the required permissions to view the files attached to this post.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: [erl] Forum HTTPS anstatt HTTP

Postby GeSchu » 19.06.2018, 11:50

Moin Uwe,
Zilli wrote:Du reitest immer sehr darauf herum, dass das alles nicht so genau genommen werden muss,

Nicht richtig gelesen, oder? Da steht:
GeSchu wrote:Rob: Lass das WIki wie es ist. Du hast recht, es liegt in jedem Leser seiner Verantwortung selbst Weil: Das WIKI ist nur ein Informationsmedium ohne Interaktion mit dem Leser. Lass dich nicht kirre machen.

Zilli wrote:das ist eine falsche Ansicht.

Wenn das meine Ansicht wäre, hättest Du recht.

Nebenbei: Ich stehe zu meiner Meinung. Allerdings lasse ich die nicht verdrehen.
Und:
Auch ich bin der Meinung, das der HTTPS Zugang nicht der schlechteste Ansatz ist. Nochmal: Lasst euch nicht kirre machen, oder Eile mit Weile. Kluge Sprüche? Ich glaube nicht.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: [erl] Forum HTTPS anstatt HTTP

Postby GeSchu » 19.06.2018, 11:54

Moin Rob,
ich kann natürlich nur für mich sprechen:
rjversluis wrote:Vielleicht reicht das schon für die Wiki Autoren?

Ich finde das ausreichend. Ob meine Meinung dazu ausreichend ist?
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: [erl] Forum HTTPS anstatt HTTP

Postby RainerK » 19.06.2018, 11:58

Hallo Rob,

mir wird schlecht, wenn ich daran denke, wie viele Querverweise auch innerhalb des Wiki vollqualifiziert definiert sind.
Davon habe ich zwar schon viele auf den Wiki-Standard reduziert, wenn sie mir begegnen,
aber die Dunkelziffer... :roll:
Best Regards, es grüßt RainerK

DCC++ with Arduino Uno / Motor shield and LocoNet GCA85, 50, 93 and 136. Special interests: DIY electronic assemblies. http://www.rainermoba.blogspot.com
Planning replace the coincidence by the mistake
RainerK
 

Re: [erl] Forum HTTPS anstatt HTTP

Postby cds » 19.06.2018, 12:12

Hallo Rainer!

Ja, ich verwende vollqualifizierte Links. Nicht, weil ich das so will, sondern weil ich anders nicht klar komme :oops:
Ich habe es oft probiert, oft gingen die Links ins Leere ...

Sollte umgestellt werden, ändere ich die Links selbst. Musst nicht alles du machen.
Beste Grüße/Kind regards
Claus

M* H0 M
HW: TAMS MC, B-2 & B-4, WD-34, VIESSMANN 5211(1), LITTFINSKY & TAMS S88-3
Decoder: Mä & TAMS (MM2)
SW: Win7 64, RR 64, andRoc
cds
 

Re: [erl] Forum HTTPS anstatt HTTP

Postby GeSchu » 19.06.2018, 12:18

Moin Rainer,
cds wrote:Sollte umgestellt werden, ändere ich die Links selbst. Musst nicht alles du machen.

Me Too .....
gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: [erl] Forum HTTPS anstatt HTTP

Postby RainerK » 19.06.2018, 13:19

Hallo Claus,

AFAIK sind häufige Gründe für Probleme bei Wiki-Links ein Fehler bei der Angabe des Ziel-Namespace und/oder das Fehlen des führenden ":" als Root-Bezug.
Best Regards, es grüßt RainerK

DCC++ with Arduino Uno / Motor shield and LocoNet GCA85, 50, 93 and 136. Special interests: DIY electronic assemblies. http://www.rainermoba.blogspot.com
Planning replace the coincidence by the mistake
RainerK
 

Re: [erl] Forum HTTPS anstatt HTTP

Postby rjversluis » 19.06.2018, 13:30

Hallo,

es geht nicht um das Wiki Lesen, sondern um die Autoren zu schützen ohne das noch ein Zertifikat her muss.

Wiki lesen:
Code: Select all
http://wiki.rocrail.net


Freiwillig beim Wiki schreiben/Einloggen:
Code: Select all
https://forum.rocrail.net/wiki
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: [erl] Forum HTTPS anstatt HTTP

Postby RainerK » 19.06.2018, 16:37

Hallo Rob,

Anmeldung über https://forum.rocrail.net/wiki/ und Öffnen des Wiki-Editor i.O.

Aber die Symbole des Editors werden nur als Platzhalter angezeigt.
Chrome, FF, und Edge verhalten sich gleich, nur die Optik der Platzhalter ist unterschiedlich.

wiki-editor-icons.png
You do not have the required permissions to view the files attached to this post.
Best Regards, es grüßt RainerK

DCC++ with Arduino Uno / Motor shield and LocoNet GCA85, 50, 93 and 136. Special interests: DIY electronic assemblies. http://www.rainermoba.blogspot.com
Planning replace the coincidence by the mistake
RainerK
 

Re: [erl] Forum HTTPS anstatt HTTP

Postby GeSchu » 19.06.2018, 16:44

Moin Rainer,
Moin Rob,
Entschuldigung, ich habe die Fotos wieder gelöscht, weil: wiki sieht aus wie Rainer schrieb. ich war zu voreilig.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: [erl] Forum HTTPS anstatt HTTP

Postby rjversluis » 19.06.2018, 16:59

OK,

der Symbolische Link habe ich wieder entfernt; Keine gute Lösung um 24 Euro zu sparen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: [erl] Forum HTTPS anstatt HTTP

Postby cds » 25.06.2018, 13:09

Hallo Rob!

Fyi:
Fehlermeldung Browser Chrome.jpg

Hab' das Problem nur ich?

W7 64 Enterprise, Chrome Version 67.0.3396.87 (Offizieller Build) (64-Bit)
You do not have the required permissions to view the files attached to this post.
Beste Grüße/Kind regards
Claus

M* H0 M
HW: TAMS MC, B-2 & B-4, WD-34, VIESSMANN 5211(1), LITTFINSKY & TAMS S88-3
Decoder: Mä & TAMS (MM2)
SW: Win7 64, RR 64, andRoc
cds
 

Re: [erl] Forum HTTPS anstatt HTTP

Postby rjversluis » 25.06.2018, 14:06

Hallo Claus,

was sagt diese Test dazu?

https://www.sslshopper.com/ssl-checker. ... crail.net/
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

PreviousNext

Return to Allgemein (DE)

cron