Fehler beim Abspielen von Sounds

Post Reply
risernhagen
Posts: 43
Joined: 09.04.2009, 17:41

Fehler beim Abspielen von Sounds

Post by risernhagen » 06.12.2018, 17:10

Hallo Rocrail Freunde,

ich habe kürzlich ein Upgrade von Version 13881(32bit) auf 14644(64bit) vorgenommen. Seitdem erhalte ich die in der angehängten Trace Datei dokumentierte Fehlermeldung.
Der aufgerufene Sound wird problemlos abgespielt!

Hat jemand eine Idee, an was das liegen könnte?
Ist eine Inkompatibilität zwischen Rocrail 64bit und "sndrec32" denkbar?
Rocrail läuft bei mir unter Win7 64bit.

Ich bin gespannt auf Eure Ideen.
Gruß Rudi.

risernhagen
Posts: 43
Joined: 09.04.2009, 17:41

Re: Fehler beim Abspielen von Sounds

Post by risernhagen » 06.12.2018, 17:15

Sorry beim ersten Mal sind die Dateien nicht mitgekommen.

Gruß Rudi
Sound.trc
Lokomotiven.xml
Lindental.xml
You do not have the required permissions to view the files attached to this post.

Pirat-Kapitan
Moderator
Posts: 4615
Joined: 06.02.2010, 15:46
Location: Rösrath bei Köln / Germany

Re: Fehler beim Abspielen von Sounds

Post by Pirat-Kapitan » 06.12.2018, 19:06

Moin Rudi,
hast Du mal in den vergangenen Berichten des Forums gesucht? ich meine dort von einer Unverträglichkeit des Soundrecoders mit 64Bit versionen gelesen zu haben. Fundstelle habe ich leider nicht parat. (ist nicht mein Primärbereich)

Schöne Grüße
johannes

M_C_nl
Posts: 336
Joined: 11.09.2010, 23:16
Location: Aachen/Germany

Re: Fehler beim Abspielen von Sounds

Post by M_C_nl » 06.12.2018, 19:34

Hallo Rudi,

ich habe mir den sndrec32 auch aus Windows7 32-bit nach Windows10 64-bit rüber kopiert. Er funktioniert unter Win10, allerdings erhalte ich bei Aufruf die angehängte Fehlermeldung:

"Beim Aktualisieren der Registrierung ist ein Fehler aufgetreten."

Vielleicht kommt diese auch bei dir beim Aufruf innerhalb von Rocrail.

Wie geschrieben, die Funktionalität ist gegeben.

Mit Rocrailgrüßen,
:rr_for_ever:
Maxel :-)

peter&basti
Moderator
Posts: 5719
Joined: 09.01.2012, 22:09
Location: Vienna, Austria

Re: Fehler beim Abspielen von Sounds

Post by peter&basti » 06.12.2018, 19:50

Hallo Rudi,

es wäre aber auch kein Problem, von Rocrail 64 Bit auf Rocrail 32 Bit zurückzukehren.
RR 64 Bit bringt gegenüber RR 32 Bit aktuell keinen Mehrwert, außer dass es den doppelten Speicherbedarf hat :wink:

risernhagen
Posts: 43
Joined: 09.04.2009, 17:41

Re: Fehler beim Abspielen von Sounds

Post by risernhagen » 07.12.2018, 14:30

Moin und Dank Euch allen!

Ich werde in den nächsten Tagen wieder zurück auf 32 bit gehen, und dann hier kurz berichten.

Gruß Rudi.

risernhagen
Posts: 43
Joined: 09.04.2009, 17:41

Re: Fehler beim Abspielen von Sounds

Post by risernhagen » 10.12.2018, 17:11

Hallo Rocrail Freunde,

ich habe den Sound Test jetzt auch mit Version 14654(32bit) durchgeführt. Es treten auch im 32bit-Fall die im Trace oben dokumentierten Fehlermeldungen auf, obwohl ein wirklicher Fehler nicht zu bemerken ist,
da die Sounds korrekt abgespielt werden.
Es kann sich also nicht um eine Inkompatibilität von sndrec32 mit 64bit Versionen von Rocrail handeln!

Ich vermute, dass eine Code-Änderung in einer Version oberhalb von 13881(32bit) zum Auftreten besagter Fehlermeldung führt.

Gruß Rudi.

ups60
Posts: 911
Joined: 30.07.2013, 17:36
Location: 50321 Brühl

Re: Fehler beim Abspielen von Sounds

Post by ups60 » 10.12.2018, 17:24

Hi Rudi,

starte soundrec 1-mal als Admin, danach waren bei mir die Fehlermeldungen weg.

mfg Uwe

Post Reply

Return to “Basisfunktionalität (DE)”