[erl] OpenSUSE 42.3 64 Bit fehlt

[erl] OpenSUSE 42.3 64 Bit fehlt

Postby AndKie » 12.07.2018, 07:26

Hallo Gemeinde,

Nur eine Frage:
Was ist das für ein Release - "Open Suse Leap 15 64bit", im Downloadbereich?
Bei der Installation ergab es in Rocview 13088.
Funktionseinschränkungen hatte ich aber bislang keine feststellen müssen.

Gruß
Andreas
Last edited by AndKie on 12.07.2018, 17:43, edited 1 time in total.
OpenSuse Leap 15.0, H0, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: OpenSUSE 42.3 64 Bit fehlt

Postby rjversluis » 12.07.2018, 07:33

Hi Andreas,

das ist der aktuelle OpenSuse Leap Version:
https://software.opensuse.org/distributions/leap

BTW: Rocview sollte 14088 anzeigen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: OpenSUSE 42.3 64 Bit fehlt

Postby AndKie » 12.07.2018, 08:18

rjversluis wrote:Hi Andreas,

das ist der aktuelle OpenSuse Leap Version:
https://software.opensuse.org/distributions/leap

BTW: Rocview sollte 14088 anzeigen.


Ja o.k., wie OpenSUSE xxx sich nennt ist mir auch letztlich egal, SuSE bastelt da oft an den Release- Bezeichnungen herum, aber in Rocview wird 13088 angezeigt, deshalb war ich verwirrt. :D

Gruß
Andreas
OpenSuse Leap 15.0, H0, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: OpenSUSE 42.3 64 Bit fehlt

Postby rjversluis » 12.07.2018, 08:24

Moin Andreas,

wenn da 13088 angezeigt wird kannst du besser verzichten auf dieses Paket.

Ich überprüfe es nachher, muss 14088 sein.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: OpenSUSE 42.3 64 Bit fehlt

Postby AndKie » 12.07.2018, 08:31

rjversluis wrote:Moin Andreas,

wenn da 13088 angezeigt wird kannst du besser verzichten auf dieses Paket.

Ich überprüfe es nachher, muss 14088 sein.


Hallo Rob,
es ist sogar noch schlimmer, ich hatte die genauen Daten von gestern nicht mehr im Kopf, habe die Anlage gerade eben hochgefahren und hänge mal einen Rembrandt an, dann siehst du was da steht.

May 21 2018 revision 13981 [LOCAL]
You do not have the required permissions to view the files attached to this post.
OpenSuse Leap 15.0, H0, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: OpenSUSE 42.3 64 Bit fehlt

Postby rjversluis » 12.07.2018, 09:25

Bei dir ist was schief gelaufen.
Nachdem ich es installiert habe sieht es so aus:
leap15.png

Also, Rocview und Rocrail haben beide 14088.
You do not have the required permissions to view the files attached to this post.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: OpenSUSE 42.3 64 Bit fehlt

Postby AndKie » 12.07.2018, 10:13

rjversluis wrote:Bei dir ist was schief gelaufen.
Nachdem ich es installiert habe sieht es so aus:
leap15.png

Also, Rocview und Rocrail haben beide 14088.


Ich kann es nochmals versuchen. Die Installation mache ich über Yast, bislang ohne Probleme.

Gruß
Andreas
OpenSuse Leap 15.0, H0, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: OpenSUSE 42.3 64 Bit fehlt

Postby AndKie » 12.07.2018, 10:30

Hallo Rob,

Frage: Mit welcher Suse Version hast du die Installation versucht, oder getestet, ich habe ja immer noch OpenSuSE Leap 42.3 64Bit und da kann ich machen was ich will es kommt das Gleiche dabei heraus.
Auf der Konsole meckert dass System sämtliche libwx
---------------------------------------------------------------------------------------------------------
Code: Select all
Failed dependencies:
        libwx_baseu-suse.so.3()(64bit) is needed by rocrail-opensuse_leap15-14088.x86_64
        libwx_baseu-suse.so.3(WXU_3.0)(64bit) is needed by rocrail-opensuse_leap15-14088.x86_64
        libwx_baseu_net-suse.so.3()(64bit) is needed by rocrail-opensuse_leap15-14088.x86_64
        libwx_baseu_xml-suse.so.3()(64bit) is needed by rocrail-opensuse_leap15-14088.x86_64
        libwx_gtk2u_adv-suse.so.3()(64bit) is needed by rocrail-opensuse_leap15-14088.x86_64
        libwx_gtk2u_adv-suse.so.3(WXU_3.0)(64bit) is needed by rocrail-opensuse_leap15-14088.x86_64
        libwx_gtk2u_core-suse.so.3()(64bit) is needed by rocrail-opensuse_leap15-14088.x86_64
        libwx_gtk2u_core-suse.so.3(WXU_3.0)(64bit) is needed by rocrail-opensuse_leap15-14088.x86_64
        libwx_gtk2u_html-suse.so.3()(64bit) is needed by rocrail-opensuse_leap15-14088.x86_64
        libwx_gtk2u_html-suse.so.3(WXU_3.0)(64bit) is needed by rocrail-opensuse_leap15-14088.x86_64
        libwx_gtk2u_qa-suse.so.3()(64bit) is needed by rocrail-opensuse_leap15-14088.x86_64
        libwx_gtk2u_xrc-suse.so.3()(64bit) is needed by rocrail-opensuse_leap15-14088.x86_64
------------------------------------------------------------------------------------------------------------------------------------------------
an.

Gruß
Andreas
OpenSuse Leap 15.0, H0, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: OpenSUSE 42.3 64 Bit fehlt

Postby rjversluis » 12.07.2018, 10:44

Hi Andreas,

mit Leap 15.

Vielleicht muss du mal dein System updaten.
Oder der wxWidgets Library passt nicht.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: OpenSUSE 42.3 64 Bit fehlt

Postby GeSchu » 12.07.2018, 10:49

Moin Andreas,
AndKie wrote:Auf der Konsole meckert dass System sämtliche libwx
---------------------------------------------------------------------------------------------------------
Failed dependencies:

Das bedeutet doch, frei übersetzt: Fehlende Abhängigkeiten. Ich bin zwar kein SuSE Fan, das Vorhaben sollte jedoch RedHat oder UBUNTU ähnlich sein.
Was hälst du davon, die fehlenden Abhängigkeiten aufzulösen, in dem Du die fehlenden Librarys einfach nachinstallierst? Wenn es nicht per yast gehen sollte, gibt es ja noch rpm.

oder, wie Rob gerade schrieb: Update des Systemes

Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: OpenSUSE 42.3 64 Bit fehlt

Postby rjversluis » 12.07.2018, 11:14

Hallo Andreas,

hast du vielleicht wxWidgets 3.2 installiert? (Vielleicht hatte ich versehentlich bei 42.3 wx3.2 installiert...)
3.2 gibt es offiziell nicht.
3.0 muss installiert sein.
Der Debian Package Manager löst diese Probleme automatisch auf.

RPM ist nicht mein Ding. Ist sehr umständlich um ein Installer Package her zu stellen.

[smalltalk]
Mein Letzte Suse Versuch war für zirka 20 Jahre her mit 12 oder 20 Diskettes. :thumb_up:
Heut zu Tage läuft es nur im VirtualBox unter macOS.
[/smalltalk]
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: OpenSUSE 42.3 64 Bit fehlt

Postby AndKie » 12.07.2018, 12:51

Hallo Rob & Co.,

Danke erst mal für die vielen Hinweise und Tipps, ich habe alles was mit Rocrail zu tun hat, (Verzeichnisse), auf dem Rechner gelöscht, aber egal was ich mache, Neuinstallation von Rocrail, es kommt ständig:
May 21 2018 revision 13981 [LOCAL] als Versionsanzeige!

Ob dies alles mit den Wx 3.0- Container zu tun haben sollte, da habe ich meine Zweifel, den Rocview startet ja, allerdings mit dieser alten Versionsangabe.

Gruß
Andreas
You do not have the required permissions to view the files attached to this post.
OpenSuse Leap 15.0, H0, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: OpenSUSE 42.3 64 Bit fehlt

Postby rjversluis » 12.07.2018, 13:04

Hi Andreas,

wenn es diese Meldung gibt:
Code: Select all
Failed dependencies:

dann wird die neue Software NICHT installiert. Also, dann gibt es noch immer eine Vorgänger Revision.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: OpenSUSE 42.3 64 Bit fehlt

Postby AndKie » 12.07.2018, 13:24

rjversluis wrote:Hi Andreas,

wenn es diese Meldung gibt:
Code: Select all
Failed dependencies:

dann wird die neue Software NICHT installiert. Also, dann gibt es noch immer eine Vorgänger Revision.


Ja, stimmt, das sehe ich auch so, allerdings hatte ich alle Rocrailverzeichnisse gelöscht, auch tmp, ja sogar den Mülleimer, ich habe keine Ahnung wo der alte Mist herkommt.

Gruß
Andreas
OpenSuse Leap 15.0, H0, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: OpenSUSE 42.3 64 Bit fehlt

Postby GeSchu » 12.07.2018, 13:42

Hallo Andreas,
wir sind hier nicht bei dem bekannten und meistverkauften OS aus Redmond. Wir sind bei einem Linux Derivat. Da deinstalliert und installiert man nicht andauernd neu. Das ist doch keine logische Fehlerfindung.
Entschuldige bitte, das ich mich wiederhole: Auch auf einem betagten Linux System können alte oder neuere Libs nachinstalliert werden.
Nochmal: Abhängigkeiten auflösen (Failed dependencies). Da braucht man doch kein hätte wäre wenn. Libraries nachinstallieren und alles wird meistens gut ..... Hast Du das denn nun schon mal probiert?
Vorgehensweise:
Eine Suchmaschiene deines Vertrauens zeigt, wo es die in der Meldung aufgezählten Libs gibt.
Download und entweder mit rpm -i , wenn es den rpm Files sind, oder YaST oder YaST2 nachinstallieren. Dann die gewünschte Rocrail Version installieren. Danach sollte auch rocview einwandfrei laufen.
Soweit ich das in Erinnerung habe, benötigst Du kein rpm -i weil YaSTdas alleine kann.

@Peter, falls du mitliest: Ist das auch schon sudern?

Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Next

Return to Basisfunktionalität (DE)