[erl] OpenSUSE 42.3 64 Bit fehlt

Re: [erl] OpenSUSE 42.3 64 Bit fehlt

Postby AndKie » 14.07.2018, 11:17

rjversluis wrote:Moin Andreas,
AndKie wrote:Was mich störte war der knallharte Wechsel von heute auf morgen!

ich hatte doch schon ein Begründung geschrieben.
Leap 42.3 hat sich verabschiedet. Ich musste neu aufsetzen, und habe dann natürlich die aktuellste Sus installiert. Das die Sus Version von 42 nach 15 herunter gestuft worden ist musst du bei Sus nachfragen. Und das Sus 15 nicht kompatibel mit Sus 42 ist, da kann ich auch nichts dafür.



Hallo Rob,

das ist richtig, das hast du auch so geschrieben und für die Inkompatibilität, verschiedener SuSE Distri's, kannst du selbstverständlich auch nichts.

Die Philosophie von SUSE, Versionsnummern, kann ich auch längst nicht nachvollziehen, ich bin seit SuSE 5.2 dabei, (ca. 1998), aber das hatte ich so auch nicht erlebt!
Man springt doch in den Versionsnummern nicht willkürlich von 11.x- bis 13.x und dann nach 42.x und wieder auf 15.x, das ist mir komplett unverständlich und nicht nachvollziehbar.
Schließen wir das Ganze mal ab, es führt eh zu nichts.

Gruß
Andreas

:rr_for_ever:
OpenSuse Leap 15.0, H0, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: [erl] OpenSUSE 42.3 64 Bit fehlt

Postby rjversluis » 16.07.2018, 18:43

Hallo Andreas,

auf mehrere Nachfrage habe ich noch ein Leap 42.3 VM installiert.
Für dich kommt es zu spät, aber ich wusste nicht das es zwischen 42.3 und 15 so ein Bruch geben würde.
https://launchpad.net/rocrail/+download
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: [erl] OpenSUSE 42.3 64 Bit fehlt

Postby AndKie » 17.07.2018, 08:04

rjversluis wrote:Hallo Andreas,

auf mehrere Nachfrage habe ich noch ein Leap 42.3 VM installiert.
Für dich kommt es zu spät, aber ich wusste nicht das es zwischen 42.3 und 15 so ein Bruch geben würde.
https://launchpad.net/rocrail/+download


Hallo Rob,

It's too late, aber macht nichts, trotzdem Danke. :coding:

Gruß
Andreas
OpenSuse Leap 15.0, H0, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: [erl] OpenSUSE 42.3 64 Bit fehlt

Postby HGuenther » 17.07.2018, 13:10

Laut Wikipedia haben die nur einmalig "Open Suse leap" 42.1 "zwischengeschoben"
und sind danach zur normalen Nummerierung zurückgekehrt,
13, 42, 14 .....

Und laut Wikipedia ist "42" eine Verbindung zu Douglas Adam's "Per Anhalter durch die Galaxis"
-> 42 ist "die Antwort auf alle Fragen"
-> für "Nerds" daher "21 nur die halbe Wahrheit" ....
Heinz Günther
--------------------------------------------------------------
OpenDCC, Fichtelbahn, RocRail, Z21 schwarz
H0 Hamburger Hochbahn U-Bahn, Modulanlage in Planung und in Bau
HGuenther
 

Re: [erl] OpenSUSE 42.3 64 Bit fehlt - suse15 libs auf 42.3

Postby WernerSc » 22.07.2018, 18:34

auch wenn der Thread als "erledigt" gekennzeichnet ist, hier eine kurze Aufstellung dessen, was zu tun ist, um die leap-15 Version von Rocrail auch auf openSUSE leap 42.3 installieren zu können.
(greift Vorschlag von GeSchu auf)

Man benötigt (lediglich) die als "failed dependencies" monierten wxwidget-Pakete von der openSUSE-leap15 Distribution. Diese holt man sich entweder aus dem /x86_64 Verzeichnis der Installations-DVD oder vom openSUSE Webserver (http://download.opensuse.org/distributi ... ss/x86_64/). Die benötigten Pakete sind
libwx_baseu-suse3-3.0.3-lp150.5.12.x86_64.rpm
libwx_baseu_net-suse3-3.0.3-lp150.5.12.x86_64.rpm
libwx_gtk2u_core-suse3-3.0.3-lp150.5.12.x86_64.rpm
libwx_gtk2u_adv-suse3-3.0.3-lp150.5.12.x86_64.rpm
libwx_baseu_xml-suse3-3.0.3-lp150.5.12.x86_64.rpm
libwx_gtk2u_html-suse3-3.0.3-lp150.5.12.x86_64.rpm
libwx_gtk2u_qa-suse3-3.0.3-lp150.5.12.x86_64.rpm
libwx_gtk2u_xrc-suse3-3.0.3-lp150.5.12.x86_64.rpm

Nach Herunterladen in obiger Reihenfolge (wg. Abhängigkeiten) als "root" installieren, z.B. per "rpm -Uhv <Paketname>" oder "zypper install <Paketname>" [ich hab's wie gewohnt per rpm gemacht].
Ein Blick ins Packet-Management sowie /usr/lib64 zeigt, dass die beiden wxwidgets-Versionen "suse1-3.0.2" für leap 42.3 und "suse3-3.0.3" für leap-15 anscheinend ungestört nebeneinander existieren können.

Nach Installation der o.a. "leap-15"-Libs kann nun auch rocrail-opensuse_leap15-14095.x86_64.rpm auf einem leap-42.3 System installiert und ausgeführt werden. (Hab' die Ausführung aber nur für den Client getestet).

(Müsste auch umgekehrt für leap15 funktionieren, d.h. Installation der wxwidget-libs von leap42.3 auf leap15, um für 42.3 gebaute Rocrail rpms installieren zu können)
viele Grüße, Werner
WernerSc
 

Previous

Return to Basisfunktionalität (DE)