[gelöst] Half-Automatik entfernt Lok vom Handregler

Re: Half-Automatik entfernt Lok vom Handregler

Postby JanLok » 14.09.2018, 11:09

Hallo Rob,

also du kannst gerne so viele Datein bekommen wie du möchtest. Hast du vielleicht gewisse Wünsche was diese für Situationen enthalten sollen?

EXIT Melder habe ich keine im Einsatz und die Lok selbst hat nur ihre Fahrstraße abgefahren. Also keinen Block unerwartet erreicht.


Bis dann
JAN
JanLok
 

Re: Half-Automatik entfernt Lok vom Handregler

Postby rjversluis » 14.09.2018, 11:23

Hi Jan,

es kann nur durch ein exit melder ausgelöst worden sein.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Half-Automatik entfernt Lok vom Handregler

Postby JanLok » 14.09.2018, 12:14

Hi Rob,

ich bin den Plan gerade noch einmal durchgegangen. Ich habe keinen EXIT Melder im Einsatz.

Auch müsste die Lok ansonsten im Automatikmodus diese Störung haben und anhalten oder nicht? Wird nur automatisch gefahren, dann tritt diese Störung nicht auf.

Bis dann
JAN
JanLok
 

Re: Half-Automatik entfernt Lok vom Handregler

Postby rjversluis » 14.09.2018, 12:19

Hi Jan,

zippe dann alle rocrail.*.trc zusammen und hänge die dann hier na nachdem es wieder passiert ist.
Oder wenn bis jetzt, nach deine letzte test, keine neue traces mehr dazu gekommen sind.
Ich hoffe ich nerve nicht wenn ich das schon zum 2. mal frage...
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Half-Automatik entfernt Lok vom Handregler

Postby JanLok » 14.09.2018, 12:37

Hallo Rob,

du nervst nicht! Ehr nerve ich dich.

Nun, ich habe die alten Trace Daten nicht mehr alle. Drum werde ich nun ein paar neue für dich erstellen. Das dauert aber etwas.

Bis dann
JAN
JanLok
 

Re: Half-Automatik entfernt Lok vom Handregler

Postby JanLok » 14.09.2018, 13:10

Hallo Rob,

hier sind einmal drei Trace Datein im Anhang.

Beim Versuch_1 und Versuch_3 kommt es direkt nachdem Start zu einer Abmeldung.

Dieser Befehl wurde von mir ausgelöst, damit mir der Zug nicht quer über die Anlage düst.
Code: Select all
20180914.134828.127 r9999c dimaxrea OMassoth 1133 emergency break reset packet
20180914.134828.143 r9999I dimaxrea OMassoth 0914 system status=0x82 power=OFF


Kann es sein, dass die Abmeldung mit den Fahrstufen zusammen hängt?
Immerhin wird die Lok immer auf 28 Fahrstufen (eingetragen ist sie im System mit 128) zurückgesetzt. Zufällig habe ich es gerade einmal nicht geändert und die letzte Runde fuhr sie ohne Abmeldung. Ist jetzt aber nur eine Vermutung.


Bis dann
JAN
You do not have the required permissions to view the files attached to this post.
JanLok
 

Re: Half-Automatik entfernt Lok vom Handregler

Postby rjversluis » 14.09.2018, 13:35

Hi Jan,

ich kann es dir nicht erklären...
Aber die traces sind ohne Automat-Level...
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Half-Automatik entfernt Lok vom Handregler

Postby rjversluis » 14.09.2018, 13:55

Hi Jan,

kannst du bitte nochmals ein Trace machen mit Revision 14349+, weil da wird im Trace gezeigt welches Kommando ein Anmeldung auslöst.
Und bitte Automat-Level dazu schalten.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Half-Automatik entfernt Lok vom Handregler

Postby JanLok » 14.09.2018, 14:49

Hallo Rob,

mein Fehler. Ich werde es wiederholen!
Heute komme ich leider nicht mehr dazu. Könnte ein paar Tage dauern, bis ich es schaffe.

Was mir aber aufgefallen ist, wenn die Lok auf 28 Fahrstufen eingestellt ist, dann tritt der Fehler nicht auf.


Bis dann
JAN
JanLok
 

Re: Half-Automatik entfernt Lok vom Handregler

Postby rjversluis » 14.09.2018, 14:52

Hi Jan,
JanLok wrote:Was mir aber aufgefallen ist, wenn die Lok auf 28 Fahrstufen eingestellt ist, dann tritt der Fehler nicht auf.

wie das zusammen hängt kann ich erst anhand von neue traces feststellen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Half-Automatik entfernt Lok vom Handregler

Postby rjversluis » 14.09.2018, 16:14

Hallo Jan,

ich habe mal ein wenig virtuell mit dein plan herum getestet, aber mit event timers von über 15000 :shock: ist das unmöglich, und dafür kann ich auch kein support anbieten.
https://wiki.rocrail.net/doku.php?id=bl ... -zeitgeber
Ich vermute das da sich events überholen und deswegen zum Lok Kommando V=0 führen.
Wenn du Halb-Auto fährst kann es sein das die Lok schneller unterwegs ist als die Timers es erwarten.

Alle Ereignis-Zeitgeber müssen auf Null gestellt oder auf einen minimalen Wert reduziert werden, bevor irgend ein Problem bzgl. unerwarteter Ereignis-Warnungen im Forum berichtet wird.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Half-Automatik entfernt Lok vom Handregler

Postby JanLok » 14.09.2018, 23:53

Hallo Rob,

du musst in dem Plan auch nicht herum spielen. Warte einfach einmal ab, bis ich es selbst probieren kann.

Übrigens mit den Timern kann es nicht viel zu tun haben, wenn die Lok noch nicht einmal los gefahren ist und schon verschwunden ist. Das war bei Versuch_1 und Versuch_3 der Fall. Da kam die Lok nicht einmal bis zum ersten Melder. Im Falle von Versuch_2 verschwand die Lok in einem Block mit ENTER2IN der ohne Timer arbeitet.
Außerdem würde ich gemäß deiner Annahme das Problem auch dann haben, wenn ich mit 28 Fahrstufen fahre. Da kommt es aber zu keinen Störungen und langsamer fahre ich da sicher nicht als mit 128 Fahrstufen :lol: .

Also warte bitte etwas ab und zur Not setzte ich dann bei meinem Plan alle Timer auf 0.


Bis dann
JAN
JanLok
 

Re: Half-Automatik entfernt Lok vom Handregler

Postby rjversluis » 15.09.2018, 06:47

Moin Jan,

ja, ich warte ab.
Weil es gibt viele Lok befehle welche in der Massoth Bibliothek nicht ausgewertet werden und landen dann automatisch als Fahrbefehl.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Half-Automatik entfernt Lok vom Handregler

Postby JanLok » 15.09.2018, 11:09

Hallo Rob,

danke dir für deine Mühe und deinen Einwand. Du darfst nich vergessen, dass du es hier mit einem Laien zu tun hast. Programmieren habe ich mal im Studium gelernt, aber wie die Busssystem aufgebaut sind, dass weißt du sicher besser. Daher schätze ich es, wenn du mir sagst warum meine Annahmen nicht stimmen.

Doch zurück zur Sache. Getestet habe ich vorhin mit Version 14351. Vier Versuche findest du im Anhang.
Direkt nach der Abmeldung wurde die Trace erstellt und der Betrieb durch Notaus abgeschaltet.

Versuch_1 (Ist vom Ablauf sehr komplex, weil eine Fahrt dargestellt wird. Betrachte ihn besser zum Schluss.)
Eine Fahrt wurde durchgeführt. Alle Melder wurden sauber von ENTER nach IN durchfahren. Die Lok war nie zu früh im nächsten Block.

Versuch_2
Bei der Abfahrt im Bahnhof wurde gleich zu weit aufgedreht. Die Lok also zu schnell. Danach kurz nachregeln und die Lok springt weg.

Versuch_3
Wie Versuch_2

Versuch_4
Wie Versuch_2 &3, aber mit 28 Fahrstufen.


Wenn ich hier ein Fazit ziehen darf, dann habe ich die Vermutung, dass Rocrail hier die Rennaufsicht macht und die Lok ggf. zum Stehen oder auf Vsoll bringen möchte, wenn sie zu schnell ist. Die Fahrstufen sind damit raus, anders als bei der alten Version 14339.

Was noch anzumerken ist, dass ist das Verhalten nach der Abmeldung. Mit dem Handregler kann ich die Lok erst nach einer erneuten Freigabe übernehmen und Rocrail steuert sie nicht an, weil sie angeblich noch vom dimax angesprochen wird. Die Lok hängt also in der Luft.



Hoffentlich hilft dir das weiter. Falls nicht, dann stelle ich gerne noch etwas nach oder setze alle Timer auf 0 zurück.


Bis dann
JAN
You do not have the required permissions to view the files attached to this post.
JanLok
 

Re: Half-Automatik entfernt Lok vom Handregler

Postby rjversluis » 15.09.2018, 11:18

Moin Jan,

du hast SBT aktiviert:
Code: Select all
20180915.114058.411 r9999a ABe 4/4  OLoc     1747 SBT Vcur=26 Vdrv=26 decelerate=1

da wird der Halb-Automat noch nicht abgefangen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

PreviousNext

Return to Automatikbetrieb (DE)