erledigt: Chaos im Automatikbetrieb

erledigt: Chaos im Automatikbetrieb

Postby achim » 11.02.2018, 09:03

Guten morgen zusammen,
nach anfänglicher Begeisterung bin ich nun recht hilflos, denn es läuft im Automatikbetrieb nichts mehr. Über Euren Rat würde ich mich sehr freuen:
aktueller Zustand:
+ RR aktuelle Version vom 11.02
+ Gleisplan auf zwei Seiten
+ Verbinder zweistellig
+ die Blockrichtung habe ich überprüft und sollte stimmen (Da gibt es einen Bereich mit der Drehscheibe, die ist jedoch nicht aktiv und spielt im Moment keine Rolle)
+ der Analyser läuft ohne Fehlermeldung durch
+ die Nebenstrecke soll in beiden Richtungen betrieben werden. Mit den Richtugnsgleisen habe ich die Richtungen angegeben.
+ hier habe ich zumindest in zwei Blöcken die Rückmelder für all enter + und - eingetragen. Wenn es grundsätzlich läuft, ergänze ich die naderen Blöcke.

Fehlerbeschreibung:
+ Im Basiskreis wird ein Fahrbefehl im Autmatikbetreibe angenommen, die Lok fährt aber in die falsche Richtung und erzeugt so einen Ghosttrain im nächsten Block
+ Auf der Nebenbahnstrecke wird keine Fahrbefehl angenommen (kein Ziel gefunden)

Bereits duchgeführte Maßnahmen:
+ Ich habe am Gleisplan einige Veränderungen vorgenommen (Blockrichtung umgedreht usw. Richtungsgleise neue gesetzt, die Gleisverbinder 2-stellig durch numeriert). Anschliessend habe ich die Analyseergebnisse entfernt, gespeichert, RR runtergefahren, neue gestartet, Analyse durchgeführt, RR runtergefahren, neu gestartet.
Es ist der Wurm drin.
Was schlagt Ihr vor, was sollte ich tun.
Im Anhang die Dateien, es ist der letzte aktuelle Stand.
Danke für Eure Rückmeldungen
You do not have the required permissions to view the files attached to this post.
Last edited by achim on 21.02.2018, 23:40, edited 1 time in total.
Beste Grüße
Achim
------------------------------------------------------
Windows 10, Spur N, 2 x GBM Boost Master, 3 x GBM Boost Node, 11 x GBM 16T, 1 x Light Control, 7 x OneControl, 14 X Herz8
achim
 

Re: Chaos im Automatikbetrieb

Postby Bernie » 11.02.2018, 09:23

Hallo Achim,

beim ersten Blick auf Deinen Plan ist mir sofort aufgefallen, dass bei etlichen Loks die Fahrtrichtung falsch eingestellt ist. Der Pfeil bei V__ in der Lokliste muss für den Automatikbetrieb immer!!! nach rechts zeigen, sonst fahren die Loks in der falschen Richtung. Den Rest sehe ich mir später an, jetzt gibt es erst mal Frühstück.
Gruß Bernd

[H0 2-L DCC] [Win10real,Win7Test] [IB-COM+GCA101+TamsMC] [4*ORD-3] [GCA50/93/102/136] [Weichen/Lichtsign. LDT/Viessmann(MM)] [Formsignale GCA136] [CarSystem/DC-Car] [Weichen CarSystem Digirails DR4024]

http://www.modelltraumland-wuppertal.de/
Bernie
 

Re: Chaos im Automatikbetrieb

Postby Bernie » 11.02.2018, 10:25

Hi,

jetzt geht es weiter.

1. Rückmelder: In allen Blöcken fehlt die Zuordnung der Rückmelder bei "all enter-", in Block BL46P04 fehlen die Rückmelder komplett. In mehreren Blöcken hast Du 2 in-Melder definiert.
2. Blöcke und Fahrmöglichkeiten: BL45P01 ist überhaupt nicht erreichbar, da er von keinem anderen Block aus angefahren werden kann. Es gibt daher schlicht und einfach keine Fahrstraßen von und zu diesem Block. Endblöcke (Kopfbahnhof): Wenn eine Lok in diesen Block eingefahren ist und dieser Zug nicht als Pendelzug definiert ist, kann er den Block nicht mehr verlassen, da kein automatischer Richtungswechsel erfolgt. Abhilfe: Entweder im Block die Option "Richtungswechsel erlaubt" aktiviert lassen und die betreffenden Loks als Pendelzug definieren, oder den Block als Kopfbahnhof einrichten ohne die Option Pendelzug bei Loks zu verwenden. Ich persönlich bevorzuge letztere Variante.

Meine Frage dazu: Hast Du vorher mal mit einem Testkreis, wie hier immer dringend empfohlen, probiert? Meines Erachtens fehlen Dir noch etliche wichtige Grundlagen zum Verständnis von Rocrail.
Gruß Bernd

[H0 2-L DCC] [Win10real,Win7Test] [IB-COM+GCA101+TamsMC] [4*ORD-3] [GCA50/93/102/136] [Weichen/Lichtsign. LDT/Viessmann(MM)] [Formsignale GCA136] [CarSystem/DC-Car] [Weichen CarSystem Digirails DR4024]

http://www.modelltraumland-wuppertal.de/
Bernie
 

Re: Chaos im Automatikbetrieb

Postby GeSchu » 11.02.2018, 10:32

Moin Achim,
zusätzlich von dem, was Bernd aufgefallen ist:
Ich bin ein gr0ßer Freund von "Keine Richtungspfeile". Von daher würde ich alle Richtungspfeile im Gleisplan entfernen. Die Fahrtrichtungen von Loks und oder Zügen werden durch vorhandene oder nicht vorhandene Fahrstrassen geregelt. Allerdings gehört dazu, das man sich jede vom Analyzer erstellte Fahrstrasse anschaut und eventuell löscht. Oder man legt seine Fahrstrassen selbst an. Das ist gar nicht so schlimm, braucht aber seine Zeit.
Um jetzt die Fehlerfindung zu vereinfachen könntest Du bitte:
Wie von Bernd schon beschrieben: Die Fahrtrichtung ("<<") aller Loks nach rechts (">>") stellen. Jede Lok darauf prüfen, ob sie jetzt, nachdem alle ">>" nacht rechts zeigen, manuell in die richtige Richtung fahren. Bei Problemen im WIKIhier nachlesen.
Eventuell alle Richtungspfeile im Gleisbild entfernen. (je nach Gusto)
Wenn das dann alles stimmt, schreibst Du und bitte genau, welche Lok in welchem Block wann das besagte Chaos hervorruft. Du hast einen sehr umfangreichen Plan. Die wenigsten Helfer werden sich jetzt den Block oder und die Lok mit Problemen ertasten.
Ganz wichtig: Im WIKI das Kapitel "Erste Schritte" lesen.

Ich möchte, nachdem ich Bernds 2. Post gelesen habe, noch etwas ergänzen: Taste Dich bitte Schritt für Schritt an die Lösung heran. Lasse Dich nicht von vielen hier noch zu schreibenden Kommentaren verwirren. Es wird noch der eine oder andere Tipp von erfahrenen Rocrailern kommen. Weil auf deinem Plan noch einiges im Argen liegt, mache Dir einen Zettel, eine ToDo Liste, in etwas so:
--- Loks Fahrrichting
--- Blocks Röcklmelder
--- Weichen Adressen
--- Fahrstrassen (erstellen (lassen), kontrollieren, Fahrstrassen Befehle für Weichen erstellen, kontrollieren
--- and so on

Ergänze diese Liste um weitere (Tipps) Punkte und arbeite nicht jeden Punkt gleichzeitig sonder einzeln hintereinander ab. Mache einen Haken hinter dem Punkt und nehme dir den nächsten vor. Bei Bedarf stelle Deine Fragen, möglichst mit Problemfall.

Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Chaos im Automatikbetrieb

Postby achim » 11.02.2018, 11:01

Hallo Gerd, Hallo Bernd,
richtig, im bin mit dem Automatikbetrieb am Anfang und lerne erst noch.
Der Basiskreis soll mein Testkreis sein, dort will ich üben. Das Kapitel "erste Schritte kenne ich, habe ich auch mehrfach gelesen, aber doch offensichtlich nicht alles verstanden.
Ich hatte es so verstanden, wenn ich einen Block nur von einer Richtung anfahre (+) muss ich nur den all enter + und nicht den all enter - definieren.
Mit dem Richtungswechsel in den Blöcken habe ich verstanden und werde es ändern.
Die Lokliste mit den Richtungen habe ich angepasst.
Zu den Richtungspfeilen: Ich hatte es so verstanden, dass sich der Analyser daran orinientert. Ich kann sie entfernen.

Zu meinem Projekt insgesamt:
Ich musste einige wichtige Strecken mechanisch umbauen (Weichen, Radien, Steigungen). Das habe ich nun abgeschlossen. Derzeit bin ich für diesen Abschnitt noch im Testbetrieb: Alle Zuggarnituren müssen in den vorgesehen Abschnitten störungsfrei arbeiten. Hier fahre und stelle ich von Hand über RR. Ich denke, dass ich ca. 90 % erledigt habe. Der Automatikbetreib ist für mich nun der nächste Projektabschnitt. Die Idee mit der To Do liste ist gut und werde ich umsetzen.
Signale und Entkuppler habe ich zwar eingebaut, aber noch nicht in RR eingerichtet. Hier will ich zunächst die Grundlagen verstanden haben.
Fazit:
Mir fehlt für den Umgang mit dem Autoamtikbetrieb noch etwas der "rote Faden"
Danke aber erst einmal für Eure Rückmeldungen.
Beste Grüße
Achim
------------------------------------------------------
Windows 10, Spur N, 2 x GBM Boost Master, 3 x GBM Boost Node, 11 x GBM 16T, 1 x Light Control, 7 x OneControl, 14 X Herz8
achim
 

Re: Chaos im Automatikbetrieb

Postby GeSchu » 11.02.2018, 11:10

Moin Achim,
achim wrote:Mir fehlt für den Umgang mit dem Autoamtikbetrieb noch etwas der "rote Faden"

Wie liest "Starman" doch so schön auf seinem Display ."No Panic". Wer ist Starman?
Diesen Faden wirst du schon finden.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Chaos im Automatikbetrieb

Postby Bernie » 11.02.2018, 11:21

Hallo Achim,

bei Deinem sehr umfangreichen Plan ist es sehr schwierig, alle Fehler bezüglich der Rückmelder auf Anhieb zu entdecken. Das Ganze wird noch durch die sehr langen Rückmelderbezeichnungen erschwert. Ich würde folgendermaßen vorgehen: Lösche in allen Blöcken (außer denen mit nur einem Rückmelder mit enter2in) die Rückmelder komplett. Dass geht in Rocrail leider nicht bei manuell zugeordneten Rückmeldern. Anschließend kannst Du per Analyser die Rückmelder automatisch zuordnen lassen. Das geht dann ganz einfach mit folgender Einstellung. Datei->Rocrail-Eigenschaften->Reiter "Gleisplan-Analyser". Siehe Anhang. Da Du ja keine Signale verwendest, können die Optionen für Signale auch deaktiviert bleiben. Anschließend Rocrail neu starten und neu Analysieren. Schau Dir dann bitte mal die Zuordnung der Rückmelder in den Blöcken an. Dann musst Du nur noch bei Blöcken mit mehr als 2 Rückmeldern manuell nacharbeiten.
You do not have the required permissions to view the files attached to this post.
Last edited by Bernie on 11.02.2018, 11:24, edited 1 time in total.
Gruß Bernd

[H0 2-L DCC] [Win10real,Win7Test] [IB-COM+GCA101+TamsMC] [4*ORD-3] [GCA50/93/102/136] [Weichen/Lichtsign. LDT/Viessmann(MM)] [Formsignale GCA136] [CarSystem/DC-Car] [Weichen CarSystem Digirails DR4024]

http://www.modelltraumland-wuppertal.de/
Bernie
 

Re: Chaos im Automatikbetrieb

Postby smitt48 » 11.02.2018, 11:22

Hi AChim,

Ich hatte es so verstanden, wenn ich einen Block nur von einer Richtung anfahre (+) muss ich nur den all enter + und nicht den all enter - definieren.

Stimmt
Zu den Richtungspfeilen: Ich hatte es so verstanden, dass sich der Analyser daran orinientert.

Stimmt

mfg Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.3) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: Chaos im Automatikbetrieb

Postby Bernie » 11.02.2018, 11:28

Hallo Achim,

das ist auch soweit richtig, aber Du hast gerade auch auf der Nebenbahn etliche Blöcke, die in beiden Richtungen befahren werden. Dort müssen natürlich die Rückmelder für beide Richtungen definiert werden. es ist sehr mühsam, die Fehler alle zu suchen und zu beseitigen. Es gibt nämlich etliche davon. Dann doch lieber in den sauren Apfel beißen und es mit Hilfe des Analysers neu zu machen. Es stört doch nicht, wenn für beide Richtungen die Rückmelder definiert werden, auch wenn man sie nicht braucht.
Gruß Bernd

[H0 2-L DCC] [Win10real,Win7Test] [IB-COM+GCA101+TamsMC] [4*ORD-3] [GCA50/93/102/136] [Weichen/Lichtsign. LDT/Viessmann(MM)] [Formsignale GCA136] [CarSystem/DC-Car] [Weichen CarSystem Digirails DR4024]

http://www.modelltraumland-wuppertal.de/
Bernie
 

Re: Chaos im Automatikbetrieb

Postby GeSchu » 11.02.2018, 11:37

Moin zusammen,
smitt48 wrote:............
Stimmt
..........
Stimmt
........

ändert aber nichts an meiner Meinung ........
Nur wenn man weis, wo man ist, weiß man, wo man hin möchte.
Will sagen: Nur wenn ich den Weg zum Ziel kenne, kann ich ihn auch kontrollieren, oder? Wer sagt mir denn, das der Analyzer alles immer richtig macht? Grundsätzlich arbeitet das Stück Software ja sehr gut. Um weiteren Fragen vorzubeugen: Ich kenne keine Situationen, wo der Analyzer nicht korrekt arbeitet. Dennoch: ich kontrolliere meist und habe damit gute Erfahrungen.
Also: Fahrstrassen gerne selbst erstellen. Nebeneffekt: Das übt.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Chaos im Automatikbetrieb

Postby achim » 11.02.2018, 11:55

Hallo zusammen,
ich erwarte von Euch wirklich nicht, dass Ihr alle meine Fehler findet. Das muss ich schon selber machen. MIr würde es reichen, wenn Ihr mir meine "gedanklichen" Fehler aufzeigt.
Nr. 1:
Warum muss ich bei einem Block, den ich nur aus der + seite anfahre, die Melder für all enter - definieren? WEnn ja, welcher wäre dann der Enter und der In. Beide Abschnitt sind ja unterschiedlich lang. Die In Abschnitt sind maximal 20 cm lang, Die Enerabschnitt sind in Regel ca. 100 cm lang.
Nr. 2:
Nebenbahn. Die habe ich pro Abschnitt mit drei Meldern versehen, 2 x in, einmal enter. Den Richtugnsechsel habe ich überprüft und eingebaut. Wenn ich den Block nun von der + Seite anfahre, defniere ich den all enter + mit dem ersten als Enter und dem zweiten als in.Entsprechend verfahre ich, wenn ich mit den Block von der - Seite anfahre, dafür würde ich dann all enter - mit den Rückmeldern versehen. Richtig?
nr. 3:
Im Kopfbahnhof selber habe ich pro Abschnitt nur zwei Melder eingaut, Enter und in. Ist es dann ausreichend, wenn diese Blöcke nicht mit Richtugnswechsle sondern mit Kopfbahnhof einrichte?
Nr. 4:
Richtugnspfeile: Ich kann sie entfernen. Kommt der Analyser dann zu anderen Ergebnissen?

Gruß
Achim
Beste Grüße
Achim
------------------------------------------------------
Windows 10, Spur N, 2 x GBM Boost Master, 3 x GBM Boost Node, 11 x GBM 16T, 1 x Light Control, 7 x OneControl, 14 X Herz8
achim
 

Re: Chaos im Automatikbetrieb

Postby Bernie » 11.02.2018, 12:03

Moin,

ich habe für Dich mal ein wenig "vorgearbeitet". Der Plan ist jetzt wieder "jungfräulich". Die Fahrstraßen per Analyser gelöscht und die Fehler soweit behoben. Bis auf die Blöcke mit enter2in sind auch alle Rückmelderzuordnungen gelöscht. Du kannst jetzt mit den von mir beschriebenen Einstellungen im Analyser die Fahrstraßen generieren und die Rückmelder zuordnen lassen. Anschließend noch bei den Blöcken mit mehr als 2 Rückmeldern die Zuordnung wie gewünscht eipflegen/korrigieren. Die Blöcke im Endbahnhof der Nebenbahn habe ich auch schon als Kopfbahnhof definiert. Der Analyser kommt natürlich zu anderen Ergebnissen, wenn Du Richtungspfeile mit nur einer Richtung verwendet hast und Du diese aus dem Plan entfernst. Er legt dann auch Fahrstraßen in der Gegenrichtung an. Bei den Doppelpfeilen gibt es keinen Unterschied. Die Zuordnung der Rückmelder ist bei Blöcken, die tatsächlich nur von einer Seite angefahren werden, in der Tat nicht unbedingt erforderlich, es schadet aber auch nicht. Die Rückmelder werden dann einfach in umgekehrter Reihenfolge definiert. Was für die +Seite des Blocks der enter-Melder ist, ist für die Gegenrichtung der in-Melder und umgekehrt.
You do not have the required permissions to view the files attached to this post.
Last edited by Bernie on 11.02.2018, 13:40, edited 3 times in total.
Gruß Bernd

[H0 2-L DCC] [Win10real,Win7Test] [IB-COM+GCA101+TamsMC] [4*ORD-3] [GCA50/93/102/136] [Weichen/Lichtsign. LDT/Viessmann(MM)] [Formsignale GCA136] [CarSystem/DC-Car] [Weichen CarSystem Digirails DR4024]

http://www.modelltraumland-wuppertal.de/
Bernie
 

Re: Chaos im Automatikbetrieb

Postby Pirat-Kapitan » 11.02.2018, 12:15

Moin Achim,
zu 1.: für Deinen Betrieb nicht zwingend erforderlich, es erleichtert aber einem Fehlersuchenden wie mir die Arbeit. Die physikalische Länge von Sensorabschnitten sehe ich nicht in Rocrail, aber die Funktionalität, und auf die kommt es bei der Bewertung für die Automatik an.
Natürlich kann ich an jeder Stelle ganz detailliert in den Plan einsteigen, dann sehe ich auch wenn nur die benötigten Rückmelder eingetragen sind. Aber das ist in meinen Augen für mich unnötige Arbeit und motiviert zumindest mich nicht zu einer weiteren Hilfeleistung.
zu 3.: entweder Kopfbahnhof oder Richtungswechsel erlaubt. Das ist eine eindeutige Alternative, Rocrail lässt Kopfbahnhof mit Richtungswechsel erlaubt nicht zu.

Den Rest hat Bernie schon beantwortet.

Schöne Grüße
Johannes
Clearasilfahrer auf Spur G&H0m, Lenz LZV (3.6), ORD-20, Manhart-Funki und WLM, RS-Bus Rückmelder (Reedkontakte/GBM),
Rocrail auf RasPi mit mobilen Geräten (andRoc). Details auf http://wiki.rocrail.net/doku.php?id=use ... at-kapitan.
Pirat-Kapitan
 

Re: Chaos im Automatikbetrieb

Postby achim » 11.02.2018, 13:00

Bernie wrote:Moin,

mit den von mir beschriebenen Einstellungen im Analyser die Fahrstraßen generieren und die Rückmelder zuordnen lassen. .


Hi Bernd,
wo finde ich die beschriebenen Einstellung für den Analyser? Welches sind denn die Blöcke mit Enter2In?

Ich würde gern die Richtugnspfeile drin lassen, sie erleichtern mir etwas die Orientierung und er legt dann nur die zugehörigen Fahrstrassen an., oder macht das Probleme?
Gruß
Achim
Beste Grüße
Achim
------------------------------------------------------
Windows 10, Spur N, 2 x GBM Boost Master, 3 x GBM Boost Node, 11 x GBM 16T, 1 x Light Control, 7 x OneControl, 14 X Herz8
achim
 

Re: Chaos im Automatikbetrieb

Postby rjversluis » 11.02.2018, 13:12

Hallo Achim,

wenn man der Analyser benutzt um Fahrstrassen generieren zu lassen sind diese Richtungspfeile sehr hilfreich.
Ich benutze diese Pfeile sogar wenn ich die FS selbst zusammen stricke um den überblick zu behalten.
Ohne Richtungspfeile generiert der Analyser Fahrstrassen in beide Richtungen.
Auf Richtungspfeile welche in beide Richtungen weisen würde ich verzichten, aber es könnte auch bei bestimmte Anlage eine visuelle Klarheit schaffen. Für der Analyser sind diese bedeutungslos.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Next

Return to Automatikbetrieb (DE)