erledigt: Ghost Train

erledigt: Ghost Train

Postby achim » 18.02.2018, 18:55

Guten Abend,
ich kann nun im Automatikbetrieb mit den Loks auf der Anlage meine Runden drehen. Bei einzelnen Blöcken wird jedoch ein Ghost Train erkannt. Es kommt z.B. die Meldung: Ghost Train in block BL51P10, fbid=RM051P11_e-reverse, code=
Bei dem Block sind die + und - Seiten richtig eingestellt, der kleine Pfeil zeigt jedoch in die falsche Richtung. (Siehe Screen shot) Den Rückmelder habe ich mit den Adressen und Einstellungen überprüft, die RM im Block selbst sind auch richtig eingetragen.

Ich habe dann beide Rückmelder gelöscht - allerdings ohne vorher die Kennung der Rückmelder im Block unter dem Reiter Fahrstrasse zu löschen - und neu definiert (Automatik aus, Plan bearbeiten an). Dann kam es zum Crash, die Verbindung zum Server ging verloren. Es kam dann die Meldung, dass ich die Trace Files packen und im Forum posten soll (Siehe Anlage). Der Plan liegt bei. Ich habe dann das System runtergefahren und neu gestartet. Konnte ohne Einschränkungen nutzen.
Die og. Fehlermeldung kann ich zwar "etwas" verstehen, mir fehlt aber der Ansatz wie ich zur Fehlerbehebung vorgehen soll. :?:

Sorry, dass ich schon wieder mit einer Frage komme, aber: in der nächsten Woche muss ich wieder arbeiten, dann habt Ihr mehr Ruhe vor mir.
You do not have the required permissions to view the files attached to this post.
Last edited by achim on 21.02.2018, 23:39, edited 1 time in total.
Beste Grüße
Achim
------------------------------------------------------
Windows 10, Spur N, 2 x GBM Boost Master, 3 x GBM Boost Node, 11 x GBM 16T, 1 x Light Control, 7 x OneControl, 14 X Herz8
achim
 

Re: Ghost Train

Postby GeSchu » 18.02.2018, 19:25

Moin Achim,
zunächst: Hier muss sich niemand andauernd für eine gestellte Frage entschuldigen. Im Gegenteil, ich persönlich mag eigentlich keine Menschen, die derart darunter leiden, geboren worden zu sein, das sie sich entschuldigen müssen.
achim wrote:.......
Bei einzelnen Blöcken wird jedoch ein Ghost Train erkannt. Es kommt z.B. die Meldung: Ghost Train in block BL51P10, fbid=RM051P11_e-reverse, code=
Bei dem Block sind die + und - Seiten richtig eingestellt, der kleine Pfeil zeigt jedoch in die falsche Richtung. (Siehe Screen shot) Den Rückmelder habe ich mit den Adressen und Einstellungen überprüft, die RM im Block selbst sind auch richtig eingetragen.

Der Block BL51P10 ist an beiden Seiten von Richtungspfeilen umgeben. Warum? Wenn ich mir Deinen Plan anschaue, dann fällt auf: Er wimmelt vor Richtungspfeilen. Die gehören weg, rigoros weg.
Einige Rückmelder werden in mehreren Blocks konfiguriert, z.B [RM008P0_I]. Dieser ist laut Plankonsistenz Prüfung sowohl in Block BL07 und BL08P0 konfiguriert. Es sind dies mehrere Melder, die so konfiguriert sind. Da ist es kein Wunder, das es zu unerwarteten Ghost Meldungen kommt. Die Melder sind also nicht richtig eingetragen.
Fazit: Zunächst Plankonsistenzprüfung durchführen und die angezeigten Fehler bereinigen.

Zur Fehlerbeschreibung: Wann genau wird im Block BL51P10 von welcher Lok ein Ghost gemeldet? Wo befindet sich die Lok in dem Augenblick? Da Dein Plan sehr komples ist, werde ich hier jetzt nicht alle möglichen Konstellationen ausprobieren. Diese Fragen bitte erst nach der Konsistenzprüfung beantworten.
Erklär doch bitte mal genau, was, wann wie passiert?
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Ghost Train

Postby GeSchu » 18.02.2018, 19:37

Moin Achim,
noch etwas ist mir in der Konsistenzprüfung aufgefallen:
Code: Select all
 block feedback action check: bl[BL51P14] from[all enter +] byroute[all enter +] found (enter enter2pre enter2shortin) but no (in)

Das bedeutet: Zu dem Block BL51P14 ist kein IN Melder definiert. Habe ich im Plan auch nicht gefunden. Dazu muss man wissen: Zu einem Block gehört neben einem ENTER auch ein IN. Das kann auch ein enter2in sein, nur er muss definiert, resp. konfiguriert sein. Ohne kann rocrail nicht ordnungsgemäß arbeiten.
Die Meldung taucht zu verschiedenen Blocks auf. Bitte hier nochmal die Konfigurationen prüfen.
Ich mache Deinen Plan erstmal wieder zu und harre der Dinge die da kommen.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Ghost Train

Postby cds » 18.02.2018, 19:57

Hallo Achim!

Wie Gerd sagt: Bitte im Block BL51P14 unter "Fahrstraßen" dem IN-Melder das "IN" zuordnen.

Nachdem ich das gemacht habe, fährt die E1156 sauber gegen den UZS durch die Gleiswendel.
Beste Grüße/Kind regards
Claus

M* H0 M
HW: TAMS MC, B-2 & B-4, WD-34, VIESSMANN 5211(1), LITTFINSKY & TAMS S88-3
Decoder: Mä & TAMS (MM2)
SW: Win7 64, RR 64, andRoc
cds
 

Re: Ghost Train

Postby achim » 18.02.2018, 21:40

Hallo Gerd, hallo Claus,
keine Sorge, ich will mich nicht für alles entschuldigen, aber ich finde ein "'Danke" schon nicht schlecht bei all Euren Bemühungen.
Zu den Fehlern:
+ Der fehlende In Melder ist mir durch die Lappen gegangen, wurde ergänzt
+ die Doppelbelegung eines Melders habe ich korrgiert.
+ Ich habe dann die erweiterte Konsistensprüfung laufen lassen. Wenn ich das richtig gesehen habe, wurdenkeine Fehler gefunden.
+ Zu den Richtungspfeilen: Da gibt es auch im Forum unterschiedliche Standpunkte. Sie haben mir zunächst geholfen, die Fahrstrassen richtig zu deuten. Wenn ich die Kollegen richtig verstanden habe, wirken sie sich nicht negativ aus, daher lasse ich sie erstmal drin.
+ im HBF Bereich habe ich mit RM029P00_E noch ein "physikalisches" Problem, da muss ich die Verdrahtung überprüfen.
+ Die V1144 und die E1156 sind die Wendel sauber hoch und runter druchlaufen. Das sollte nun funktionieren.

So, nun ist die Bastelzeit vorbei, ab morgen geht es wieder in den Job. ich wünsche Euch noch einen schönen Abend. :beer:
Beste Grüße
Achim
------------------------------------------------------
Windows 10, Spur N, 2 x GBM Boost Master, 3 x GBM Boost Node, 11 x GBM 16T, 1 x Light Control, 7 x OneControl, 14 X Herz8
achim
 

Re: Ghost Train

Postby GeSchu » 18.02.2018, 21:46

Moin Achim,
freut mich, das wir soweit haben helfen können.
Na denn: frohes Schaffen:-)
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Ghost Train

Postby cds » 19.02.2018, 08:04

Hallo Achim!

Würdest du bitte einen erledigten Thread auch als solchen kennzeichnen? Einfach im ersten Posting auf "Ändern" und die Titelzeile editieren.
Danke!
Beste Grüße/Kind regards
Claus

M* H0 M
HW: TAMS MC, B-2 & B-4, WD-34, VIESSMANN 5211(1), LITTFINSKY & TAMS S88-3
Decoder: Mä & TAMS (MM2)
SW: Win7 64, RR 64, andRoc
cds
 


Return to Automatikbetrieb (DE)