Zimo MX9 'Hauptabschnitt ' Kommandos

Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 15.12.2015, 09:34

Hallo,

ab Revision 10312 gibt es 5 Block Kommandos:

1) Power on
2) Power off
3) Stop
4) Speed 1
5) Speed 2

Auf der Schnittstelle Seite vom Block muss die MX9 Adresse und Hauptabschnitt(Port) eingetragen werden.
Die Folgende Bibliotheken unterstützen es zur Zeit:
- ZimoBin (CV2...CV9)
- Virtual

http://wiki.rocrail.net/doku.php?id=blo ... k_commands
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby buddybergy » 16.12.2015, 07:24

Ok. Jetzt hab ich soweit verstanden wie man es einstellt.

Und wo die Doku bei ROCRAIL liegt. :D

So die Menü sind schon mal da ok. Aber es tut sich nix. Also am Fahrpult kann ich über LEDS den STATUS des MX9 sehen .

Bunte LED
RoT blinkent heisst Strom aus.
Ultralagsam GELB
Frei Fahrt Grün
Anhalten ROT.

OK am Fahrpult rufe ich die ADRESSE 901 (modul cv1 1 ). Aber keine LED ändert sich. HABS in den Einstellungen unter Address Treiber. mit 1 und 901 versucht nix. :shock:

Also wenn man ROCRAIL zum ersten mal startet kann man sehen, so war es aber schon die ganze Zeit, die ANLAGE mit alles ROT Bootet und es alles auf Grün nach und nach geschaltet wird.
Also Frei fahrt. ? Nur welche Addresse macht den die ZIMOBIN DLL da. Da läuft von Addresse 1-63 alles durch ????. Wäre interressant was da passiert. das klappt ja.

Krieg ich irgendwie ne Compilierbar ZIMOBIN.dll die ich irgendwie zum Testen nutzen könnte ?

SYSCMD BLOCKRESET wird aufgerufen und die ZIMOBIN ist im LOG auch zu sehen allerdings passiert nix.

Gruss
Buddy

Was für LOG mit welchen DEBUG informationen soll ich schicken.
buddybergy
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 16.12.2015, 07:27

buddybergy wrote:Was für LOG mit welchen DEBUG informationen soll ich schicken.

Info, Byte und Monitor. Bitte KEIN Debug.

Das Protokoll sagt zum MX9 Adresse:
The new binary interface protocol Page 9 wrote:MX9 address (0-63 not 900-963)


http://wiki.rocrail.net/doku.php?id=blo ... k_commands
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 16.12.2015, 07:42

Hi,

zum testen bitte Revision 10312+ verwenden.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby buddybergy » 16.12.2015, 08:06

Aha. OK. Muss ich dann bis morgen warten.

Oder gibts ne andere Homeplage wo die Version ist.

Habe Windows NIGHTLY UPDATEs????? SNAPSHOT oder bin ich da falsch.

Hatte jetzt mit 309 probiert.
buddybergy
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 16.12.2015, 08:07

Ich baue gerade eine neu Windos build...
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 16.12.2015, 08:26

Hi,

sollte jetzt da sein. (Nightly builds)
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby buddybergy » 16.12.2015, 08:56

Ja ist da. Hatte wahrscheinlich auch noch ne Bug gemacht. Da die INSTALLTION von 309 nach C:\ROCRAIL wollte und nicht nach C:/programme/ROCRAIL.

da noch mit dem falschen Server gespielt mit client neuem ROCVIEW. so wird datt nix. hihi.

Toll wie du das machst....


Was bei mir geht.

ADRESSE wäre 1 für MODUL 901.
PORT 1 = Wert 0 Hauptabschnitt 1
PORT 2 = Wert 7 Hauptabschnitt 8

Das geht schon mal Supi.......

Ich werde mir demnächst mal ansehen wie so ein STP arbeitet. Das finde ich nicht so ansprechend.
Der Kollege sagte mir das hier das Programm ständig die Blöcke umprogrammiert.

Da 1 Block immer aus einem Fahrabschnitt und einem Bremsabschnitt besteht.

z.B. Zug fährt ein Signal ist rot. 1 abschnitt wohl die geschwindigkeit von CV2 etweder fahrt langsam ultralangsam, dann der 2 abschnitt CV22 HALT.

Da soll alles sich ständig der Situation anpassen.

Werde mir das mal anschauen. Vielleicht kann ich den Kollegen auch noch bewegen hier Mitglied zu werden. Der hat eine riesige Gartenbahn.
Der hat nähmlich 10 MX9. mit STP. Und hat immer gezögert weil kein HLU geht. Ob das aber wirklick so ist konnte ich bisher nicht testen.

Werde ihn mal Informieren dann kann er das mal testen. Weil ROCRAIL ist besser finde ich von Bedienung usw. Meine Bahn läuft jetzt einwandfrei damit.
Könnte man Blockdeaktivieren mit der OPTION ZIMO STROMAUS koppeln irgendwie. Da würde ich nähmlich noch meinen Schattenbahnhof daran packen. Wegen Abschaltung der Beleuchtung.
Die BAHN sieht so schon 4A für nix.
Buddy
:beer: :beer:
buddybergy
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 16.12.2015, 10:04

Der Kollege sagte mir das hier das Programm ständig die Blöcke umprogrammiert.

dann sollte er wie du auch updaten.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 16.12.2015, 10:20

Könnte man Blockdeaktivieren mit der OPTION ZIMO STROMAUS koppeln irgendwie.

das kannst du mit Aktionen machen. (Stromaus? Strom aus!) ;)
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby buddybergy » 16.12.2015, 12:29

Hab hier noch was. Gefunden.

Eine von beiden Geschwindigkeiten geht nicht.
Wird nur GELB nicht orange denke die nach rot kommt als Funktion auf dem Fahrpult.

Der SPEED 1 und 2 macht ist immer gleich.

Andere Frage wäre wenn ne Lok auf dem BLOCK steht sollte man da auch an MENÜ drankommen. BEFEHLE ?

Oder macht das keinen SINN.
buddybergy
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 16.12.2015, 12:39

Der SPEED 1 und 2 macht ist immer gleich.

wenn Speed 1 und 2 immer gleich sind dann wird es nicht richtig im Zentrale verarbeitet.


Andere Frage wäre wenn ne Lok auf dem BLOCK steht sollte man da auch an MENÜ drankommen. BEFEHLE ?

es wird in beide Fällen im menu angezeigt; Belegt oder nicht.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby buddybergy » 16.12.2015, 13:29

Vielleicht Falsch vormuliert.

ULTRALANGSAM GEHT nicht ! Vielleicht hier ne Zahl falsch.

Irgendwo musste doch ULTRALAGSAM und Langsam einen UNTERSCHIED MACHEN. Anscheinend tuts das aber nicht.MODI musss gehen. bei bit und bit

MUSS gehen.

Kannste nochmal schaun.. CV2 Wert1=1 Ultralangsam und WERT2=2 langsam. sckickst nur langsam. wenn speed1 und speed2 dem ensprechen. kein unterschied von hand geht mit fahrpult.
buddybergy
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 16.12.2015, 14:16

Ich habe es in Revision 10314 korrigiert.

Kannst du bitte die unnötige Großbuchstabe weglassen? Das liest sich sehr UNGEMÜTLICH. :|
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby Dirk1965 » 22.11.2016, 15:27

Hallo ,

ich hole dies mal aus der Versenkung, weil es mich interessiert.

Ich habe bis zum letzten Eintrag diese Diskussion gelesen.
Meine Frage dazu wäre:
Arbeitet RR nun einwandfrei mit der Zimobin.dll und den MX9 Modulen zusammen?

Ich frage, weil ich auch mit MX9 und STP fahre. Möchte diese aber dauerhaft ändern
und auf RR umstellen. Ein MX9 Modul ist schon in RR eingebunden und ich kann
mit "Rechtsklick" auf einen Block auch die Speedlimits setzen. Mein MX31 meldet
es dann durch die Farbänderung über den Tasten 1-8 zurück. Soweit funktioniert es.

Stelle ich nun eine Lok auf einen Gleisabschnitt meiner Anlage, so bekomme ich keine
Meldung in RR, dass der Gleisabschnitt besetzt ist.
Wenn ich in RR im Automtikmodus (Test) fahre, dann schlten zwar die Weichen, aber
die Speedlimits vom MX9 verändern sich nicht.

Vielen Dank im Voraus für eine Antwort.

Gruß Dirk

PS: Hier steht, welche HW ich benutze:
http://forum.rocrail.net/viewtopic.php?f=44&t=995&p=130387#p130387
Dirk1965
 

Next

Return to Zentralen (DE)