Zimo MX9 'Hauptabschnitt ' Kommandos

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby aling » 25.11.2016, 11:43

Hi Dirk,

wenn Du 8 MX9 hast sieht das so in Ordnung aus. Wichtig ist auch das die MX1 eingeschaltet und angeschlossen ist. Die MX9 müssen beim Start von RR erst auf die richtige Betriebsweise eingestellt werden.

Ich selber habe meine Geräte von ZIMO vor ein paar Jahren wegen der schleppenden Softwareentwicklung und den ständigen nicht eingehaltenen Versprechen verkauft.
Mit freundlichen Grüßen
Achim Lingner
--
BiDiB/GBMBoost/Zimo/SC7/macOS/XU3
aling
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby Dirk1965 » 25.11.2016, 12:12

Hallo Achim,

entschuldige Bitte, dass ich vorher Joachim geschrieben habe. :(

Jetzt muss Du mir Bitte erklären, woran Du erkennst, dass ich 8 MX9 habe?
Edit: Ich glaube ich habe es: bei Rückmelder kommt nur eine "2" rein,
wenn ich ein MX9 anmelde? Richtig?

Ja, die Versprechungen von Zimo laufen bis heute meist ins Leere. Da muss ich Dir 100%-ig
zustimmen. Wechseln wollte ich nicht, weil ich mir mühsam einen Fahrregler programmiert habe,
mit dem ich die Loks vom PC aus steuern kann. Ich will halt von STP weg!

Ist es möglich, dass wir am Wochenende mal telefonieren können? Das würde den Zeitaufwand erheblich minimieren. :roll:

Gruß Dirk
Dirk1965
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby Dirk1965 » 25.11.2016, 21:15

Hallo,

ich bekomme es nicht hin. Und bei allen Versuchen, die ich jetzt mit den Einstellungen probiert habe, funktionirt es leider nicht.

Mir stellt sich die Frage, ob die Software im MX1 richtig ist? Denn wie schon geschrieben, ist in meinem MX1/HS die Softwareversion 3.06 aufgespielt! Nach der 3.06 Version gab es noch weitere Testversionen, die in Bezug auf andere Softwarehersteller geändert wurde.

Mit welcher Software im MX1 ist die binäre Kommunikation getestet worden? Ich vermute, dass es nicht die 3.06 Version ist.

Gruß Dirk
Dirk1965
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 25.11.2016, 21:35

Hallo Dirk,

es ist auf basis von dieses Dokument implementiert worden:
zimo-bin-prot.pdf

Version 5.4?
You do not have the required permissions to view the files attached to this post.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby Dirk1965 » 25.11.2016, 22:02

Hallo Rob,

die PDF hat ein Datum vom 31.07.2008. Also sollte es für die MX1 Softwareversion 3.06 sein.
Aber man weiß ja nie bei ZIMO.

Die letzte Testversion ist "4.00T7".

http://www.zimo.at/web2010/support/Updatelisten_altes_System.htm
Etwas weiter unten auf der Zimo Seite.

Ich habe die 4.0T7 gerade in das MX1/HS geladen und werde mal sehen, was ich heraus finde.

Gruß Dirk
Dirk1965
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby aling » 26.11.2016, 12:53

Hallo Dirk,

ich muss mit der 3.06 gearbeitet haben. Ich habe auch Motorola-Decoder und die gehen mit den 4-Versionen nach der Beschreibung ja nicht.

Bei nur einem MX9 muss das dann die Adresse 901 haben. Du hattest doch schon Rückmeldungen im RM-Monitor. Was geht den jetzt nicht?
Mit freundlichen Grüßen
Achim Lingner
--
BiDiB/GBMBoost/Zimo/SC7/macOS/XU3
aling
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby Dirk1965 » 27.11.2016, 19:45

Hei,

ich habe mit der MX1 SWV 4.0T7 getestet und nicht wirklich Erfolg gehabt.
Also alles wieder auf Anfang. MX1 SWV 3.06 aufgespielt. Reset am MX1 durchgeführt und am MX9.

In den CVs des MX9 hatte ich Speedlimits eingestellt, die nach dem Einschalten wirksam sind.
Nachdem Reset des MX9 werden jetzt wieder alle Speedlimits auf "Stopp" gesetzt. Was ja auch sehr vernünftig erscheint.
Starte ich RR, so ist es in der Tat so, dass die Spitlimits von "Stopp"(0) auf "Freie Fahrt"(3) gesetzt werden.
Und zwar in der Reihenfolge von Hauptabschnitt(HS) 1, HS 2,......HS 8. :(

Was noch geht, dass man aus RR heraus die Befehle(z.B. Gleisspannung Ein, Halt usw.) je Block senden kann.
Dieses Verhalten läßt sich am MX31 ablesen, durch den Farbwechsel an den LEDs über den Tasten.

Fährt eine Lok in einen Block, z.B. 6, ein und überfährt den Abschnitt "a" nach "b", dann wird die Lok von RR
angehalten. Das ist auch ok. ---> Hier hätte ich jetzt das setzen eines Speedlimits erwartet. <---
Stattdessen wird die Geschwindigkeitsfahrstufe vom Ist-Zustand auf "0" gesetzt. Leider fährt die Lok aber nicht
wieder raus, da ja Fahrstufe "0" ist, wenn der kommende Block frei gegeben wird. Wartezeiten wurden berücksichtigt.

Es sind Zugnummeranzeige-Platinen im MX9 verbaut. Da jeder Zimo-Decoder die Zugnummer aussendet, werden diese von RR erkannt?

Nachtrag: 23.34 Uhr
Vermutung: Es gibt evtl. einen Fehler im Server? Denn wenn RR gestartet ist, erscheint immer folgendes im Server Fenster:
Server.PNG

Der Block ist vorhanden und läßt sich auch bedienen. Und er wird in RR als besetzt gemeldet, wenn eine Lok in dem Block steht. :roll:


Gruß Dirk
You do not have the required permissions to view the files attached to this post.
Dirk1965
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 28.11.2016, 10:49

Hallo Dirk,

Der Block ist vorhanden und läßt sich auch bedienen. Und er wird in RR als besetzt gemeldet, wenn eine Lok in dem Block steht. :roll:

der Server sagt dir nicht das Block 01 nicht existiert sonder Melder fb1a und fb1b existieren nicht welche du bei Block 01 eingetragen hast.

Vielleicht doch erst mal hier anfangen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby Dirk1965 » 28.11.2016, 11:45

Hallo Rob,

jo, stimmt. Die Blockkennung war falsch eingetragen. :oops:
Der Rest ist aber richtig.

Den Link habe ich oft gelesen. Mir erschließt trotzdem nicht,
Warum die Abschnitte des MX9 alle auf Fahrt gesetzt werden, wenn sie frei sind?
Das steht ja in meinem gestrigen Text. Und es bleibt die Frage offen, ob die Zimo-Zugnummern
erkannt werden? Und ob die Zimo Speedlimits genutzt werden?

Vielen Dank im Voraus für eine Antwort.

Gruß Dirk

ich hoffe, es sind die richtigen Dateien dabei.
issue.zip
You do not have the required permissions to view the files attached to this post.
Dirk1965
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby aling » 28.11.2016, 17:43

Hallo Dirk,

die ZIMO Zugbeeinflussung wird von Rocrail nicht verwendet und daher werden die MX9-Abschnitte auch auf Fahrt gestellt. Die ZIMO Zugnummeranzeige ist nicht getestet und wird von Rocrail auch nicht gebraucht.
Mit freundlichen Grüßen
Achim Lingner
--
BiDiB/GBMBoost/Zimo/SC7/macOS/XU3
aling
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby Dirk1965 » 28.11.2016, 18:52

Hallo Achim,

danke für Deine Antwort.
Schade, das mit den Zugnummern hätte so einiges vereinfacht. :(
Nämlich dann, wenn zum Beispiel bei einer Gartenbahn nicht jeden Tag dieselben Loks fahren.

Vielleicht bekommt Rob es noch eingebaut. 8) Bei den Tests würde ich gerne helfen.
Wenn ich es richtig erinnere, sind es nur zwei Bytes, die die Lokerkennung (Decoderadresse)
im String des Hauptabschnittes mitführen.

Danke nochmals.

Gruß Dirk
Dirk1965
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 28.11.2016, 19:22

Hi Dirk,

der Zug Erkennung ist schon drin. 2000+
Aber wie Achim schon geschrieben hat braucht Rocrail es überhaupt nicht.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby Dirk1965 » 28.11.2016, 19:48

Hei Rob,

danke für Deine Antwort. Das ist Super.

Nur eine Frage, währe es denn möglich, es doch nutzen zu können? Auch wenn RR es nicht braucht.
Und zwar dann, wenn ich eine Lok aus der Garage hole (es ist leider noch kein Schattenbahnhof vorhanden),
die Lok auf einen Block stelle und RR die erkannte Lok dem Block zuordnet ?

Gruß Dirk
Dirk1965
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 29.11.2016, 06:05

Hi Dirk,

ja, das funktioniert auch alles wie mit RailCom und RFID.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby Dirk1965 » 29.11.2016, 18:14

Hei Rob,

Achim hatte geschrieben, dass es mit der Zugnummernerkennung und MX9 von Zimo nie getestet wurde.
Ok, vielleicht hat Achim es nicht getestet oder testen können.

Aber wenn ich Dich richtig verstanden habe, Rob, dann soll es funktionieren, oder?

Gruß Dirk
Dirk1965
 

PreviousNext

Return to Zentralen (DE)