Zimo MX9 'Hauptabschnitt ' Kommandos

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby Dirk1965 » 05.12.2016, 14:13

Hallo ,

kurzes Update:
Soweit habe ich es jetzt hinbekommen, dass die Rückmelder sich einwandfrei im Gleisplan melden.

Problem ist immer noch die Zugnummernerkennung. Ich kann im Rückmelder Monitor die Zugnummern nur kurz erkennen. Soll heißen, sobald die Zugnummer unter "Code" des jeweiligen Blocks im Rückmeldermonitor angezeigt wird, ist die Zugnummer auch schon wieder weg. Da steht dann wieder eine Null, und RR hängt sich auf. :(

Soweit ich es verifizieren konnte, liegt es scheinbar an meinem USB to Serial Adapter und dessen Verarbeitung der Daten. :( Der Adapter ist neu und für Win 10; 64bit. Dieser überschüttet scheinbar den Rückmeldemonitor mit Daten.

So ein Problem hatte ich bei der Programmierung meiner Zeitnahmesoftware für meine alte Carrera Rennbahn auch. Statt einer einzelnen Messung wurden 8 Zeiten ausgegeben. (Man könnte auch Prellen dazu sagen.)

Vielleicht kann mir da jemand helfen?

Beste Grüße Dirk
Dirk1965
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 05.12.2016, 14:29

Hallo,

was hängt sich da auf? Rocview oder der Rocrail Server?
Bitte passend Traces dazu anhängen.

Normal wird ein Melder nur dann kommuniziert wenn ein Änderung vorliegt. Wenn es pausenlos kommuniziert wird dann stimmt da was nicht mit dein Hardware.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby Dirk1965 » 05.12.2016, 14:53

Hei Rob,

ich kann RocView nur über den Task-Manager beenden. Dann ist auch der RocRail Server aus.

Werde nachher (bin noch auf der Arbeit) Trace`s hier einstellen.

Normal wird ein Melder nur dann kommuniziert wenn ein Änderung vorliegt. Wenn es pausenlos kommuniziert wird dann stimmt da was nicht mit dein Hardware.


Das kann nur der USB to Serial Adapter sein. Ich habe es in meiner SW so gelöstet:

'Spur 1 (SP1) erkennen (***DSR_PIN)
Case IO.Ports.SerialPinChange.DsrChanged
If SP1 = 0 Then
SP1 = 1
Else
SP1 = 0
End If

Damit hat es funkioniert.

Gruß Dirk
Dirk1965
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 05.12.2016, 14:58

Hi Dirk,

da die foreach-Schleife alphabetisch ausgeführt wird.

klar, wenn du der Server mittels ein Arbeitsbereich startest wird es mitgerissen als Child Process von Rocview.

Rocview friert ein wegen zu viele Meldungen pro Sekunde; Scheint unter Windows schnell zu passieren.

Versuche erst mal dein Kommunikation im Griff zu bekommen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby Dirk1965 » 05.12.2016, 16:06

Hei Rob,

Versuche erst mal dein Kommunikation im Griff zu bekommen.


Hast Du einen Tipp für mich?

Die Fahrregler von RocView funktionieren einwandfrei.

Gruß Dirk
Dirk1965
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 05.12.2016, 16:13

Dirk1965 wrote:Hast Du einen Tipp für mich?


ja, hänge ein passende Server Trace hier an wenn ein Melder pausenlos gemeldet hat.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby Dirk1965 » 05.12.2016, 22:24

Hei Rob,

hier die Dateien:
issues.zip


Ich habe gestern den Gleisplan komplett neu erstellt. Es gibt kein MX9 Modul mit
der Adresse 2 mehr. Also auch keine Rückmelder mir den Adressen >12 !!! Da nur 6 Blöcke eingerichtet sind.
Aber im Rückmeldermonitor tauchen sie immer wieder mit den Adressen >2012 oder andere auf.
Es sind auch noch nicht alle Fahrstrassen komplett eingerichtet.

Ich habe einen zweiten USB to Serial Adapter genutzt. Aber das Ergebnis ist daselbe. Der Melder wird von Daten überflutet.
Ich kann an meiner HW nichts mehr ändern. Oder gibt es spezielle Einstellungen im Gerätemanager, die ein Fehlverhalten ändern würden?

Danke für die Hilfe.

Gruß Dirk
You do not have the required permissions to view the files attached to this post.
Dirk1965
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 06.12.2016, 07:32

Hi Dirk,

bitte Tracelevel Byte nur einschalten wenn ich darum frage.
Im Trace sind kein Meldungen von MX9 vorhanden.

Vielleicht sind die MX9 so konfiguriert das die ein Bestätigung erwarten für jede Meldung und schickt diese pausenlos bis ein Bestätigung ein trifft.
Ich kenne mich mit Zimo nicht aus; Bitte die Bedienungsanleitung lesen.

Als work around kannst du diese Option mal testen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby Dirk1965 » 06.12.2016, 09:55

Guten Morgen Rob,

bitte Tracelevel Byte nur einschalten wenn ich darum frage.


Ok, werde ich berücksichtigen.

Im Trace sind kein Meldungen von MX9 vorhanden.


Ok, werde mal am RR-Server mitlesen.

Ich kenne mich mit Zimo nicht aus; Bitte die Bedienungsanleitung lesen.


Die habe ich gelesen und das MX9 ist richtig eingestellt. Meldungen vom MX9 werden durch die Zimobin.dll
auch erst gesendet, wenn ein Ereignis in einem Haupt/Teilabschnitt stattfindet. Da ist alles gut.

Das mit dem Work around werde ich noch testen.

Danke und Gruß Dirk
Dirk1965
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby rjversluis » 06.12.2016, 10:34

Hi Dirk,
Dirk1965 wrote:Die habe ich gelesen und das MX9 ist richtig eingestellt. Meldungen vom MX9 werden durch die Zimobin.dll
auch erst gesendet, wenn ein Ereignis in einem Haupt/Teilabschnitt stattfindet. Da ist alles gut.

und woher kommen dann die pausenlose Meldungen her?
Versuche es in ein Server Trace zu fangen; Damit kann ich vielleicht was anfangen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby aling » 06.12.2016, 12:26

Hallo Dirk,

befreie dein MX9 doch mal von den acht Steckplatinen für die Zugnummernpulse. Vielleicht hängen die vielen Meldungen ja damit zusammen.
Mit freundlichen Grüßen
Achim Lingner
--
BiDiB/GBMBoost/Zimo/SC7/macOS/XU3
aling
 

Re: Zimo MX9 'Hauptabschnitt ' Kommandos

Postby apemberton » 02.06.2018, 21:09

Hallo Rocrailers,

Ich versuche zu diesem Zeitpunkt meinen MX1EC / MX9 mit Rocrail einzurichten. Ich werde mit den Rocrail-Einstellungen experimentieren, um das richtige Feedback von meinen MX9 (901.902.903) über MX1EC und Zimobin zu bekommen.

Ich habe den Abschnitt über Zimobin in Rocrail gelesen und ich habe keine Probleme damit, dass Loks auf Befehle reagiert. Ich möchte jetzt Sensorinformationen von den MX9 in Rocrail bekommen und es wäre sehr hilfreich, wenn Ihre Rocrail Einstellungen mir helfen könnten.

Danke im Voraus

Keine deutsche shreibe, Google translate Englischer screibe:-

I am trying to set up my MX1EC/MX9 with Rocrail at this time. I will be experimenting with the Rocrail settings to get correct feedback from my MX9's (901,902,903) via the MX1EC and Zimobin.

I have read the section on Zimobin in Rocrail and I have no problems with loks responding to commands. I now wish to get sensor information from the MX9's into Rocrail and it would be most helpful if your Rocrail settings could help me.

Thanks in advance

Tony P.
N-Scale, DR5000 and Periphs, Zimo MX1EC and periphs,
Qdecoder OstEuropa for SZD signals (pending)
Rock64 4GB Armbian Rocrail Server
Fictional location, Great Patriotic War era.
apemberton
 

Previous

Return to Zentralen (DE)