Verzögerte/Verschwundene Rückmelder und Automatik

Re: Verzögerte/Verschwundene Rückmelder und Automatik

Postby Schorse » 29.04.2017, 22:32

Hallo Ulf,

erst war es der Datendurchsatz der Zentrale, dann die nicht entprellten Rückmelder... Du kennst Dich ja gut aus...
Viele Grüße Gerd
Schorse
 

Re: Verzögerte/Verschwundene Rückmelder und Automatik

Postby ulf325 » 29.04.2017, 23:07

Schorse wrote:Hallo Ulf,

erst war es der Datendurchsatz der Zentrale, dann die nicht entprellten Rückmelder... Du kennst Dich ja gut aus...

Danke für die Blumen, wenn Du es besser weisst hättest Du mir den entscheidenen Tip ja vielleicht eher geben können
mfG: Ulf aus Magdeburg

H0 2L DCC, Roco z21, 3x Blücher GBM16 mit Railcom

Anlagenvorstellung
Modelleisenbahnfreunde Magdeburg
ulf325
 

Re: Verzögerte/Verschwundene Rückmelder und Automatik

Postby Schorse » 30.04.2017, 09:03

Moin Ulf,

Im wesentlichen habe ich meine Aufgabe darin gesehen Deine Annahmen zu dementieren, womit ich ja nicht wirklich falsch gelegen habe. :wink:
Viele Grüße Gerd
Schorse
 

Re: Verzögerte/Verschwundene Rückmelder und Automatik

Postby ulf325 » 30.04.2017, 09:43

Schorse wrote:Moin Ulf,

Im wesentlichen habe ich meine Aufgabe darin gesehen Deine Annahmen zu dementieren, womit ich ja nicht wirklich falsch gelegen habe. :wink:

Den Datendurchsatz der Zentrale kann ich selber ja nicht feststellen; und die nicht oder schlecht entprellten Rückmelder sind genau genommen immer noch die Ursache. Die Blücher Rückmelder prellen nicht, nur die Digikeijs.
mfG: Ulf aus Magdeburg

H0 2L DCC, Roco z21, 3x Blücher GBM16 mit Railcom

Anlagenvorstellung
Modelleisenbahnfreunde Magdeburg
ulf325
 

Re: Verzögerte/Verschwundene Rückmelder und Automatik

Postby rjversluis » 30.04.2017, 11:17

ulf325 wrote:Ich habe unter "Rocview" den Wert "Monitor Puffer Größe" auf 16 gestellt.

das hat damit nichts zu tun und ist eher Zufall das es eine Stunde lang ohne Verzögerungen gelaufen hat.
Wie größer der "Monitor Puffer" wie mehr CPU Leistung benötigt wird von Rocview.
Es gibt nur ein Weg: Entprellen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Verzögerte/Verschwundene Rückmelder und Automatik

Postby GeSchu » 30.04.2017, 16:10

Moin Ulf,
ich habe da mal eine Verständnissfrage:
ulf325 wrote:....... und die nicht oder schlecht entprellten Rückmelder sind genau genommen immer noch die Ursache. Die Blücher Rückmelder prellen nicht, nur die Digikeijs.

Sind deine Digikeijs Rückmelder mechanische Schalter, sprich werden dort mechanisch Schalter umgelegt oder handelt es sich um Sensoren wie z.B. Lichtschranken, Kontaktgleise oder wie auch immer? Wenn es Schalter sind, die mechanisch arbeiten, dann würde ich die doch erstmal austauschen.
Warum frage ich das?
Prellen gibt es bei mechanischen Schalter. Mir persönlich ist nicht bekannt, habe ich auch noch nicht erlebt, das Sensoren, egal welchen Aufbau die haben, prellen. Ich höre auch jetzt zum ersten Mal, das Rückmelder prellen. Erkläre doch bitte mal kurz, wie du herausgefunden hast, das Deine Rückmelder prellen. Prellen kann man durch Messen feststellen.
Oder ist es eine Vermutung von Dir?
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Verzögerte/Verschwundene Rückmelder und Automatik

Postby rjversluis » 30.04.2017, 16:15

Hi Gerd,

in Prinzip sind alle MoBa Strom/Kontakt Melder mechanisch weil diese werden mittels Metalräder und Schienen ausgelöst.
Diese mechanische Vorgang kann prellen.
Das 'entprellen' ist der aufgabe von der Melderaufnahmeelektronik. Also erst wieder frei melden wenn mindestens 1 oder 2 Sekunde lang das durch Räder und Schienen ausgelöste Kontakt weg ist. Wenn es zwischendurch wieder prellt muss diese Überwachungszeit wieder zurück gesetzt werden.
S88 & Co werden in takt abgefragt durch eine Zentrale oder so und meldet brav alles was es eingelesen hat.
In Rocrail gibt es ein software 'entprellung' aber diese hilft nicht der Datenflut zwischen Zentrale und Rocrail ein zu dämmen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Verzögerte/Verschwundene Rückmelder und Automatik

Postby GeSchu » 30.04.2017, 16:59

Moin Rob,
danke für die Erklärung. Habe ich einigermassen verstanden. Nur einigermassen, weil war mir bis dato nicht bewusst war, das dann z.B. meine Kontaktgleise auch prellen könnten. Bei den Lichtschranken kann ich mir das ganz schlecht vorstellen.
Wieder was gelernt.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Verzögerte/Verschwundene Rückmelder und Automatik

Postby Schorse » 30.04.2017, 17:04

Moin Gerd,

ich würde das diskutierte Problem mit den Rückmeldern nicht als entprellen sonder als verzögertes Ausschalten bezeichen (das hat Rob beschrieben).
Entprellen in der Elektronik oder Mikrocontroller Elektronik wird mit wesentlich kleineren Zeiteinheiten gehandhabt.
Viele Grüße Gerd
Schorse
 

Re: Verzögerte/Verschwundene Rückmelder und Automatik

Postby ulf325 » 30.04.2017, 18:52

"Leider" hat meine Anlage heute tadellos funktioniert, daher gibt es erst einmal nichts Neues.
mfG: Ulf aus Magdeburg

H0 2L DCC, Roco z21, 3x Blücher GBM16 mit Railcom

Anlagenvorstellung
Modelleisenbahnfreunde Magdeburg
ulf325
 

Re: Verzögerte/Verschwundene Rückmelder und Automatik

Postby StefanF. » 30.04.2017, 19:00

Hallo Ulf,
wieso leider? Sei doch froh, wenn es funzt. Dann kann Deine Infrastruktur ja doch nicht so schlecht sein. :)
Beste Grüße
Stefan
=========================
Zentrale: OpenDCC Z1 und 2 Booster: OpenDCC - Booster2
Loconet MGV85, 50, 93,76,77,136
Rechner: Kubuntu14.04 auf 2*Core i3 (3Monitore) 6GBRAM
=========================
StefanF.
 

Re: Verzögerte/Verschwundene Rückmelder und Automatik

Postby wuethrichs » 06.05.2017, 16:59

So mein Problem ist auch gelöst.

Ich habe ja 2 Leiter Geleis und hatte da jeweils einen Seite auf der Schiene um 1cm aufgetrennt ( ----------¦---------¦--------- ) und mit einem Draht eine Verbindung des 1cm Stück zu einem
Eingang am S88. Mit der Intellibox Basic gab es da nie Probleme aber die DR5000 hat wo H Brücken die die Intellibox wohl nicht hatt.

Auf jedenfall habe ich jetzt eine Diode zwischen Draht und S88 Eingang und siehe da alles Palletti :-)


Gruss
Stefan
___________________________________________________________________________________________
Modellbahn Spur N auf ca. 20 m2 seit Jan. 2017 im bau
Windows 10, 4Gb Ram, 2 Monitore
DCC DR5000 mit S88, Locnet, Arduino
Arduino DMX Licht
wuethrichs
 

Re: Verzögerte/Verschwundene Rückmelder und Automatik

Postby Schorse » 06.05.2017, 17:52

Hallo Stefan,

Auf jedenfall habe ich jetzt eine Diode zwischen Draht und S88 Eingang und siehe da alles Palletti
:thumb_up: Also war das negative Potential am S88 Eingang nicht negativ genug. :idea:
Viele Grüße Gerd
Schorse
 

Re: Verzögerte/Verschwundene Rückmelder und Automatik

Postby wuethrichs » 06.05.2017, 20:46

Ja ich denke das ist so.

Wieso auch immer aber jetzt geht's :-)

RM Blinkt jetzt auch richtig auf und Flackert nicht mehr nur ganz kurz
___________________________________________________________________________________________
Modellbahn Spur N auf ca. 20 m2 seit Jan. 2017 im bau
Windows 10, 4Gb Ram, 2 Monitore
DCC DR5000 mit S88, Locnet, Arduino
Arduino DMX Licht
wuethrichs
 

Re: Verzögerte/Verschwundene Rückmelder und Automatik

Postby Lok115 » 14.11.2017, 15:24

Hallo zusammen, leider finde ich keine wirkliche Lösung des Problems. Habe seit Jahren meine Bahn in Betrieb, jetzt plötzlich tritt das Problem auf. Habe Software 13011 von Heute. Die Loks schleichen über die In Melder und werden im Automaticbetrieb verzögert angezeigt.

Fahre: Spur N, Digikeiys DR 5000 (Softw. 1.44) und S88 Bus, alles über LAN an RR.

Wäre schön wenn jemand eine Lösung bieten könnte.

Gruß Manfred
Gruß

Manfred
Lok115
 

PreviousNext

Return to Zentralen (DE)