[gelöst] DINAMO läuft nicht mit langen Adressen

[gelöst] DINAMO läuft nicht mit langen Adressen

Postby MEKarlsruhe » 18.01.2018, 12:29

Hallo

Wir, die Modellbahn- und Eisenbahnfreunde Karlsruhe (MEK), bauen eine neue Clubanlage (H0-Zweileiter). Zur Steuerung wollen wir DINAMO für die Fahrspannungserzeugung nutzen, die Weichen und Signale werden per Z21 und DCC-Decoder (DR4024) gestellt. Uns ist der Mischbetrieb Analog/Digital wichtig, da es im Club und bei den Mitgliedern noch viele Analog-Modelle gibt. Um das Ganze auch ausprobieren zu können, haben wir zunächst ein Oval mit einem Ausweichgleis und zwei Weichen aufgebaut (4 Blöcke = 1 TM44). Bei der Suche nach der passenden Software sind wir von TC (kann mit DINAMO nur analog) über i-Train (kann mit Testlizenz DINAMO und Z21 wie gewünscht steuern) nun bei Rocrail angelangt.
Lernen mussten wir, dass in Rocrail die DINAMO Rückmelder-Adressen 1 – 16 sind, die Block-Adressen aber bei 0 anfangen.

Wir haben nun noch folgendes Problem:
- Digital fahren geht nur bei Loks mit kurzen Adressen (Rocrail-Einstellung „DCC – NMRA“). Wenn „DCC – NMRA long address“ in Rocrail gewählt wird, funktioniert die Lok (mit langer Adresse) nicht. Gibt es dafür eine Lösung?
An der Hardware sollte es nicht liegen, weil es mit i-Train funktioniert hat.
Last edited by MEKarlsruhe on 31.01.2018, 12:43, edited 2 times in total.
MEKarlsruhe
 

Re: DINAMO läuft nicht mit langen Adressen

Postby rjversluis » 18.01.2018, 12:43

Hallo Dietrich,

stimmt, da war der Paketlänge nicht richtig.
Ist jetzt korrigiert.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: DINAMO läuft nicht mit langen Adressen

Postby MEKarlsruhe » 18.01.2018, 13:33

Hallo Rob

Das ging aber fix, besten Dank.

Was muss ich jetzt updaten, damit es funktioniert? (Sorry für die Anfängerfrage)
MEKarlsruhe
 

Re: DINAMO läuft nicht mit langen Adressen

Postby rjversluis » 18.01.2018, 13:37

Hi Dietrich,

hier gibt es Nightly Builds:
http://rocrail.net/software/rocrail-snapshot/
Also, ab Morgen kannst du testen.

Dein Avatar geht nicht; Entweder dein Gesicht oder weglassen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: DINAMO läuft nicht mit langen Adressen

Postby MEKarlsruhe » 31.01.2018, 12:42

Hallo Rob

Lange Adressen gehen jetzt, besten Dank.
MEKarlsruhe
 


Return to Zentralen (DE)