server socket broken

server socket broken

Postby Gerard » 13.12.2017, 07:57

Hallo,

ik heb de volgende melding gekregen:
07:44:49 send() failed [10057]
07:44:49 connect(localhost:8051) failed [10061]
07:44:49 server connection is broken; try to recover...
07:44:35 Server Socket broken: errno=10054
07:44:35 *broken* errno=0, rc=10054, read=-1
07:44:12 No destination found for loco [24 044 DB] from block [b1]; Check previous trace lines.
07:44:12 empty ecos oid found for []
07:43:44 empty ecos oid found for []
07:43:25 No destination found for loco [lp] from block [b2]; Check previous trace lines.
07:43:25 [b2][lp] No free blocks available.
07:43:25 empty ecos oid found for []
07:42:44 empty ecos oid found for []
07:42:25 empty ecos oid found for []
07:42:02 Block initialising is ready.
07:42:02 Initialising all blocks...
07:35:43 empty ecos oid found for []
07:35:43 24 044 DB tried to unlock block b3 but '2 owns it!
07:35:18 empty ecos oid found for []
07:34:51 Block initialising is ready.
07:34:51 reject init block [b3] because loco [24 044 DB] is still in automode
07:34:51 reject init block [b1] because loco [24 044 DB] is still in automode
07:34:51 Initialising all blocks...
07:34:15 power off, freeze clock
07:34:10 empty ecos oid found for []
07:34:03 No destination found for loco [24 044 DB] from block [b1]; Check previous trace lines.
07:34:03 [b1][24 044 DB] No free blocks available.
07:34:02 empty ecos oid found for []
07:33:42 empty ecos oid found for []
07:33:10 empty ecos oid found for []
07:32:33 Block initialising is ready.
07:32:33 Initialising all blocks...
07:32:12 initPlan() READY

Incident aanmaken lukt niet. Trace heeft maar 4 regels.
07:55:10 Server connection lost.
07:55:07 send() failed [10057]
07:55:07 connect(localhost:8051) failed [10061]
07:55:07 server connection is broken; try to recover...

Wat moet ik hieraan doen. Het is mij eerder overkomen. Ik kan alles wel herstarten en dan werkt het weer maar kennelijk zit er ergens iets niet goed. Ik gebruik W10, laptop (i.5), kabel tussen Ecos en router.

Met vriendelijke groet,
Gerard
Met vriendelijke groet,
Gerard
Ecos 50200, Marklin C, Windows 10/i5, Locs: Märklin-Piko-Brawa-Liliput, DR 4018, DR 4088, ESU switchpilot, Ecos detector
Gerard
 

Re: server socket broken

Postby rjversluis » 13.12.2017, 08:39

Hi Gerard,

1) Rocrail op de actueelste stand brengen.
2) Als het weer gebeurt:
- Laatste server trace hier bijvoegen.
- rocrail.ini hier bijvoegen.
- Het plan.xml toevoegen.

En beschrijven na welke actie dit gebeurt.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: server socket broken

Postby Gerard » 13.12.2017, 14:43

Hallo,

dank voor je reactie. Hoe actualiseer ik rocrail? Ik heb gezocht maar kan niets vinden? Dit is mijn meest recente revisie: 13127 2017-12-01 16:16:14 +0100 rocview: extra status info at startup

Met vriendelijke groet,
Gerard
Met vriendelijke groet,
Gerard
Ecos 50200, Marklin C, Windows 10/i5, Locs: Märklin-Piko-Brawa-Liliput, DR 4018, DR 4088, ESU switchpilot, Ecos detector
Gerard
 

Re: server socket broken

Postby smitt48 » 13.12.2017, 14:58

Hi Gerard,

http://rocrail.net/software/rocrail-snapshot/

Het is mogelijk dat er een moeilijkheod is met 13202, dus in jouw geval zou ik het proberen met 13198 (een beetje lager).
De Win32 past ook op een Win64 machine. Neem die als je niet zeker bent.

Na de update can je hier zien of het gelukt is. Help->Info
http://wiki.rocrail.net/doku.php?id=rocview-info-nl


Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.3) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 


Return to Basis functionaliteit (NL)