Loc's rijden niet automatisch

Re: Loc's rijden niet automatisch

Postby rjversluis » 15.11.2016, 14:27

Hi Neelix,

dat bestaat al:
http://wiki.rocrail.net/doku.php?id=roc ... mer_events

Het wordt in de lok lijst dan aangegeven omdat er in het blok geen plaats is.

Wat de kleur van de melders betreft kun je eigen SVG's maken.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: Loc's rijden niet automatisch

Postby smitt48 » 15.11.2016, 14:29

Hi Neelix.

The wait indicator is in the "mode" field from the lok.

http://wiki.rocrail.net/doku.php?id=loc-tab-en&s[]=mode#mode
Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.4) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: Loc's rijden niet automatisch

Postby janvanderborden » 15.11.2016, 15:06

Hi Neelix

mbt wachttijd weergeven: in het loc scherm wordt tussen haakjes een getal gepresenteerd welke een indicatie is voor de wachttijd. Een indicatie want je weet nooit of andere treinen nog invloed hebben op het vertrek van de wachtende.

melders kun je misschien zelf omkleuren, alle symbolen op het scherm zijn .svg tekeningen en de files vind je terug in de rocraildirectory onder svg/thema's etc.
gr jan
janvanderborden
 

Re: Loc's rijden niet automatisch

Postby janvanderborden » 15.11.2016, 17:27

hi Neelex

ook moet je deze data nog weghalen bij de definitie van de melders


zKnipsel.JPG
You do not have the required permissions to view the files attached to this post.
gr jan
janvanderborden
 

Re: Loc's rijden niet automatisch

Postby neelix » 15.11.2016, 22:11

Jan,

Definities weggehaald, en alles werkt nog. Uitgebreid getest met verscillende loc´s en ook verschillende rijrichtingen. Na een paar keer stoppen de loc´s op de juiste plaats. In eerste instantie had ik RocRail via de USB aangesloten op de DR5000. En nu heb ik ook Rocrail met de DR5000 verbondern via mijn netwerk. Dat gaat als volgt:
1e Sluit de DR5000 aan op de usb van de computer
2e Start de DR5000 software op
3e Kies 100baseT LAN
4e Stel het protocol in op "LocoNet over TCP/IP Binary"
5e Scrhijf het ip adres van de DR5000 op (in mijn geval 192.168.2.118)
6e Sluit het "LAN Properties" window
7e Sluit de DR5000 software af
8e Start RocView op
9e Ga naar [Bestand] -> [RocRail Eigenschappen]
10e Kies het tabblad [Centrale]
11e Onder "Nieuw" kies voor Loconet en druk op toevoegen
12e Kies de "NEW" interface en druk op [Eigenschappen]
13e Kies voor "LNTCP" vul het ip adres bij "Hostnaam" in en 5550 bij "Poort"
14e Sluit het window "Loconet" af
15e Sluit het window "RocRail Eigenschappen af
16e Sluit Rocrail af, en start opnieuw op

Tenslotte op de Rocrail op de Raspberry PI geinstalleerd en opgestart. Eerst de werkruimte van mijn pc met ftp overgezet. Helaas kan de PI de bestanden niet lezen, want er komt een blanco baanplan. Is daar een oplossing voor?

m.vr.gr
Neelix
neelix
 

Re: Loc's rijden niet automatisch

Postby janvanderborden » 15.11.2016, 22:56

Hi neelix

ik dacht niet dat de DR5000 hier een item was maar OK. Je router heeft keurig een IP adres aan de DR5000 gegeven neem ik aan.

mbt de rasp heb ik geen ervaring maar RR moet op de rasp wel de juiste directory kunnen vinden en als je de werkruimte overgezet hebt is deze vast in een andere dir terecht gekomen dan op de PC dus in Rocview even vastleggen wat je opstart werkruimte is.

Als je .xml een grootte van 1kB heeft gekregen is er iets mis gegaan ;_)
gr jan
janvanderborden
 

Re: Loc's rijden niet automatisch

Postby smitt48 » 15.11.2016, 23:59

Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.4) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: Loc's rijden niet automatisch

Postby neelix » 18.11.2016, 21:44

Jan,

Je had een probleem met melder 6 op mijn baan, ik moet zeggen dat die melder bestaat uit een bocht met een wissel (ik weet dat dat niet gebruikelijk is, maar ik ben ook niet gebruikelijk. Innovatie onstaat door mensen die ongebruikelijke dingen doen). Dat was om symetrie te krijgen met de buitenste baan, waarmee de binnenste samen een station vormt. Maar ik heb er toch iets zinnigs mee kunnen doen. Ik heb in de wikie een verhaal gevonden over virtuele melders.

http://wiki.rocrail.net/doku.php?id=mic ... cript-en&s[]=virtual&s[]=sensors

Ik heb twee virtuele melders VM1 en VM2 geplaatst, die door middel van een XML script vanuit melder M6 gestuurd worden in combinatie met een test op de route. Daarmee heb ik nu een pendeltrein gemaakt, die pendelt van blok1 naar blok2 en weer terug. Met nog wat geexperimenteer met een delay stopt de pendeltrein nu perfect in blok 2. Een andere manier is er niet, omdat de DR5000 twee uitgangen heeft. De ene stuurt de baan, en de andere is het programmeer spoor, en daar voed ik blok2 mee. Deze twee uitgangen zijn galvanisch gescheiden, dat betekent dat ik de DR4088 (waar de overige 9 melders op zitten) niet kan gebruiken om melders in blok2 te maken. Of ik moet een extra DR4088 gebruiken, waarvan dan maar 1 of 2 ingangen gebruikt worden.

Dus op dat kleine experiment railplan lopen nu drie loc met wagons rond.

Zie bijlage.

m.vr.gr
Neelix
You do not have the required permissions to view the files attached to this post.
neelix
 

Re: Loc's rijden niet automatisch

Postby janvanderborden » 18.11.2016, 22:21

Tja

waarom zou je het makkelijk doen als het moeilijk kan zou ik bijna zeggen.

waarom de programmeeruitgang gebruiken om een deel van je baan te voeden ??

inderdaad het gebruik van virtuele melders en xml scripts zijn mij bekend maar op zo'n eenvoudig baantje ??

suc6
gr jan
janvanderborden
 

Re: Loc's rijden niet automatisch

Postby neelix » 18.11.2016, 22:38

Jan,

Ik wil gewoon mijn loc's kunnen programmeren zonder dat ik bedrading hoef aan te passen. Je kan natuurlijk ook op het main track programmeren, maar dan moet je wel alle andere loc's van de rails halen. Deze methode is het gemakkelijkste in het gebruik, waarom zou je het moeilijk doen, als die mogelijkheid er is. En dank zij de XML scripts is het opgelost.

m.rv.gr
Neelix
neelix
 

Re: Loc's rijden niet automatisch

Postby janvanderborden » 18.11.2016, 23:26

HI Neelix

Loc kun je mbv POM , programming on the main, ook op de hoofdbaan programmeren. Wat met POM niet kan is een loc een adres geven.
Kleine opmerking huidige locdecoders kennen POM, de ouder niet.


suc6
gr jan
janvanderborden
 

Previous

Return to Automatisch rijden (NL)