OpenSuse 13.1 en BiDiB werkt niet meer

OpenSuse 13.1 en BiDiB werkt niet meer

Postby kees » 03.09.2014, 15:50

[attachment=2]rocview.000.trc[/attachment]
Enige tijd geleden heb ik van Bidib de GBM Boost gebouwd en deze was ook direct in Rocrail te gebruiken. Daarna de Lightcontrol gebouwd en dat gaf ook geen problemen.
Dat alles in combinatie met OpenSUSE linux. Op het moment dat OpenSUSE werd geupgrade naar 13.1 ging het mis. Rocrail kon opeens de hardware niet meer vinden.
Uiteindelijik OpenSUSE geheel opnieuw geinstalleerd, maar het probleem bleef.
Ook BidiB-wizard kan de nodes niet meer vinden, maar meldt "Communication met master not established". Teleurgesteld alles maar een tijd laten liggen, maar de vakantieperiode is een mooi moment om hier nog eens naar te kijken. In het Forum dit niet kunnen vinden, dus nu meld ik mij toch zelf maar.

Via het confungaratiesysteem heb ik de gebruiker Kees rechten verschaft op het gebied van dialout, tty, uucp, lock en users.Rocview.trc blijft melding maken van:
" 20140901.122001.498 g9999W main frame 3114 open workspace="/opt/rocrail/rocrail -l "/opt/rocrail" -w "/home/kees/rocrail""
20140901.122001.500 g9999I main app 1634 connecting... waitloops=300
20140901.122001.500 g8020E main OSocket 0407 connect(localhost:8051) failed [111] [Connection refused]"
Dit lijkt op ene probleem met rechten, maar ik kom hier niet uit.

Ik hoop dat jullie me hiermee kunnen helpen. Het alternatief is dat ik meld bij het forum van OpenSUSE. Alvast heel hartelijk dank

Kees
You do not have the required permissions to view the files attached to this post.
kees
 

Re: Open Suse, Rocrail en Bidib

Postby rjversluis » 03.09.2014, 16:05

Hi Kees,

de rocrail trace past niet bij de rocrail.ini want daar wordt alleen een virtual centrale gebruikt terwijl in de rocrail.ini bidib staat.
De socket error in de rocview trace komt omdat de server niet gestart is.

Het lijkt erop dat alles door elkaar ligt bij jou installatie.

Hoe kom je trouwens op OpenSuse?
IMHO de meest lastige Linux distro. Stukken beter zijn Ubuntu en Mint.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: OpenSuse 13.1 en BiDiB werkt niet meer

Postby kees » 03.09.2014, 21:17

[attachment=2]rocrail.009.trc[/attachment]Beankt voor je snelle reactie.

In een ver verleden ben ik van Windows 98 overgestapt op Suse Linux (zoals dat toen nog heette). Een enkele keer een andere distributie geprobeerd, maar uiteindelijk tocht steeds weer hiernaar teruggekeerd. Alles werkt ook, alleen de trein rijdt niet.

In het verlengde van jouw bericht het programma Rocrail verwijderd en de map Rocrail met alle configuratiebestanden weggegooid.
Rocrail 7874 geinstalleerd en nog maar eens van voor af aan begonnen.
De eerste indruk is dat geen enkele verandering zie. De voorbeeldbaan iets aangepast en opgeslagen als BaanvanKees. Aagengeven welke werkruimte bij de start moet worden geopend. Rocrail geeft vervolgens als optie ook aan dat ik offline kan werken.
Het valt me wel op dat alleen de baan gekleurd is terwijl de rest egaal grijs is. Ik zal wel iets simpels over het hoofd zien, maar ik kom er nog niet uit.
De laatste configuratiebestanden nog maar eens meegezonden.
Alvast heel hartelijk dank
Kees
You do not have the required permissions to view the files attached to this post.
kees
 

Re: OpenSuse 13.1 en BiDiB werkt niet meer

Postby rjversluis » 04.09.2014, 05:55

Mogge Kees,

in de Rocrail trace ziet het er goed uit alleen de GBMBoost Master reageert niet; Was deze aangesloten tijdens de test?

Ook Rocview of een andere client heeft verbinding met de Rocrail server:
Code: Select all
20140903.215836.831 r9999I cconmngr OClntCon 0395 client connect count: 1

De Rocview trace past van de tijd niet bij de Rocrail trace.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: OpenSuse 13.1 en BiDiB werkt niet meer

Postby kees » 04.09.2014, 21:06

Eerst de Lightcontrol maar losgekoppeld en alle draden gecontroleerd. Ik heb een klein baantje op de grond van de huiskamer liggen en op het moment dat ik daar iets mee wil doen moet ik gaan schuiven met apparatuur. Dat geeft risicos's op draadbreuk etc. Op het moment dat ik Digib inschakel voert het systeem en zelftest uit. Daarna geeft een aantal LED's de status van het systeem weer. Dat zie er op zich allemaal goed uit.
Het veld voor de serverberichten in Rocrail meldt echter dat er geen commandstation is aangesloten.
Ik heb een loc op de baan staan waarvan de verlichting permanent brand, dus er staat spanning op de baan. Ik had een foto gemaakt van het digitale spanningsbeeld op de oscilloscoop. Bij het Absenden was het ik hele bericht kwijt (foto zeker te groot), dus nu maar zonder.

Bij de opwaardering naar OpenSUSE 13.1 is m.n. "AppArmor enabled by default". OpenSUSE meldt vervolgens zelf "This means more security, but might prevent services from working, if you run them in unexpected ways." Ik zal eerst maar eens bij OpenSUSE informeren of er meer berichten zoals dat van mij zijn ontvangen.

Ik wil jullie om te beginnen heel hartelijk danken voor de ondersteuning.

Met vriendelijke groet,
Kees
kees
 


Return to Centrales (NL)