IRM-Module senden immer den BUS x

http://www.opendcc.de
http://www.bidib.org

IRM-Module senden immer den BUS x

Postby Hilbrand » 08.01.2018, 13:25

Hallo,

Habe ein Problem mit der Rückmeldung, mit dem IRM-Modulen von Fichtelbahn.
Ich steuere meine Anlage über BIDIB mit der Zentrale GBMboostMaster, RF-Basis.
Der Car-Decoder sendet über Funk an die Zentrallen die Daten was das IRM-Modul dem Car-Decoder übermittelt.
Aber die IRM-Module senden immer den BUS 41988074 und Adresse 0 obwohl die Adresse schon umprogrammiert ist
Bei einem anderen Programm Übermittelt das IRM-Modul die richtige Adresse.

Aber warum geht das nicht auf Rocrail???

Vielen Dank!
Hilbrand
 

Re: Open Car System

Postby rjversluis » 08.01.2018, 13:43

Hi,

bitte die übliche Dateien anhängen.
(Siehe Signatur)

http://wiki.rocrail.net/doku.php?id=ope ... booster-de
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Open Car System

Postby ups60 » 08.01.2018, 14:30

rjversluis wrote:Hi,

bitte die übliche Dateien anhängen.
(Siehe Signatur)

http://wiki.rocrail.net/doku.php?id=ope ... booster-de

Hi Rob,

ich vermute, Hilbrand hat das gleiche Problem wie ich in diesem Beitrag viewtopic.php?f=47&t=13549&p=153693#p153693.

Mir ist dabei noch aufgefallen, daß im Rückmeldermonitor beim auslösen des IRM die Adresse des Fahrzeugs bei Code zurückgemeldet wird und nicht die Adresse des IRM.

Kann es damit zusammen hängen, daß bei energypercentage (battery) ein = als Trenner übergeben wird, beim position aber ein : ?

mfg Uwe
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: Open Car System

Postby rjversluis » 08.01.2018, 14:35

Hi Uwe,

mein Stand der Dinge ist:
Code: Select all
      20170912.105550.516 r9999c rfbooste ORFBOOST 0397 received: [Car->:3 Msg_Nr:2 an Position:513]
      20170912.105550.557 r9999c rfbooste ORFBOOST 0397 received: [Car->:3 Msg_Nr:3 an Position:513]
      20170912.105550.588 r9999c rfbooste ORFBOOST 0397 received: [Car->:3 Msg_Nr:4 an Position:513]
      20170912.105550.629 r9999c rfbooste ORFBOOST 0397 received: [Car->:3 Msg_Nr:7 an Position:513]
      20170912.105550.660 r9999c rfbooste ORFBOOST 0397 received: [Car->:3 Msg_Nr:10 an Position:513]

wo ist da dann eine Fragezeichen?

Wobei hier 513 der MelderID wird in Rocrail.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Open Car System

Postby rjversluis » 08.01.2018, 14:39

ich vermute, Hilbrand hat das gleiche Problem wie ich in diesem Beitrag viewtopic.php?f=47&t=13549&p=153693#p153693.

da scheint, außerhalb dein Skript ,alles zu funktionieren.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Open Car System

Postby rjversluis » 08.01.2018, 14:56

@Hilbrand: Wenn du hier keine Daten anhängst kann ich nicht weiter helfen.

Anscheinend kommuniziert der RF-Basis bei dir über BiDiB anstatt USB/Seriell.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Open Car System

Postby Hilbrand » 08.01.2018, 15:23

Hi,

Meine Zentrale(Interface) GBMboostMatser ist mit usb am PC verbunden.
Aber alle anderen knoten laufen über BIDIB.
Also auch meine RF-Basis für die Auto Steuerung .
Die IRM-Module Sind selbständiges Module
Habe erst angefangen mit der Steuerung mit Rocrail .
Nur mein Problem ist das im Rückmelder-Monitor keine adresse anzeigt
Und ohne adresse kann ich sie nicht zuordnen
programiert habe ich die IRM-Module mit Wizard und dort gehts
Last edited by Hilbrand on 08.01.2018, 15:34, edited 1 time in total.
Hilbrand
 

Re: Open Car System

Postby ups60 » 08.01.2018, 15:25

rjversluis wrote:Hi Uwe,

mein Stand der Dinge ist:
Code: Select all
      20170912.105550.516 r9999c rfbooste ORFBOOST 0397 received: [Car->:3 Msg_Nr:2 an Position:513]
      20170912.105550.557 r9999c rfbooste ORFBOOST 0397 received: [Car->:3 Msg_Nr:3 an Position:513]
      20170912.105550.588 r9999c rfbooste ORFBOOST 0397 received: [Car->:3 Msg_Nr:4 an Position:513]
      20170912.105550.629 r9999c rfbooste ORFBOOST 0397 received: [Car->:3 Msg_Nr:7 an Position:513]
      20170912.105550.660 r9999c rfbooste ORFBOOST 0397 received: [Car->:3 Msg_Nr:10 an Position:513]

wo ist da dann eine Fragezeichen?

Wobei hier 513 der MelderID wird in Rocrail.


Hi Rob,

sorry, kein Fragezeichen, sondern ein Doppelpunkt (:). Bei battery (energypercentage) ists ein = . Eine Auswertung von position im Script wird m.E nicht ausgewertet bzw. ist immer 0 (null).

mfg Uwe
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: Open Car System

Postby rjversluis » 08.01.2018, 15:29

Hi Uwe,

dieses Thema geht nicht um XMLScript, sondern Positionsmeldungen über BiDiB.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Open Car System

Postby rjversluis » 09.01.2018, 21:46

Hilbrand wrote:Hi,

Meine Zentrale(Interface) GBMboostMatser ist mit usb am PC verbunden.
Aber alle anderen knoten laufen über BIDIB.
Also auch meine RF-Basis für die Auto Steuerung .
Die IRM-Module Sind selbständiges Module
Habe erst angefangen mit der Steuerung mit Rocrail .
Nur mein Problem ist das im Rückmelder-Monitor keine adresse anzeigt
Und ohne adresse kann ich sie nicht zuordnen
programiert habe ich die IRM-Module mit Wizard und dort gehts

Na dann hänge doch mal ein Byte trace hier an wo sich ein Irm meldet.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: IRM-Module senden immer den BUS x

Postby Bergi » 09.01.2018, 21:55

Hallo Rob,
Fahrzeuge lösen beim Empfang des IRM eine MSG_BM_POSITION aus.
viele Grüße
⋄ Andreas Bergmaier - http://bidib.org/
Bergi
 

Re: IRM-Module senden immer den BUS x

Postby rjversluis » 10.01.2018, 07:41

Bergi wrote:Hallo Rob,
Fahrzeuge lösen beim Empfang des IRM eine MSG_BM_POSITION aus.

Ja, und das ist schon länger unterstützt in Rocrail.
Ich kann es leider nicht selbst testen. RF-Basis habe ich.
Also muss Hillbrand Daten liefern welche ich auswerten kann.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: IRM-Module senden immer den BUS x

Postby ups60 » 10.01.2018, 10:04

Moin Rob,

doppelt:
You do not have the required permissions to view the files attached to this post.
Last edited by ups60 on 10.01.2018, 10:07, edited 1 time in total.
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: IRM-Module senden immer den BUS x

Postby ups60 » 10.01.2018, 10:06

Moin Rob,

ich habe auch eine RF-Basis. Ich hab Dir mal eine Byte,Monitor und Infolevel Trace hier angehängt. Um ca. 09.55 habe ich einen Ausgang über Rocnet ausgelöst, der einen IRM mit programmierter Adresse 16 zurückgeben sollte.

mfg Uwe
You do not have the required permissions to view the files attached to this post.
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: IRM-Module senden immer den BUS x

Postby aling » 10.01.2018, 10:25

Hallo Uwe,

in diesem speziellen Fall must Du einen Rückmelder mit der ID "16" (http://wiki.rocrail.net/doku.php?id=sensor-gen-en) anlegen und nicht mit der Adresse 16.
Mit freundlichen Grüßen
Achim Lingner
--
BiDiB/GBMBoost/Zimo/SC7/macOS/XU3
aling
 

Next

Return to OpenDCC-BiDiB (DE)