Background colour of block symbol Topic is solved

Post Reply
RCGeek
Posts: 55
Joined: 29.12.2018, 11:18

Background colour of block symbol

Post by RCGeek » 05.05.2019, 02:26

A minor issue but one I would like to understand. When a loco leaves a block sometimes the block background colour changes to white but sometimes its stays coloured. Is there any significance to this?

hermannk
Moderator
Posts: 1150
Joined: 06.07.2014, 12:32
Location: Kiel Germany

Re: Background colour of block symbol

Post by hermannk » 05.05.2019, 03:37

Hi Richard,
you will find the "Color and state of Blocksymbols" at
- https://wiki.rocrail.net/doku.php?id=bl ... lock_state
As soon as the loco has reached the next block this current block should be "free" and should be of color "white".
In other words: if this block does not become "white" the loco has not reached the next block.
Regards
Hermann

RCGeek
Posts: 55
Joined: 29.12.2018, 11:18

Re: Background colour of block symbol

Post by RCGeek » 06.05.2019, 08:46

Thanks Hermann

How does a block become "Reserved"?

hermannk
Moderator
Posts: 1150
Joined: 06.07.2014, 12:32
Location: Kiel Germany

Re: Background colour of block symbol

Post by hermannk » 06.05.2019, 15:24

Hi Richard,
a loco starts traveling from block A to block B then
- block A is "occupied" (color "Pink") and
- block B is "reserved" (color "Yellow").
As soon as the loco activates the ENTER sensor of block B
- the block B becomes the color "Blue" (and block A is still occupied).
Now the loco activates the IN sensor of block B
- the block B becomes "occupied" (color "Pink") and block A becomes "free" (color "White").
see:
- https://wiki.rocrail.net/doku.php?id=bl ... lock_state
Regards
Hermann

RCGeek
Posts: 55
Joined: 29.12.2018, 11:18

Re: Background colour of block symbol

Post by RCGeek » 07.05.2019, 09:30

Thanks again Hermann.

I now understand more but why does the system sometimes show the Loco Id in a Reserved block and sometimes it does not?

Sorry to be a pest but I want to really understand RR.

Regards
Richard

smitt48
Moderator
Posts: 6114
Joined: 04.04.2014, 01:07
Location: Kralendijk, Bonaire - Dutch Caribbean

Re: Background colour of block symbol

Post by smitt48 » 07.05.2019, 12:54

Hi Richard,

Just show us pictures if it doesn't. Also create an issue. https://wiki.rocrail.net/doku.php?id=issue-en

Tom

RCGeek
Posts: 55
Joined: 29.12.2018, 11:18

Re: Background colour of block symbol

Post by RCGeek » 08.05.2019, 07:30

Please see attached issue.zip

Regards
Richard
You do not have the required permissions to view the files attached to this post.

hermannk
Moderator
Posts: 1150
Joined: 06.07.2014, 12:32
Location: Kiel Germany

Re: Background colour of block symbol

Post by hermannk » 08.05.2019, 08:40

Hi Richard,
simulating with your data is working fine.
In addition to the issue files a screenshot would have been helpful to understand your request.
The "green" background color is caused by the configuration of "Accept BiDi Loco" to blocks "05" and "06".
Regards
Hermann
You do not have the required permissions to view the files attached to this post.

RCGeek
Posts: 55
Joined: 29.12.2018, 11:18

Re: Background colour of block symbol

Post by RCGeek » 10.05.2019, 00:43

Thanks Hermann
Richard

Post Reply

Return to “Automatic mode”