troppo lento

troppo lento

Postby andez8 » 21.08.2010, 10:19

ciao a tutti,
scrivo qui perche il mio inglese e' troppo mediocre
spero nel vostro aiuto.
perchè Rocrail col mio pc arriva sempre (quasi) dopo che il treno è passato sul blocco (e va oltre) ?
il mio pc è troppo vecchio (pentium III 433MHz with Windows XP) o è un mio problema di settaggio ?
questo in automatic mode (senza schedule);
- vedo sullo schermo rocRail (sul disegno del plastico) che i sensori modificano lo stato quando il treno li attraversa (o ci passa sopra), ma non derivano azione, questo viene dopo (anche molto).
provo con un lento treno merci, e va bene,
provo con un treno IC ed oltrepassa i blocco ( poi si ferma, o RocRail stoppa per ghost train ).
è la comunicazione lenta tra PC e centrale?
prima utilizzavo RocRail col DXX (niente centrale) pensavo fosse questo,
ora RocRail con GenLI-S88 e nuova centrale (XpressNet) ma è lo stesso.
qualcuno mi può aiutare ?
grazie Andrea
andez8
 

Postby sergio » 22.08.2010, 08:00

sto facendo le stesse prove, cominciate solo ieri, per preparare l' esposizione di Natale.
Al momento sono ancora molto indietro, ma visto che per l' hardware che ho a disposizione ci sono PC come il tuo, sto pensando di fare prove anche con Win 98 oppure (meglio) ad una soluzione Linux con Ubuntu 10.04, che sto usando oramai per altre applicazioni in quanto Win mi fa venire il latte alle ginocchia.....
Quello che mi da' soprattutto fastidio di Win, che all' accensione l' antivirus si prende il controllo del PC e per un bel po' non si ha modo di fare nulla. Con Ubuntu, di virus, neanche l' ombra, mai visto uno.... .
Altro aspetto intereesante da valutare, differenza di comportamento tra DDX e la GenLi con Xpressnet - nel mio caso devo capire anche la differenza di comportamento tra decoder Horniby 8249 e Lenz.....
Come vedi di prove ne ho da fare moltissime, e non ho risposto per nulla alla tua questione, ma forse cominciando da un sistema operativo piu' reattivo potrebbe essere un punto di partenza, visto che lassu' i smanettatori di questo software hanno da sempre privilegiato l' ambiente Linux nelle varie distribuzioni.
Piu' avanti, ma molto piu' avanti, quando avro' fatto un bel po'' di prove (soprattutto di affidabilita' - che ne e' l'aspetto consequenziale dei tempi di risposta), faro' sapere i risultati.
ciao - sergio
Why busy with Rocrail?? Because not too young to play trains, nor too old to learn something new.
http://www.amc-chiaravalle.org
sergio
 

Postby andez8 » 25.08.2010, 19:16

ciao Sergio,
ci si risente, ogni tanto,
grazie comunque per la risposta.
purtroppo ho solo Win
ed ho già riscontrato quanto da te lamentato;
vero, latte ai gincchi ! ! !
tantìevvero che avevo tolto l'antivirus
e mi sono giocato il pc
(formattato con perdita di tanti doc).
con DDX anche io avevo problemi di risposta
coi dec Zimo, bho ! ! ! ma gli esu erano OK.
ora con la centrale KDCC (di Despx)
connessa tramite la GenLi
rispondono tutti bene.
ma sono cambiati tutti gli indirizzi degli s88
e poi degli scambi:
il passaggio e' stato un trauma
non ancora risolto.
speriamo qualcun altro legga e ci possa aiutare.
a risentirci, Andrea
andez8
 

Postby sergio » 25.08.2010, 20:22

per velocizzare, qualcuno mette il server su un pc ed il client su un altro.
ciao - sergio
Why busy with Rocrail?? Because not too young to play trains, nor too old to learn something new.
http://www.amc-chiaravalle.org
sergio
 

Postby eroncelli » 28.08.2010, 19:02

Con PC vecchi è utile disattivare il "trace" dei comandi (avevo lo stesso inconveniente su un PC con Win 98SE; utlizzando una macchina più recente con Win XP e tutto il resto uguale il problema spariva).
Comunque non è un problema legato a Windows: anche se è meglio eliminare anche tutti i SW che girano in background.
A presto e buon lavoro (io al momento sono fermo perché cambierò i locali dove stavo costruendo il plastico).
Eugenio
HO Maerklin, CS2+MS2, PC with Win10, Android phone, electronics by IEK, decoder by Maerklin-ESU-TAMS
".. and let your dog enjoy Rocrail"
eroncelli
 

Postby andez8 » 30.08.2010, 10:15

ciao,
grazie anche a te Eugenio,
il "trace" da eliminare, dove lo trovo ?
è quello in proprietà di rocrail o rocview ?
Andrea
andez8
 

Postby eroncelli » 30.08.2010, 18:49

Prova ed eliminarli uno alla volta (prima quello di Ricrail): dovresti avere un significativo aumento della velocità di risposta.
Anche far girare i 2 sistemi su 2 macchine, come già indicato, è una soluzione: richiede però 2 PC.
Facci sapere gli sviluppi.
Eugenio
HO Maerklin, CS2+MS2, PC with Win10, Android phone, electronics by IEK, decoder by Maerklin-ESU-TAMS
".. and let your dog enjoy Rocrail"
eroncelli
 


Return to Modalità automatica (IT)

cron