SOLVED Power icon not updated after external power command

Märklin Central Station 2

Re: SOLVED Power icon not updated after external power comma

Postby rjversluis » 01.04.2014, 14:12

Hi Bert,

check your trace; I read a sub cmd 6.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: SOLVED Power icon not updated after external power comma

Postby woodyboy » 01.04.2014, 14:49

Hi Rob,

Yes, I agree, but thats the command for altering the default accessory command time. I just installed 7084 and I got a CS STOP, but never a CS GO :?: Inspecting my CAN packets learned that the MS2 sends:

00 00 37 35 07 00 00 00 00 09 00 03 00

The Gleisbox is reacting to this command as a GO and replies conform specs :?: :shock:

Now I know it's foolday ..... but this is quit new to me. I should expect:
00 00 37 35 05 00 00 00 00 01 00 00 00

I adapted my sketch to insert the last command after the sub cmd 9 packet and its working like a charm.
But strange... isn't it?
Regards,

Bert

Equipment: Roco WLANMaus, MS2, Gleisbox 2x(separated switch & rollingstock). Ubuntu 16. Edits booster. Arduino: S88 CANbus interface & Ethernet-CANbus gateway
woodyboy
 

Re: SOLVED Power icon not updated after external power comma

Postby woodyboy » 04.04.2014, 11:12

Forget my last reply. This is due to a "heavy" :wink: loaded CAN bus with no available receivebuffers. In better words my sketch is to slow to run up with the received messages. :oops: I have something to fix :coding: .
Regards,

Bert

Equipment: Roco WLANMaus, MS2, Gleisbox 2x(separated switch & rollingstock). Ubuntu 16. Edits booster. Arduino: S88 CANbus interface & Ethernet-CANbus gateway
woodyboy
 

Previous

Return to CS2