IB2 (ulni) echo timer timed out for OPCODE 0xBB

Uhlenbrock new generation CS-Line
Post Reply
cfour
Posts: 8
Joined: 03.12.2018, 11:54

IB2 (ulni) echo timer timed out for OPCODE 0xBB

Post by cfour » 06.12.2018, 13:04

Hello

under windows everything is fine. On a freshly installed RaspberryPi it comes immediately after start from the rocrail server to regular error message.

The controller commands reacts strongly delayed. Setting in rocrail is default.

Greetings, cfour
Attachments
rocrail.trc
(16.41 KiB) Downloaded 3 times
rocrail.ini
(4.26 KiB) Downloaded 3 times
plan.xml
(6.93 KiB) Downloaded 3 times
occ.xml
(232 Bytes) Downloaded 3 times
issue.txt
(1.72 KiB) Downloaded 5 times

alef201
Posts: 2
Joined: 11.03.2019, 15:31

Re: IB2 (ulni) echo timer timed out for OPCODE 0xBB

Post by alef201 » 11.03.2019, 16:23

The same problem.

Hello,

I am new in rocrail from Czech Republic. I have the commnand station Intellibox 2 and loconet & DCC accessories.

I installed rocrail sw 15166 (rocrail , rocview, and andRoc on android). All configuration I did according to the manual for IB2 (loconet, ulni / 115200 / ibcom) .

All seems to be working well if command station is running on Windows 10 (my notebook).

Under Linux (raspberry pi 2, raspbian version 9 (stretch) , uname -a Linux raspberrypi 4.19.27-v7+ #1206) all installation seems to be ok too, services are running, but the communication with Intellibox 2 seems to be a problem.
I received a lot of error messages like "echo timer timed out for OPCODE" (different codes) in the console. For accessories switches, signals it worked somehow, but control of locomotives is big issue,
some commands from sw throttle were not processed at all or delayed few seconds, command station became unresponsive.

dmesg (after putting cable to usb plug)
[ 551.834853] usb 1-1.3: new full-speed USB device number 6 using dwc_otg
[ 551.974112] usb 1-1.3: New USB device found, idVendor=10c4, idProduct=ea60, bcdDevice= 1.00
[ 551.974134] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 551.974149] usb 1-1.3: Product: CP2102 USB to UART Bridge Controller
[ 551.974161] usb 1-1.3: Manufacturer: Silicon Labs
[ 551.974172] usb 1-1.3: SerialNumber: 0001
[ 551.988290] cp210x 1-1.3:1.0: cp210x converter detected
[ 551.991793] usb 1-1.3: cp210x converter now attached to ttyUSB0

Missing (in comparison with manual)
cp2101: Silicon Labs CP2101/CP2102 RS232 serial adaptor driver v0.07

lsusb
Bus 001 Device 006: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x UART Bridge / myAVR mySmartUSB light
Bus 001 Device 004: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Is there any solution for linux ? Is it linux version / kernel dependent (linux modules cp210x, usbserial) ?

Thanks.

Ales

LDG
Site Admin
Posts: 2624
Joined: 18.10.2010, 00:03
Location: near Karlsruhe/Germany

Re: IB2 (ulni) echo timer timed out for OPCODE 0xBB

Post by LDG » 11.03.2019, 17:03

Hello Ales,

the full device name for your IB2 will be: /dev/ttyUSB0

The user starting rocrail has to be member of the group "dialout" to access the "tty"-devices (serial and/or usb).
Check on linux command line with command: id

If not listed in groups then (on Raspbian) you may use

Code: Select all

sudo adduser <user> dialout
or (same effect)

Code: Select all

sudo usermod -a -G dialout <user>
(replace <user> by your username -> whoami )

Logout and (re)login to get the group change activated.

Regards,
Lothar

smitt48
Moderator
Posts: 5564
Joined: 04.04.2014, 01:07
Location: Kralendijk, Bonaire - Dutch Caribbean

Re: IB2 (ulni) echo timer timed out for OPCODE 0xBB

Post by smitt48 » 11.03.2019, 18:52

Hi ALes,

Welcome to Rocrail!

Tom

alef201
Posts: 2
Joined: 11.03.2019, 15:31

Re: IB2 (ulni) echo timer timed out for OPCODE 0xBB

Post by alef201 » 11.03.2019, 21:53

Hi,

thank you for quick response.

I had proper setup of usb device /dev/ttyUSB0 from the beginning.
I did not add pi user to the dialup group till now (I will try), but I started services via command sudo service rocraild start, so access rights should not have any impact.

I tried re-install the whole raspberry again and installed kernel 4.14 (not the latest 4.17...).
It is significantly better, but still sometimes there are errors in console "timer timed out for OPCODE: and control of locomotives react with delay.

Are there any problems with other control stations on linux/raspberry ?
Is anybody with IB2 without problems on the latest Stretch Raspbian ?

Remark: I saw in kernel description some changes in implementation of usb serial module(s), which could have some impact.

Regards.

Ales

rjversluis
Site Admin
Posts: 39295
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: IB2 (ulni) echo timer timed out for OPCODE 0xBB

Post by rjversluis » 12.03.2019, 10:07

Hi Ales,

its not a good idea to run Rocrail in Root context, and is no longer supported.
This is the preferred way:
https://wiki.rocrail.net/doku.php?id=ro ... ux-user-en

Post Reply

Return to “IB-Basic IB-Com IB2”