Settings needed in IB-COM for mixed DCC/Motorola layout

Uhlenbrock new generation CS-Line

Postby rjversluis » 24.08.2011, 09:21

Hi Hans,

it seems that WDP had the same problem which has been solved in the latest release.
Maybe it can give us a clue if you could do the same test as with the 'other' program.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Postby hclaassens » 24.08.2011, 10:14

Hi Rob,

I'll give it a try tonight
Hans

rjversluis wrote:Hi Hans,

it seems that WDP had the same problem which has been solved in the latest release.
Maybe it can give us a clue if you could do the same test as with the 'other' program.
hclaassens
 

Postby hclaassens » 24.08.2011, 21:01

Hi Rob,

Here are the trace files of the windigipet demo version with the 2 locos created. Note that the loc speed is incremented by wdp. I see a lot of differences but I need more time to study it. The read of slot=0 is also here, but it reads more slots.

hclaassens wrote:Hi Rob,

I'll give it a try tonight
Hans

rjversluis wrote:Hi Hans,

it seems that WDP had the same problem which has been solved in the latest release.
Maybe it can give us a clue if you could do the same test as with the 'other' program.
You do not have the required permissions to view the files attached to this post.
hclaassens
 

Postby hclaassens » 24.08.2011, 21:14

Hi Rob,

I've made another trace file. This time I've used the ib_util.exe util from Uhlenbrock. This util is used add locos to the ib-com, default protocol and so on. But you can also drive locos with it and that is what I did. It is a lot less communication.

Hans


hclaassens wrote:Hi Rob,

I'll give it a try tonight
Hans

rjversluis wrote:Hi Hans,

it seems that WDP had the same problem which has been solved in the latest release.
Maybe it can give us a clue if you could do the same test as with the 'other' program.
hclaassens
 

Postby rjversluis » 24.08.2011, 21:40

Hi Hans,

should I wait for your evaluation before I check the wdp sniffer trace?
I did not look in to them jet, but reading your comment the wdp program does something like pinging slots...

Its a pity that a named manu like Uhlenbrock does not contribute to this issue. Whats in steak?
The LocoNet PE does not provide information on how to convince Command Stations to keep up refreshing slots... Its the main job of the CS!

I have worked a long time in the industrial process automation, but if we had to deal with model train Command Station manufacturers we would have a major catastrophe.

Now I stop this posting before I type words I will regret. ;)
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Postby rjversluis » 25.08.2011, 06:49

Hi Hans,

hclaassens wrote:I've made another trace file. This time I've used the ib_util.exe util from Uhlenbrock. This util is used add locos to the ib-com, default protocol and so on. But you can also drive locos with it and that is what I did. It is a lot less communication.


did you forget to attach this trace?
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Postby hclaassens » 25.08.2011, 06:53

Hi Rob,

I probably did. Sorry.
It is not allowed to add .trc file it seems, so a .zip now

Hans

rjversluis wrote:Hi Hans,

hclaassens wrote:I've made another trace file. This time I've used the ib_util.exe util from Uhlenbrock. This util is used add locos to the ib-com, default protocol and so on. But you can also drive locos with it and that is what I did. It is a lot less communication.


did you forget to attach this trace?
You do not have the required permissions to view the files attached to this post.
hclaassens
 

Postby hclaassens » 25.08.2011, 07:00

Hi Rob,

No, you shouldn't wait. I just want to say I did not have the time to study the trace files and protocol description in the wiki last night.

Hans

rjversluis wrote:Hi Hans,

should I wait for your evaluation before I check the wdp sniffer trace?
I did not look in to them jet, but reading your comment the wdp program does something like pinging slots...

Its a pity that a named manu like Uhlenbrock does not contribute to this issue. Whats in steak?
The LocoNet PE does not provide information on how to convince Command Stations to keep up refreshing slots... Its the main job of the CS!

I have worked a long time in the industrial process automation, but if we had to deal with model train Command Station manufacturers we would have a major catastrophe.

Now I stop this posting before I type words I will regret. ;)
hclaassens
 

Postby rjversluis » 25.08.2011, 07:19

Hi Hans,

now we see that this utility programs the IB-COM:
Code: Select all
PGM ABORT
    offset:   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F |ASCII...........|
    --------------------------------------------------------- |----------------|
    00000000: E6 15 00 01 20 1A 00 06 00 00 00 00 00 00 52 11 |.... .........R.|
    00000010: 00 00 00 00 72                                  |....r           |

OPC_IMM_PACKET
    offset:   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F |ASCII...........|
    --------------------------------------------------------- |----------------|
    00000000: ED 0F 01 49 42 0D 00 1A 00 00 00 00 00 00 00    |...IB.......... |
lnreader lnmon    1586 Weird Send Packet Immediate, 3rd byte id 0x01 not 0x7f

OPC_PEER_XFER
    offset:   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F |ASCII...........|
    --------------------------------------------------------- |----------------|
    00000000: E5 0F 00 49 4B 0B 04 1A 00 52 11 1A 00 00 5B    |...IK....R....[ |

The format of the packets is LN-PE but the content is free to define.
As long as Uhlenbrock does not document this contents we only can use both packets hard coded and hope it works...
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Postby hclaassens » 25.08.2011, 08:07

Hi Rob,

I've seen that the reading of the dispatch slot is also in the trace.
So may I suggest to leave that in and add both packets hard coded in a test version of loconet.c. If you can give me that file, I will test it.

In the mean time I am going to call the technical guy of the dutch representative of Uhlenbrock (hobbytime) and try to get some information.

Hans


rjversluis wrote:Hi Hans,

now we see that this utility programs the IB-COM:
Code: Select all
PGM ABORT
    offset:   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F |ASCII...........|
    --------------------------------------------------------- |----------------|
    00000000: E6 15 00 01 20 1A 00 06 00 00 00 00 00 00 52 11 |.... .........R.|
    00000010: 00 00 00 00 72                                  |....r           |

OPC_IMM_PACKET
    offset:   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F |ASCII...........|
    --------------------------------------------------------- |----------------|
    00000000: ED 0F 01 49 42 0D 00 1A 00 00 00 00 00 00 00    |...IB.......... |
lnreader lnmon    1586 Weird Send Packet Immediate, 3rd byte id 0x01 not 0x7f

OPC_PEER_XFER
    offset:   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F |ASCII...........|
    --------------------------------------------------------- |----------------|
    00000000: E5 0F 00 49 4B 0B 04 1A 00 52 11 1A 00 00 5B    |...IK....R....[ |

The format of the packets is LN-PE but the content is free to define.
As long as Uhlenbrock does not document this contents we only can use both packets hard coded and hope it works...
hclaassens
 

Postby rjversluis » 25.08.2011, 08:18

Hi Hans,

attached the hard coded ib-com setup...

BTW: The utility also query switch 1 to 16, but that are not settings I suppose.
You do not have the required permissions to view the files attached to this post.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Postby hclaassens » 25.08.2011, 08:36

Hi Rob,

You are as fast as lightning!

I've talked to Gerard Lucassen of HobbyTime (dutch Uhlenbrock representative ) and he is willing to talk to Uhlenbrock about this. I've send him a link to this forum topic so he is able to know what is going on.
I don't know how long this will take.

I will test tonight and get back with the results.


Hans


rjversluis wrote:Hi Hans,

attached the hard coded ib-com setup...

BTW: The utility also query switch 1 to 16, but that are not settings I suppose.
hclaassens
 

Postby rjversluis » 25.08.2011, 11:55

Uhlenbrock wrote:Sehr geehrter Herr Versluis,

mit der So27 (IB + IB II) wird die Zeit wie lange die Lok im Refresh bleibt eingestellt, diese Einstellung ist bei IB-Com/Basic nicht vorgesehen.

Mit freundlichen Grüßen
Ihr Uhlenbrock Service Team


OK, now we know. :roll:
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Postby hclaassens » 25.08.2011, 12:15

I think they are telling me I should not use the IB-Com :roll: :? :?:

rjversluis wrote:
Uhlenbrock wrote:Sehr geehrter Herr Versluis,

mit der So27 (IB + IB II) wird die Zeit wie lange die Lok im Refresh bleibt eingestellt, diese Einstellung ist bei IB-Com/Basic nicht vorgesehen.

Mit freundlichen Grüßen
Ihr Uhlenbrock Service Team


OK, now we know. :roll:
hclaassens
 

Postby hclaassens » 25.08.2011, 21:32

Hi Rob,

I've tested the version with the hard coded stuff inside. In the zip they are the ones starting with rocrail.

We've made some progress: If I only control the DCC loc, the commands are refreshed!!! But unfortunately if I also control a Motorola loc, the DCC loc is NOT refreshed anymore?! :shock:

That is why I did another test with the U's ib_util.exe and controlled both locos with it. The trace file is ibutl_motorola.trc. Both locos are refreshed with this one. I've seen the lets call them the hardcoded commands are repeated.

Best regards,
Hans
You do not have the required permissions to view the files attached to this post.
hclaassens
 

PreviousNext

Return to IB-Basic IB-Com IB2