(Résolu) Gros problèmeavec un aiguillage

(Résolu) Gros problèmeavec un aiguillage

Postby richard » 13.09.2018, 20:17

Bonjour,

Je suis en train de tester l'automatisation d'un réseau HO dont j'ai joint le tracé:
Sur la boucle extérieure, à chaque fois qu'une loco passe sur l'aiguillage en position droite, celui-ci passe en position déviée. Cela provoque bon nombre de court-circuits voire de déraillements.
Auriez-vous de solutions ou des idées pour remédier à cela? J'ai déja supprimé l'aiguillage et configuré un nouveau mais rien n'y fait, il bascule toujours en dévié. Les deux autres aiguillages situés sur la boucle intérieure ne posent aucun problème

Merci beaucoup

Richard
You do not have the required permissions to view the files attached to this post.
Last edited by richard on 15.09.2018, 15:52, edited 1 time in total.
HO, 2 rails, Roco geoLine
z21, r-Bus + S88N
GNU/Linux (x64), Rocrail
richard
 

Re: Gros problèmeavec un aiguillage

Postby PaulXpress » 14.09.2018, 05:27

Bonjour Richard,

Tout d'abord, une chose m'étonne dans la description de ton problème, c'est que l'aiguillage bascule au passage de la loco ? Dans Rocrail l'itinéraire est verrouillé avant le départ du train.
De plus, Il n'est pas facile de t'aider qu'avec une simple vue de ton réseau, il nous faut un rapport d'incident.
https://wiki.rocrail.net/doku.php?id=issue-fr#creer_un_rapport_d_incident

Cordialement,
Jean-Paul
HO 2 rails Fleischmann.
ESU ECoS 2 V4.2.2, SwitchPilot, EcosDetector, EcosBoost.
Windows X (64 bits), 3 D Train Studio V4.2.2.0 (64 bits).
PaulXpress
 

Re: Gros problèmeavec un aiguillage

Postby richard » 14.09.2018, 06:42

Bonjour Jean-Paul,

Je pense avoir réussi à générer un rapport d'incident que j'ai joint.

Bonne journée et encore merci.
You do not have the required permissions to view the files attached to this post.
HO, 2 rails, Roco geoLine
z21, r-Bus + S88N
GNU/Linux (x64), Rocrail
richard
 

Re: Gros problèmeavec un aiguillage

Postby Liviu M » 14.09.2018, 09:55

Bonjour Richard,

tu as deux aiguillage (sw001 et sw002) avec la même adresse -
bus="0" addr1="1" port1="0" gate1="0" inv="false" singlegate="false" accessory="false" addr2="0" port2="0" gate2="0" inv2="false"

C'est avec intention, ou c'est une faute?

A+
Liviu
----------------------------------------------
System: DCC N-Scale
CS: Profiboss (Loconet)
Server: RaspberryPi/OdroidC1/OpenSuse
Client: OpenSuse/Windows(?)
----------------------------------------------
Liviu M
 

Re: Gros problèmeavec un aiguillage

Postby PaulXpress » 14.09.2018, 13:03

Bonjour Richard,

Après l'analyse de ton fichier trace, il me semble que tu sois en mode manuel et non en automatique.
Comme le dit Liviu, le problème des deux aiguillages avec la même adresse peut expliquer que l'aiguillage bascule pendant le passage du train, en mode automatique, dans des conditions normales, RocRail verrouille les aiguillages de l'itinéraire, ils ne peuvent donc pas basculer durant le passage du train.

Trace en automatique :
20180914.131553.456 r9999a Moyse OBlock 2412 block bk001 locked for [Moyse][Moyse][bk006] in [normal] direction, indelay=0
20180914.131553.457 r9999a Moyse OBlock 2544 Block [bk001] reset counters and event triggers
20180914.131553.457 r9999a Moyse ORoute 0355 status of route [bk0006-]-[bk001+] is 1, locked by Moyse
20180914.131553.458 r9999a Moyse OBlock 0981 [bk001] CAR COUNT = 0
20180914.131553.458 r9999a Moyse OFBack 0359 [enter_01] CAR COUNT = 0
20180914.131553.458 r9999a Moyse OFBack 0359 [in_01] CAR COUNT = 0
20180914.131553.459 r9999a Moyse ORoute 1892 Route [[bk0006-]-[bk001+]] locked by [Moyse]
20180914.131553.459 r9999I Moyse ORoute 0694 route [bk0006-]-[bk001+] GO
20180914.131553.460 r9999a Moyse OSwitch 0826 Switch "sw001" is locked by "Moyse".
20180914.131553.460 r9999c Moyse OSwitch 1259 Switch [sw001] will be set to [straight,0,0]

Ton fichier trace :
20180914.073748.443 r9999c z21reade OZ21 1498 LAN_X_TURNOUT_INFO: addr=1 zz=01 (192.168.0.111)
20180914.073748.443 r9999a 1C641700 OModel 5128 trying to match switch event: 0:1:0:0 type=0 uidname=[]
20180914.073748.443 r9999I 1C641700 OSwitch 1982 switch [sw002] field event: state=turnout(field:turnout) gatevalue=2 inv=0 fieldstate=turnout
20180914.073748.443 r9999I 1C641700 OSwitch 1982 switch [sw001] field event: state=turnout(field:turnout) gatevalue=2 inv=0 fieldstate=turnout
20180914.073748.444 r9999a 1C641700 OModel 3632 no more switches found by address [1,0]

Cordialement,
Jean-Paul
HO 2 rails Fleischmann.
ESU ECoS 2 V4.2.2, SwitchPilot, EcosDetector, EcosBoost.
Windows X (64 bits), 3 D Train Studio V4.2.2.0 (64 bits).
PaulXpress
 

Re: Gros problèmeavec un aiguillage

Postby richard » 14.09.2018, 16:26

Bonjour Liviu,

J'ai mis la même adresse ai deux aiguillages pour que les deux basculent en même temps vu qu'ils sont reliés l'un a l'autre et sans cela, rocrail en basculait un mais pas l'autre ce qui provoquait des court-circuit. Était ce une mauvaise idée ?



Bonjour Jean-Paul,

J'ai fait le test en manuel c'est peut être pour ça, mais le problème a lieu aussi en automatique. Dès que la loco atteint le détecteur enter du bloc 1 l'aiguille bascule. Ça provoque même des erreurs d'itinéraire par exemple la loco de la boucle extérieure se retrouve sur l'intérieure et j'obtiens une erreur Train Fantôme.

Cordialement
HO, 2 rails, Roco geoLine
z21, r-Bus + S88N
GNU/Linux (x64), Rocrail
richard
 

Re: Gros problèmeavec un aiguillage

Postby richard » 14.09.2018, 18:50

J'ai modifié l'adresse du deuxième aiguillage (celui sur la boucle intérieure) mais le problème persiste, dès que le premier essieu de la loco attient le détecteur "eneter" du bloc 1, l'aiguillage passe en position déviée.
J'ai effacé tous les itinéraires puis ai relancé une analyse mais rien n'y fait. En plus dès que la loco atteint le bk002 j'ai une alerte train fantôme, m'indiquant qu'un évènement "in" a été déclenché sans qu"un "enter" ne le soit. Je n'avais pas ça hier, c'est bizarre. Je vais tester avec l'autre loco.

J'ai trouvé ça dans le .trc

20180914.212257.998 r9999I B0867700 OSwitch 1982 switch [sw001] field event: state=turnout(field:turnout) gatevalue=2 inv=0 fieldstate=turnout
20180914.212257.998 r9999a B0867700 OModel 3632 no more switches found by address [1,0]

Mais je sais pas du tout à quoi ça correspond
You do not have the required permissions to view the files attached to this post.
HO, 2 rails, Roco geoLine
z21, r-Bus + S88N
GNU/Linux (x64), Rocrail
richard
 

Re: Gros problèmeavec un aiguillage

Postby PaulXpress » 15.09.2018, 06:49

Bonjour Richard,

Tout d'abord, ton fichier trace ne contient pas le moment où l'incident se produit (aucune trace de sw001), il contient seulement la circulation de la BR_132 sur la boucle intérieure.
J'ai ensuite relevé deux choses à vérifier :
1- Pourquoi sur sw002 - Sauver la position : Droit ?
2- La plus importante, pourquoi sur bk001 - Center train, alors qu'aucune longueur n'est renseignée ?

Cordialement,
Jean-Paul
HO 2 rails Fleischmann.
ESU ECoS 2 V4.2.2, SwitchPilot, EcosDetector, EcosBoost.
Windows X (64 bits), 3 D Train Studio V4.2.2.0 (64 bits).
PaulXpress
 

Re: Gros problèmeavec un aiguillage

Postby richard » 15.09.2018, 09:53

Bonjour Jean-Paul,

Il semble que j'ai mis trop de temps à lancer la génération du rapport d'incident mais j'en ai fait un autre que j'ai joint.
Je ne sais pas pourquoi ces réglages sont mis en place. J'ai enlevé le paramètre "Sauver la position" de sw02 mais je ne trouve pas le "Center train" dans les propriétés de bk001

Pour l'instant, le problème persiste
You do not have the required permissions to view the files attached to this post.
HO, 2 rails, Roco geoLine
z21, r-Bus + S88N
GNU/Linux (x64), Rocrail
richard
 

Re: Gros problèmeavec un aiguillage

Postby PaulXpress » 15.09.2018, 10:17

Richard,

Sauver la position est toujours actif.
sw001.png

Pour Center train voir image.
bk001.png
You do not have the required permissions to view the files attached to this post.
HO 2 rails Fleischmann.
ESU ECoS 2 V4.2.2, SwitchPilot, EcosDetector, EcosBoost.
Windows X (64 bits), 3 D Train Studio V4.2.2.0 (64 bits).
PaulXpress
 

Re: Gros problèmeavec un aiguillage

Postby richard » 15.09.2018, 10:50

En fait le .trc date d'hier soir, en voici un mis à jour. J'ai bien modifé sw02. On voit l'évenement sw01 dans le .trc

Par contre je n'ai pas l'option "center train", j'ai décoché "Positionnement du train" au cas ou mais rien n'y fait.
You do not have the required permissions to view the files attached to this post.
HO, 2 rails, Roco geoLine
z21, r-Bus + S88N
GNU/Linux (x64), Rocrail
richard
 

Re: Gros problèmeavec un aiguillage

Postby PaulXpress » 15.09.2018, 13:41

En fait, j'ai 2 Pc et celui où je faisais le test de ton plan n'était pas à jour.

Pour les options, tu peux déjà comparer le bk001 avec les autres blocs.
bk001.png

bk006.png

Une autre chose que je trouve bizarroïde, quand j'ouvre ton plan les locos occupe 3 blocs, pour Moyse : bk0011, bk002 et bk003 et pour BR_132 : bk007, bk008 et bk009.
Pour que sw001 bascule, il faut que l'itinéraire soit libéré, donc que le détecteur "in" soit activé alors que la loco est toujours sur l'aiguillage ?
Qu'elle est la longueur de tes blocs ?
plan.png
You do not have the required permissions to view the files attached to this post.
HO 2 rails Fleischmann.
ESU ECoS 2 V4.2.2, SwitchPilot, EcosDetector, EcosBoost.
Windows X (64 bits), 3 D Train Studio V4.2.2.0 (64 bits).
PaulXpress
 

Re: Gros problèmeavec un aiguillage

Postby richard » 15.09.2018, 14:20

J'ai comparé les options des blocs mais tout semble identique.

Pour les trois blocs c'est dû au fait que j'ai demandé à rocrail de reserver deux blocs pour l'itinéraire afin d'avoir les feux verts. Autrement, ils restaient orange car le bloc suivant était "rouge". Y-a-t'il un autre moyen de gérer les feux verts en ne réservant que le bloc suivant?

Mes blocs font environ 75cm de long, mais comme j'utilise des voies roco geoLine, ma zone enter fait environ 55 cm de long et ma zone in fait 20 cm.

J'ai fait quelques tests et le problème a lieu dès que rocrail est en route. SI je ne démarre que la z21 et que j'utilise la multiMaus, pas de soucis. Mais si rocrail est démarré (même sans le mode automatique) le simple fait de poser une loco dans la zone enter du bk001 entraine la bascule de l'aiguillage en position "dévié".
HO, 2 rails, Roco geoLine
z21, r-Bus + S88N
GNU/Linux (x64), Rocrail
richard
 

(Résolu) Gros problèmeavec un aiguillage

Postby richard » 15.09.2018, 15:52

J'ai supprimer le bloc ainsi que sondétecteur "enter". Je les ai recréés puis j'ai relancer l'analyse. L'aiguillage reste maintenant en position.
HO, 2 rails, Roco geoLine
z21, r-Bus + S88N
GNU/Linux (x64), Rocrail
richard
 

Re: (Résolu) Gros problèmeavec un aiguillage

Postby PaulXpress » 15.09.2018, 16:05

C'est super d'avoir résolu ton problème, il est vrai qu'à force de bidouillé il est bon de repartir sur de bonne base.
Pour la signalisation je ne me suis pas encore penché sur le sujet, je ne peux donc pas t'aider.

Cordialement,
Jean-Paul
HO 2 rails Fleischmann.
ESU ECoS 2 V4.2.2, SwitchPilot, EcosDetector, EcosBoost.
Windows X (64 bits), 3 D Train Studio V4.2.2.0 (64 bits).
PaulXpress
 

Next

Return to Général (FR)