Relais am PI02 mit Weiche verbinden [gelöst]

RocNet(RaspberryPi), mergCBUS, LocoNet und vieles mehr von Peter Giling. (GCA)
Dokumentation: http://wiki.rocrail.net/doku.php?id=german#hardware
Bestellinformation: http://wiki.rocrail.net/doku.php?id=gca:gca-index-de
RocNetNode: http://wiki.rocrail.net/doku.php?id=roc ... netnode-de

<< Neu: GCA-Pi06 http://wiki.rocrail.net/doku.php?id=gca-pi06-de

Relais am PI02 mit Weiche verbinden [gelöst]

Postby AndKie » 16.01.2017, 10:54

Hallo Gemeinde,

erst mal ein gutes, gesundes neues Jahr euch allen.

ich brüte mal wieder über ein Problem bei dem ich nicht weiterkomme.
Ich versuche seit Tagen einige Relais am PI02 Softwareseitig mit den Weichen zu verbinden, (Zwecks Polarität -Umschaltung), die Relais kann ich ohne Probleme am PI02, über die Konfigurationssoftware in Rocview ein und aus schalten, das gelingt auch ohne Probleme, aber das Software seitige Verknüpfen mit der dementsprechenden Weiche will einfach nicht zuverlässig gelingen, mal schaltet das dementsprechende Relais ein, aber dann nicht mehr aus, immer wieder kommt es vor, dass ohne Zeiteinstellung, oder Zeitvorgabe, die Relais drei, vier mal hin und her schalten, auch das kann ich mir nicht erklären.,

Was will ich eigentlich wissen, ich möchte wissen wie ich die Relais zuverlässig, Softwareseitig, vom PI02 aus mit den Weichen verbinde, sodass bei Weichensteuerung auch das dementsprechende Relais am PI02 zuverlässig mit geschaltet wird, also die exakte Softwarekonfiguration im Weichendialog.
Die Dokumentation, die ich ausgiebig studiert habe, ist da nicht unbedingt hilfreich und bietet keine Unterstützung, alles zu allgemein gehalten.

Gruß
Andreas

Rocview Revision 11848 opensuse Leap
Rocrail Server (raspberry Pi3) 11871
Rocnetnode 11760
Last edited by AndKie on 17.01.2017, 14:33, edited 1 time in total.
H0, Open Source, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: Relais am PI02 mit Weiche verbinden

Postby Donald » 16.01.2017, 11:01

Guten Tag Andreas

Möglicherweise hilft das weiter: http://wiki.rocrail.net/doku.php?id=rocnet:sw-servo-setup-de
Ich arbeite mit CBUS und habe deshalb keine praktische Erfahrung.

Viele Grüsse
Donald
Spur 0: Modelleisenbahn der schönsten Art
Donald Roschi
Donald
 

Re: Relais am PI02 mit Weiche verbinden

Postby AndKie » 16.01.2017, 11:07

Donald wrote:Guten Tag Andreas

Möglicherweise hilft das weiter: http://wiki.rocrail.net/doku.php?id=rocnet:sw-servo-setup-de
Ich arbeite mit CBUS und habe deshalb keine praktische Erfahrung.

Viele Grüsse
Donald


Hallo Donald,
Danke für deine Antwort, aber ich befürchte, dass ich das auch schon durch habe, die Abbildungen in der Doku sind mit dem aktuellen rocview nicht mehr Identisch, ich schaue es mir dennoch nochmal an.
Auch die Adressierung ist ein Problem, wenn das Relais am ersten PI02 hängt also am Kanal 8 des ersten PI02, dann müsste die Adresse doch lauten Adresse "0" und port "8", oder?

Danke und Gruß
H0, Open Source, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: Relais am PI02 mit Weiche verbinden

Postby ups60 » 16.01.2017, 13:48

AndKie wrote:
Donald wrote:Guten Tag Andreas

Möglicherweise hilft das weiter: http://wiki.rocrail.net/doku.php?id=rocnet:sw-servo-setup-de

Viele Grüsse
Donald



Auch die Adressierung ist ein Problem, wenn das Relais am ersten PI02 hängt also am Kanal 8 des ersten PI02, dann müsste die Adresse doch lauten Adresse "0" und port "8", oder?

Danke und Gruß

Hallo Andreas,

sowie ich das auf der oben verlinkten Seite sehe, müsste die Adress "8" und der Port "0" sein, unten bei Herzstück-Relais.

mfg Uwe
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: Relais am PI02 mit Weiche verbinden

Postby AndKie » 16.01.2017, 14:22

Hallo Uwe,

auch dass habe ich realisiert und geändert.

Wenn ich unter Weichen -Konfiguration im Reiter Herzstück die Adresse des betreffenden PI02 Kanals einstelle und unten im gleichen Feld Zubehör und Ausgang aktiviere geht gar nichts, keine Reaktion, erst wenn ich den Button "Weiche" mit dazunehme schaltet der Ausgang am PI02 das Relais zu, aber bei Rückstellung der Weiche bleibt dieser Ausgang trotzdem aktiv und daran verzweifele ich fast!

Gruß
Andreas
H0, Open Source, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: Relais am PI02 mit Weiche verbinden

Postby StefanF. » 16.01.2017, 15:01

Hallo Andreas,
wenn du ein bistabiles Relais für die Herzstückpolarisierung einsetzt würde ich für jeden Port die gleiche Portnummer (PI02) auswählen. Ähnlich wie am GCA50. Im Herzstückdialog der Weiche genauso. Kann ich für Dich leider nicht in der Praxis testen, mangels fehlender Hardware.
Beste Grüße
Stefan
=========================
Zentrale: OpenDCC Z1 und 2 Booster: OpenDCC - Booster2
Loconet MGV85, 50, 93,76,77,136
Rechner: Kubuntu14.04 auf 2*Core i3 (3Monitore) 6GBRAM
=========================
StefanF.
 

Re: Relais am PI02 mit Weiche verbinden

Postby AndKie » 16.01.2017, 16:44

Hallo Stefan,
Danke erst mal für die Antwort.

Also die Adressierung ist auch in der Doku widersprüchlich, in der Doku wird der erste, von bis zu vier PI02, als Adresse "0" angegeben und jeder Kanal, oder Port nach seiner laufenden Nummer, also ergäbe dies eine Adresse "0" für den ersten PI02 und der Port den betreffenden Kanal, also z.B. "1", oder "8" usw.
Leider fehlen in der Doku auch nachvollziehbare Beispielkonfigurationen aus denen man das Vorgehen eindeutig ablesen und übertragen könnte, nur Beschreibungen der einzelnen Punkte.

Bei meinen Einstellversuchen in der Weicheineinstellung, Karteireiter Herzstücke, musste ich feststellen, dass es gerade umgedreht ist und mit der Einstellung "Zubehör: Ausgang" nichts geht, erst wenn ich "Weiche: Ausgang" anklicke, aktiviere, dann erfolgt aber nur der "EIN" Befehl, ausschalten lässt sich, bei Rückstellung der Weiche der Ausgang des PI02 nicht mehr. - Hmhmm?

Ziehe ich den Kanal des PI02 per "Drag and Drop" auf die betreffende Weiche, so wird die Weiche als nur noch "Ausgang" angesprochen und muss in diesem Punkt wieder auf "Servo" zurückgestellt werden, aber damit geht auch der PI02 Kanal nicht mehr, - alles seltsam.

Ich möchte einfach nur erreichen, dass bei Weichenstellung, gleichzeitig der betreffende zugeordnete Kanal (Ausgang) des PI02 auf high 5v geht und das daran befindliche Relais, oder was auch immer daran hängt auf EIN und bei Weicheinrückstellung der Ausgang des PI02 Kanals wieder zuverlässig auf low 0v, also AUS zurückfällt, leider funktioniert das nicht, jedenfalls nicht zuverlässig.


Gruß
Andreas
Last edited by AndKie on 16.01.2017, 16:53, edited 1 time in total.
H0, Open Source, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: Relais am PI02 mit Weiche verbinden

Postby StefanF. » 16.01.2017, 16:52

Hallo Andreas,
bevor Du verzweifelst, vielleicht bekomme ich bei mir einen Testaufbau hin. Oder vielleicht meldet sich hier noch jemand, der Dir helfen kann. Ich bin im Moment etwas out of order (Grippe). Daher Morgen eventuell mehr. Sag mir nur: ist das Relais ein bistabiles oder ein monostabiles Relais?
Beste Grüße
Stefan
=========================
Zentrale: OpenDCC Z1 und 2 Booster: OpenDCC - Booster2
Loconet MGV85, 50, 93,76,77,136
Rechner: Kubuntu14.04 auf 2*Core i3 (3Monitore) 6GBRAM
=========================
StefanF.
 

Re: Relais am PI02 mit Weiche verbinden

Postby AndKie » 16.01.2017, 16:59

StefanF. wrote:Hallo Andreas,
bevor Du verzweifelst, vielleicht bekomme ich bei mir einen Testaufbau hin. Oder vielleicht meldet sich hier noch jemand, der Dir helfen kann. Ich bin im Moment etwas out of order (Grippe). Daher Morgen eventuell mehr. Sag mir nur: ist das Relais ein bistabiles oder ein monostabiles Relais?
Beste Grüße
Stefan


Hallo Stefan,
Du leidest auch an der Seuche, ich bedaure dich, bei mir ist gerade die Genesungsphase erreicht.
- Gute Besserung wünsche ich. -

Also die Polarisation der Herzstücke habe ich seit eh und je schon mit Miniaturschalter, die mechanisch am Servo angeschlossen sind realisiert, aber über die Feiertags dachte ich, ich könnte doch mal eine Lösung mit Relais versuchen, bin von der Fehlentwicklung und mangelnden Konfigurationsbeispiele in der Doku schon etwas enttäuscht, aber vielleicht bekomme ich es noch hin.

Also die Anlage funktioniert deshalb trotzdem, eben halt nur mit Schaltern und die haben auch so Ihr "Eigenleben".

Gruß
Andreas
H0, Open Source, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: Relais am PI02 mit Weiche verbinden

Postby StefanF. » 17.01.2017, 13:34

Hallo Andreas,
ich habe meinen Testkoffer wieder aktiviert und anstatt eines Doppelspulenrelais mal 2 LED's an den PI02 angeschlossen. Ich mußte in der Tat ein wenig herum probieren, bis ich die Lösung gefunden habe. Anbei meine beiden Bilder dazu.
Kannst ja mal schauen, ob das bei Dir auch mit dem Relais klappt. Wenn ja, kann ich vielleicht einen Hinweis ins Wiki schreiben, wenn es nicht schon drin steht.
herz1.png
herz2.png

Wichtig ist der Typ "Analog". Die Leuchtdioden flackern kurz auf, je nach dem wo die Weichenzunge hingeht.
Beste Grüße
Stefan
You do not have the required permissions to view the files attached to this post.
=========================
Zentrale: OpenDCC Z1 und 2 Booster: OpenDCC - Booster2
Loconet MGV85, 50, 93,76,77,136
Rechner: Kubuntu14.04 auf 2*Core i3 (3Monitore) 6GBRAM
=========================
StefanF.
 

Re: Relais am PI02 mit Weiche verbinden

Postby AndKie » 17.01.2017, 14:27

StefanF. wrote:Hallo Andreas,
ich habe meinen Testkoffer wieder aktiviert und anstatt eines Doppelspulenrelais mal 2 LED's an den PI02 angeschlossen. Ich mußte in der Tat ein wenig herum probieren, bis ich die Lösung gefunden habe. Anbei meine beiden Bilder dazu.
Kannst ja mal schauen, ob das bei Dir auch mit dem Relais klappt. Wenn ja, kann ich vielleicht einen Hinweis ins Wiki schreiben, wenn es nicht schon drin steht.
herz1.png
herz2.png

Wichtig ist der Typ "Analog". Die Leuchtdioden flackern kurz auf, je nach dem wo die Weichenzunge hingeht.
Beste Grüße
Stefan



Hallo Stefan,
erst einmal herzlichen Danke für die Mühe die du dir machst.
Ich probiere es mal aus.

Ich habe heute ebenfalls auf dem Labortisch ein absolut identisches System aufgebaut, mit dem gleichen plan,xml und allen anderen Software und Hardware Komponenten, die Effekte sind leider die Gleichen die ich gestern schon beschrieben hatte, egal ob mit Relais und oder nur LED, die Symptome sind die gleichen.
Ich versuche mal es so zu lösen wie du es beschrieben hast und gebe dementsprechend Rückmeldung.

Danke und Gruß
Andreas
H0, Open Source, DR5000, RaspberryPi III, - I2C Bus
AndKie
 

Re: Relais am PI02 mit Weiche verbinden [gelöst]

Postby AndKie » 17.01.2017, 14:32

Hallo Stefan,

Nochmals herzlichen Danke für die Mühe und Hilfe, - ja so es funktioniert jetzt.

Meine zusätzliche Bitte an dich, oder diejenigen die die Doku bearbeiten, sorgt Bitte dafür, dass es so auch so in die Doku einfließt, denn darin sehe ich das eigentliche, das größte Problem.

:rr_for_ever:

Gruß Andreas
H0, Open Source, DR5000, RaspberryPi III, - I2C Bus
AndKie
 


Return to GCA-Hardware (DE) (Peter Giling)