[gelöst] GCA41 RFID funktioniert nicht an Pi3

RocNet(RaspberryPi), mergCBUS, LocoNet und vieles mehr von Peter Giling. (GCA)
Dokumentation: http://wiki.rocrail.net/doku.php?id=german#hardware
Bestellinformation: http://wiki.rocrail.net/doku.php?id=gca:gca-index-de
RocNetNode: http://wiki.rocrail.net/doku.php?id=roc ... netnode-de

<< Neu: GCA-Pi06 http://wiki.rocrail.net/doku.php?id=gca-pi06-de

Re: GCA41 RFID funktioniert nicht an Pi3

Postby ups60 » 09.02.2018, 17:26

Hi Rob,

mit der neuen Einstellung für PI3 (rocnetnode: raspi type 3 added for using ttyS0 instead of ttyAMA0,)stürtz der Raspi ab und läßt sich nicht neu booten.
Muß jetzt erstmal Ubuntu starten und auf der SD-Karte die Traces sammeln und die Config anpassen.

mfg Uwe
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: GCA41 RFID funktioniert nicht an Pi3

Postby ups60 » 09.02.2018, 17:50

Hi Rob,

laut .trc wird damit WLan deaktiviert:
20180209.171840.280 r9999E rnscanne OSocket 0803 sendto() failed [101] [Network is unreachable].

mfg Uwe
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: GCA41 RFID funktioniert nicht an Pi3

Postby rjversluis » 09.02.2018, 18:06

Hi Uwe,

ich mache ein revert...
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: GCA41 RFID funktioniert nicht an Pi3

Postby rjversluis » 10.02.2018, 10:44

Hi Uwe,

wenn ich Seriell deaktiviere ist die /dev/ttyAMA0 weg.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: GCA41 RFID funktioniert nicht an Pi3

Postby rjversluis » 10.02.2018, 10:53

Moin Uwe,

man muss diese uart wieder manuel auf 1 stellen, dann geht es auch bei mein Raspi3...

Also, mit raspi-config seriell ausschalten, und im /boot/config.txt wieder auf 1 stellen...
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: GCA41 RFID funktioniert nicht an Pi3

Postby ups60 » 10.02.2018, 11:01

rjversluis wrote:Moin Uwe,

man muss diese uart wieder manuel auf 1 stellen, dann geht es auch bei mein Raspi3...

Also, mit raspi-config seriell ausschalten, und im /boot/config.txt wieder auf 1 stellen...

Moin Rob,

Schön, dann ist Deine Serielle Schnittstelle doch nicht kaputt. Schaun mer mal, ob damit auch die anderen Probleme, von denen Du oben geschrieben hast, damit auch gelöst sind.
Eventuell wären diese Einstellungen auch ein Hinweis wert im Wiki.

Soll ich den Thread damit auf erledigt setzen?

mfg Uwe
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: GCA41 RFID funktioniert nicht an Pi3

Postby rjversluis » 10.02.2018, 11:11

Hi Uwe,

ich habe es schon im Wiki:
http://wiki.rocrail.net/doku.php?id=gca ... s232_on_s1
Kannst du mal drüber schauen ob das so OK ist?
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: GCA41 RFID funktioniert nicht an Pi3

Postby ups60 » 10.02.2018, 11:30

rjversluis wrote:Hi Uwe,

ich habe es schon im Wiki:
http://wiki.rocrail.net/doku.php?id=gca ... s232_on_s1
Kannst du mal drüber schauen ob das so OK ist?


Hi Rob,
ich würde noch
"dwc_otg.lpm_enable=0 console=tty1 console=ttyAMA0,115200 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait fbcon=map:10 fbcon=font:ProFont6x11 logo.nologo"
aus der /boot/cmdline.txt mit aufnehmen.
Da liegt auch der Fehler in dem Raspi-Config Programm. Wenn Du sudo raspi-config von der Kommandozeile aufrufst, seriell abschaltest, musst Du zweimal bestätigen, einmal ob die Schnittstelle abgeschaltet werden soll (config.txt) und einmal ob serieller Fernzugriff möglich sein soll (cmdline.txt). Das wird beim grafischen Tool wohl nicht korrekt gemacht.

mfg Uwe
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: GCA41 RFID funktioniert nicht an Pi3

Postby rjversluis » 10.02.2018, 11:34

Hi Uwe,

diese lange Zeile verstehe ich nicht.

Code: Select all
pi@raspi8:~/rocnet-demo $ cat /boot/cmdline.txt
dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait quiet splash plymouth.ignore-serial-consoles
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: GCA41 RFID funktioniert nicht an Pi3

Postby ups60 » 10.02.2018, 11:42

rjversluis wrote:Hi Uwe,

diese lange Zeile verstehe ich nicht.

Code: Select all
pi@raspi8:~/rocnet-demo $ cat /boot/cmdline.txt
dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait quiet splash plymouth.ignore-serial-consoles

Hi Rob,

ganz genaues weiß ich auch nicht, aber ich gehe davon aus, daß es sich dabei um den Bootloader handelt.

mfg Uwe
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: GCA41 RFID funktioniert nicht an Pi3

Postby rjversluis » 10.02.2018, 11:46

Hi Uwe,

ohne Änderung sieht diese Datei so aus:

Code: Select all
pi@raspi9:~ $ cat /boot/cmdline.txt
dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=01062708-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles


Nachdem ich in der Graphische Oberfläche Serial disabled habe so:
Code: Select all
pi@raspi8:~/rocnet-demo $ cat /boot/cmdline.txt
dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait quiet splash plymouth.ignore-serial-consoles


Also denke ich nicht das man diese Datei nochmal Manuell bearbeiten muss.

Nur blöd das es beim Raspi3 so inkompatibel geworden ist. :(
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: GCA41 RFID funktioniert nicht an Pi3

Postby ups60 » 10.02.2018, 11:54

rjversluis wrote:
Also denke ich nicht das man diese Datei nochmal Manuell bearbeiten muss.

Nur blöd das es beim Raspi3 so inkompatibel geworden ist. :(

Hi Rob,

ja, dann laß es so im Wiki, sollte nochmal jemand Probleme haben, behalten wir das im Hinterkopf.

Und warten wir mal ab, was dann beim Raspi4 auf uns zukommt. ;-)

mfg Uwe
Für Hilfestellung nicht vergessen: http://wiki.rocrail.net/doku.php?id=issue-de
Märklin H0 K-Gleis, CS3 60226 (V1.3.2(1)), Windows 10, Ubuntu 16.04, GCA_PI01, GCA_PI02, GBM-Boost + GBM-16T
ups60
 

Re: GCA41 RFID funktioniert nicht an Pi3

Postby rjversluis » 10.02.2018, 11:55

Hi Uwe,

OK, weil es ist jetzt schon wieder Schräg genug für 'Anfänger', aber da is Raspberry Pi schuld.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: GCA41 RFID funktioniert nicht an Pi3

Postby Liviu M » 10.02.2018, 14:02

Hi Rob, hi Uwe,
rjversluis wrote:Hi Uwe,
diese lange Zeile verstehe ich nicht.

wenn ich richtig verstanden habe, wichtig für uns in dieser Zeile ist der Teil
Code: Select all
 
console=ttyxxx

den die Serielle boot Konsole an einer bestimmte Schnittstelle zuweist.
Meiner Meinung nach, mit
Code: Select all
 
console=ttyAMA0

wird die Serielle Konsole an "unsere" Schnittstelle" zugewiesen und bin nicht sicher, dass die Konsole noch für andere Anwendungen (GCA41, zB) zur Verfügung bleibt.
Im Link das ich vorher gepostet habe, steht:
Diese Zeile suchen:
Code: Select all
dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

und editieren. Der Eintrag console=serial0,115200 sollte wie schon beim RPi2 entfernt werden, wenn es gesetzt ist, damit die UART-Schnittstelle von Zusatzmodulen wie EnOceanPi verwendet werden kann. Der genaue Inhalt der Zeile kann sich je nach System unterscheiden.


Grüße,
Liviu

PS @Rob: Mein Gesicht kennst du jetzt, habe wieder entfernt. Sorry, bin ein bisschen "schüchtern". :oops:
----------------------------------------------
System: DCC N-Scale
CS: Profiboss (Loconet)
Server: RaspberryPi/OdroidC1/OpenSuse
Client: OpenSuse/Windows(?)
----------------------------------------------
Liviu M
 

Previous

Return to GCA-Hardware (DE) (Peter Giling)

cron