[solved] Rocmouse Troubles Topic is solved

http://wiki.rocrail.net/doku.php?id=roc ... netnode-en
Post Reply
pmansvelder

[solved] Rocmouse Troubles

Post by pmansvelder » 23.05.2014, 08:38

Hello Rob and others,

I have recently added a rocmouse to my rocnetnode setup, and it seems to work fine (at least I see it in the rocnetnode config, and the buttons and leds work as described). But I cannot seem to dispatch a lok to the roucmouse. I see in the trace that my commands get through:

20140523.074732.232 r9999I cmdrA800 OLoc 2919 processing cmd="dispatch" for [PT2/3]
20140523.074732.234 r9999I cmdrA800 OBiDiB 0201 slot created for PT2/3
20140523.074732.235 r9999c cmdrA800 OBiDiB 0916 loco 6058 V=0 dir=fwd lights=on steps=128
20140523.074732.246 r9999c bidibrea OBiDiB 2145 loco 6058 ack=1
20140523.074734.369 r9999I clocktic OBiDiB 1252 clock: sync
20140523.074734.369 r9999I clocktic OBiDiB 1264 sync clock
20140523.074734.370 r9999I clocktic OBiDiB 1288 set clock to 1:26 wday=4 divider=5
20140523.074734.370 r9999c clocktic OrocNet 0238 Clock sync
20140523.074734.371 r9999I rnwriter OrocNet 1810 write request [000000000107020800000417011A0005] to 0
20140523.074746.382 r9999I clocktic OBiDiB 1252 clock: sync
20140523.074746.383 r9999I clocktic OBiDiB 1264 sync clock
20140523.074746.383 r9999I clocktic OBiDiB 1288 set clock to 1:27 wday=4 divider=5
20140523.074746.384 r9999c clocktic OrocNet 0238 Clock sync
20140523.074746.392 r9999I rnwriter OrocNet 1810 write request [000000000107020800000417011B0005] to 0
20140523.074748.748 r9999I rnreader OrocNet 1673 evaluate event [0000000004022509380003808000000132] from 4 to 0
20140523.074748.748 r9999I rnreader OrocNet 0969 node [4] reports a rocmouse 0x38 event, dispatchAddr=0
20140523.074753.148 r9999I rnreader OrocNet 1673 evaluate event [0000000004022509380103808000000032] from 4 to 0
20140523.074753.148 r9999I rnreader OrocNet 0969 node [4] reports a rocmouse 0x38 event, dispatchAddr=0
20140523.074753.253 r9999I rnreader OrocNet 1673 evaluate event [0000000004022509380203808000000032] from 4 to 0
20140523.074753.253 r9999I rnreader OrocNet 0969 node [4] reports a rocmouse 0x38 event, dispatchAddr=0
20140523.074753.358 r9999I rnreader OrocNet 1673 evaluate event [0000000004022509380303808000000032] from 4 to 0
20140523.074753.358 r9999I rnreader OrocNet 0969 node [4] reports a rocmouse 0x38 event, dispatchAddr=0
20140523.074753.463 r9999I rnreader OrocNet 1673 evaluate event [0000000004022509380403808000000032] from 4 to 0
20140523.074753.463 r9999I rnreader OrocNet 0969 node [4] reports a rocmouse 0x38 event, dispatchAddr=0
20140523.074753.568 r9999I rnreader OrocNet 1673 evaluate event [0000000004022509380503808000000032] from 4 to 0

But the rocmouse is not being used: the led is not changing its blink frequency, and the controls don't work (which is logical if I look at the line 'dispatchAddr=0'.
I am probably doing something wrong, but I can't find it.
My layout is as follows:
- a GBMBoost/GBM16T bidib controller with S88 interface, named 'Bidib' as iid
- a Rocnetnode setup with as yet one Raspi, named 'Rocnet'.
I will attach the plan, ini and trace files,

Peter

rjversluis
Site Admin
Posts: 42383
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Rocmouse Troubles

Post by rjversluis » 23.05.2014, 08:48


pmansvelder

Re: Rocmouse Troubles

Post by pmansvelder » 23.05.2014, 09:49

Hello Rob,

yes, but I did have some trouble interpreting it, but as I understand it now it means: since the controller sending DCC to the locs is not my default controller (this is Rocnet), I must set the 'dpiid' to the iid of the controller that does control the locos, so in my case 'Bidib'. I have already tried all settings: leaving it empty, setting it to 'Rocnet', but all to no avail.

Peter

rjversluis
Site Admin
Posts: 42383
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Rocmouse Troubles

Post by rjversluis » 23.05.2014, 10:40

Hi Peter,

DPIID -> RocNet.
Loco IID -> BiDiB

After dispatch -> Use the throttle or a function button to take over the dispatched loco.

Just check this German thread:
http://forum.rocrail.net/viewtopic.php? ... hilit=pi04

pmansvelder

Re: Rocmouse Troubles

Post by pmansvelder » 23.05.2014, 13:31

Hello Rob,

it works! My mistake was that I entered the 'Bidib' iid in the locomotives table, with every loco; if I use your method I don't have to, and the dispatching works!
My intention is to make a 'local' switchboard with a button for every station block, so that by pressing the button I can take over the loco that is present in that block. Someting similar is possible with the Uhlenbrock 'Track-Control' system, but that is way too costly for me, and besides, doing it this way is much more fun!

Thanks again,

Peter

Post Reply

Return to “RocNetNode”