[erl.] Zug fährt nicht: RocNetNode + DCC232

http://wiki.rocrail.net/doku.php?id=roc ... netnode-de

[erl.] Zug fährt nicht: RocNetNode + DCC232

Postby Martin » 22.10.2016, 06:01

Hallo zusammen,

ich bin neu in diesem Forum.
Vor ein paar Wochen habe ich mir von Peter die Bausätze erworben für die Steuerung der Eisenbahn über RocNetNode und einem Raspi.
Die Bausätze funktionieren einwandfrei, der I2P Bus macht keine Probleme. Rückmeldungen kommen, Kurzschluss wird erkannt, Weichen können geschaltet werden.
Gesteuert werden soll meine Eisenbahn H0 welche bisher mit der Märklin Mobile Station 1 gesteuert wurde.
Am Raspi läuft die Softwarezentrale DCC232. Die Hardware wird über einen USB-Seriell Adapter und dem ORD-3 Booster betrieben. Der Booster lässt sich über RocView ein- und ausschalten. Die Gleisspannung soweit diese mit einem Messgerät gemessen werden kann stimmt auch.
Als Versuchslok habe ich eine BR 89 (Märklin Decoder 115797) gewählt. Diese hat die Adresse in der Mobile Station "A 78". In Rocview habe ich diese dann auch mit der Adresse 78, Protokoll Motorola, Protokollversion 2, 14 Fahrstufen und 4 Funktionen angelegt.
Leider lässt sich die Lok nicht steuern. Nachdem ich nun mehrere Forenbeiträge gelesen und auf Hardware Fehlersuche und seit zwei Wochen nicht weiter komme jetzt meine Problembeschreibung.
Noch ein kleiner Satz zur Fehlersuche: Fehlerbild in Raspian und Windows ist das selbe, USB-Seriell Adapter mit Chip FTDI und PL2303 bringen selbe Ergebnisse.

Ich hoffe Ihr könnt mir weiterhelfen.

Gruß
Martin
========================
Booster: ORD-3
Zentrale: RocNetNode
Server: Raspberry Model 3, Raspian
Martin
 

Re: Zug fährt nicht, Funktionen reagieren nicht

Postby rjversluis » 22.10.2016, 06:20

Hallo Martin,

DCC232 generiert ausschließlich das DCC-Format und kann deswegen kein Märklin Motorola-Format decoder steuern.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Zug fährt nicht, Funktionen reagieren nicht

Postby StefanF. » 22.10.2016, 18:19

Hallo Martin,
auch wenn ich das hier eigentlich nicht mehr sagen darf. Es gibt noch das DDX-Protokoll. Das unterstützt auch MM. Ist für die ersten Gehversuche und Erfolgserlebnisse gar nicht so schlecht. Für später musst Du dann mal sehen.
Beste Grüße
Stefan
=========================
Zentrale: OpenDCC Z1 und 2 Booster: OpenDCC - Booster2
Loconet MGV85, 50, 93,76,77,136
Rechner: Kubuntu14.04 auf 2*Core i3 (3Monitore) 6GBRAM
=========================
StefanF.
 

Re: Zug fährt nicht, Funktionen reagieren nicht

Postby Martin » 22.10.2016, 18:51

Super, danke für eure schnellen Antworten. :thumb_up:

Wo und wie stelle ich DDX ein?

Was empfehlt ihr mir?
Hardwarezentrale die sowohl MM, DCC und MFX kann oder alle Loks mit DCC Decoder umrüsten? Gibt es Decoder die Ihr empfehlen könnt?

Grüße
Martin
========================
Booster: ORD-3
Zentrale: RocNetNode
Server: Raspberry Model 3, Raspian
Martin
 

Re: Zug fährt nicht, Funktionen reagieren nicht

Postby Bernie » 22.10.2016, 19:18

Hallo Martin,

auf die Dauer ist eine hardware-Zentrale auf jeden Fall die bessere Lösung. Hilft Dir aber jetzt nicht übers Wochenende. Teste doch einfach mal DDX. Einrichten ist eigentlich easy, da schon in RR implementiert. DCC232 aus der Liste deiner Zentralen löschen und stattdessen ddx auswählen.

Alles weitere hier: http://wiki.rocrail.net/doku.php?id=ddx-de
Gruß Bernd

[H0 2-L DCC] [Win10real,Win7Test] [IB-COM+GCA101+TamsMC] [4*ORD-3] [GCA50/93/102/136] [Weichen/Lichtsign. LDT/Viessmann(MM)] [Formsignale GCA136] [CarSystem/DC-Car] [Weichen CarSystem Digirails DR4024]

http://www.modelltraumland-wuppertal.de/
Bernie
 

Re: Zug fährt nicht, Funktionen reagieren nicht

Postby Schorse » 22.10.2016, 19:43

Hallo Martin,

Hardwarezentrale die sowohl MM, DCC und MFX kann oder alle Loks mit DCC Decoder umrüsten?
DCC Decoder können über Rocrail programmiert werden (MM und mfx nicht) und selbst preisgünstige Decoder besitzen eine Lastregelung. Das ist nicht nur günstig bei Neigungen sonder auch bei engen Mä. Radien z. B. auf Weichen.
Moderne Decoder sollten das DCC und MM Protokoll unterstützen. Wichtig für den Kauf ist auch ob die Lok einen Wechsel- oder Gleichstrommotor besitzt.
Viele Grüße Gerd
Schorse
 

Re: Zug fährt nicht, Funktionen reagieren nicht

Postby rjversluis » 23.10.2016, 06:57

Hi Martin,
Martin wrote:Wo und wie stelle ich DDX ein?

DDX wird nicht in RocNetNode unterstützt. (Deprecated)
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Zug fährt nicht, Funktionen reagieren nicht

Postby Martin » 23.10.2016, 07:57

Guten Morgen zusammen,

echt super wie schnell in diesem Forum die Antworten gegeben.
Der Zug fährt mit einer DDX als eingerichtet Zentrale nicht. In RocNetNode habe ich die Zentrale auf "keine" gesetzt und in den Einstellungen der Zentralen die DDX als "default". :(

Werde wohl jetzt mir mal für das erste ein DDC Dekoder zulegen.
========================
Booster: ORD-3
Zentrale: RocNetNode
Server: Raspberry Model 3, Raspian
Martin
 

Re: Zug fährt nicht, Funktionen reagieren nicht

Postby StefanF. » 23.10.2016, 08:23

Hallo Rob,
DDX kann man auf einem Raspi doch wie auf jedem anderen Rechner auch als extra Zentrale betreiben, oder sehe ich das falsch?
Geht doch nur um einen Test um Rocrail besser kennen zu lernen.
Beste Grüße
Stefan
=========================
Zentrale: OpenDCC Z1 und 2 Booster: OpenDCC - Booster2
Loconet MGV85, 50, 93,76,77,136
Rechner: Kubuntu14.04 auf 2*Core i3 (3Monitore) 6GBRAM
=========================
StefanF.
 

Re: Zug fährt nicht, Funktionen reagieren nicht

Postby rjversluis » 23.10.2016, 08:55

Hallo Stefan,

klar geht das, aber nicht im Kontext von RocNetNode.
Für DDX muss man der Rocrail Server installieren.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Zug fährt nicht, Funktionen reagieren nicht

Postby Martin » 23.10.2016, 09:17

Server ist auf meinem Rasp. installiert und läuft auch. Was mache ich falsch?
========================
Booster: ORD-3
Zentrale: RocNetNode
Server: Raspberry Model 3, Raspian
Martin
 

Re: Zug fährt nicht, Funktionen reagieren nicht

Postby rjversluis » 23.10.2016, 09:25

Martin wrote:Server ist auf meinem Rasp. installiert und läuft auch. Was mache ich falsch?

Dateien anhängen vielleicht?
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Zug fährt nicht, Funktionen reagieren nicht

Postby Martin » 23.10.2016, 10:00

Hier die gewünschten Dateien.
You do not have the required permissions to view the files attached to this post.
========================
Booster: ORD-3
Zentrale: RocNetNode
Server: Raspberry Model 3, Raspian
Martin
 

Re: Zug fährt nicht, Funktionen reagieren nicht

Postby Martin » 30.10.2016, 07:54

Hallo zusammen,

mit dem neu gekauften Lokdecoder lässt sich die Lok nun steuern. :D :D :D

Dazu ist es aber notwendig als Zentrale ein DCC232 einzurichten. Als eingerichtete RocNet Zentrale und darin eingestellte DCC232 fährt die Lok nicht.

Wo ist der Fehler?

Gruß
Martin
========================
Booster: ORD-3
Zentrale: RocNetNode
Server: Raspberry Model 3, Raspian
Martin
 

Re: Zug fährt nicht, Funktionen reagieren nicht

Postby rjversluis » 30.10.2016, 08:10

Moin,
Martin wrote:Als eingerichtete RocNet Zentrale und darin eingestellte DCC232 fährt die Lok nicht.

vielleicht falsche Port, oder der Raspi hat kein Treiber für dein USB-RS232 Stick...
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Next

Return to RocNetNode (DE)