Help with digitrax setup Topic is solved

cdnrider

Post by cdnrider » 09.12.2009, 00:47

rjversluis wrote:Hi,

the ms100 I never tested, and I do not think an older Rocrail release will help you.

It seems that the incoming packets are lost between MS100 and Rocrail.
I would no one advise to use this interface, better use a LocoBuffer which will work very good.
There is also a DIY Locobuffer.

But I also saw in the trace that it was not possible to set the DTR signal which could be the cause of the problem: RS232 does not signal to MS100 that it is ready to receive data.

If someone can lent me a MS100 a will have a look at this problem...
Thanks for all the help on this problem. My Locobuffer USB arrived today. I tested it with 1.3 and it seems to be working fine with the new interface. I will retire the ms100.

I will also in the next week or two try to make the switch to Linux. I have Installed Linux Mint 8 on one desktop and like it. I will try to put it on my train computer next and try it with (Locobuffer/1.3 and JMRI)

Thanks again,

coldguy

Rocrail 1.3 (Air) broken for MS100

Post by coldguy » 17.02.2010, 16:37

Hi all. I just thought I would add to this post in the LocoNet section, since I searched all over before I found the answer.

I have the same setup as CdnRider(DCS50, MS100, Rocrail 1.3 release) and had the same problem(can control track power and not locos). CdnRider solved the problem by reverting to Rocrail 1.2(Act) and eventually replacing the MS100 with a locobuffer. I'm quite cheap, and since my MS100/USB serial port works with JMRI, I was convinced that 1.3 was the problem. After exhaustive searching, I found this post:
http://forum.rocrail.net/viewtopic.php? ... ight=ms100
At the end of which
rjversluis wrote:Hi,

beginning with revno 1129 you have to set this option by hand:

http://wiki.rocrail.net/doku.php?id=usb-rs232-en

The correction made in revno 768 did break some working configurations:

- MDRRC (p50x)
- MS100 (loconet)
Rocrail 1.3(Air), the current stable release new users are directed to install, is revno 982, after 768 where ms100 support was broken and before 1129 where it was fixed.

I installed 1.2 in a new directory to confirm that my setup was working, as CdnRider did, and then the latest nightly snapshot, revno 1309. My setup is working great, full control of everything, including iRoc, with my MS100 on a USB serial port. I didn't even need to edit the .ini as stated in Rob's link.

Any MS100 users, I highly recommend the latest snapshot of Rocrail 1.4, as the release version of 1.3 is broken for us. I would also reccomend that the LocoNet/MS100 section of the wiki documentation be updated to include this fix. It took me a while to find it, and I nearly gave up on this incredible project before I found this info in a very obscure location.

Thanks Rocrail team!


dmerrill

PR3 LocoNet and Rocrail v1.3.0

Post by dmerrill » 10.03.2010, 22:41

All

Just downloaded Rocrail to use with LocoNet.

Does thread this mean that Rocrail 1.3.0 revision 982 will not work with my Digitrax PR3 which I understand functions like an MS100?

Thanks,
Dave

coldguy

Post by coldguy » 11.03.2010, 04:23

The PR3 is different from the ms100, but it is the same thing as far as rocrail is concerned. If you find that all you can do is turn track power on and off, get the latest nightly build. You need a newer build of 1.4 to use iroc and many of the newer features anyway.

Post Reply

Return to “Loconet”