[erledigt] srcpd -> Max232ECPE -> Booster - Konfiguration

[erledigt] srcpd -> Max232ECPE -> Booster - Konfiguration

Postby 206HDI » 01.10.2017, 18:21

Die oben erwähnte konstellation lief beim ersten versucht vor zwei Jahren. Leider hatte ich mir keine Notizen gemacht da ich nach dem PC-Welt Artikel vorgegangen war. :(
Jetzt habe ich die Version 2.1.3 und folgendes srcpd.conf
Code: Select all
<?xml version="1.0"?>
<srcpd version="2.1.0">
<!-- generated by srcpd web config generator version 1.4 -->
<!-- save this file as srcpd.conf -->
<bus>
   <server>
      <tcp-port>4303</tcp-port>
      <pid-file>/var/run/srcpd.pid</pid-file>
      <username>nobody</username>
      <groupname>nogroup</groupname>
   </server>
   <verbosity>2</verbosity>
</bus>
<bus>
   <auto_power_on>yes</auto_power_on>
   <verbosity>4</verbosity>
   <device>/dev/ttyS0</device>
   <ddl>
      <number_ga>324</number_ga>
      <number_gl>81</number_gl>
      <enable_maerklin>yes</enable_maerklin>
      <enable_nmradcc>yes</enable_nmradcc>
      <enable_ringindicator_checking>no</enable_ringindicator_checking>
      <enable_checkshort_checking>no</enable_checkshort_checking>
      <inverse_dsr_handling>no</inverse_dsr_handling>
      <shortcut_failure_delay>0</shortcut_failure_delay>
      <nmradcc_translation_routine>3</nmradcc_translation_routine>
      <improve_nmradcc_timing>no</improve_nmradcc_timing>
      <enable_usleep_patch>yes</enable_usleep_patch>
      <usleep_usec>250</usleep_usec>
   </ddl>
</bus>
</srcpd>


Die Gleisspannung ein und ausschalten geht. Aber die Lok macht keinen wank. Hänge ich den Booster an die z21 kann ich in Rocrail die Lok steuern. Also Booster Lok in Ordnung und da ich die Gleisspannung ein und Aussachalten kann sollte die Schaltung um den Max232ECPE stimmen oder?
Beim Versuch die Lok anzusteuern kommt:
15:21:26 Try to reconnect...
Jedoch nicht bei der Gleisspannung

Gruss Peter
Last edited by 206HDI on 01.10.2017, 23:00, edited 3 times in total.
206HDI
 

Re: srcpd -> Max232ECPE -> Booster - Konfiguration

Postby smitt48 » 01.10.2017, 18:42

HI,

Du sollst deine Dateien beifuegen! Die Glaskugel -o ist abgenutzt.
http://wiki.rocrail.net/doku.php?id=issue-de

mfg Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.4) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: srcpd -> Max232ECPE -> Booster - Konfiguration

Postby LDG » 01.10.2017, 18:50

Hallo 206HDI,

wenn Du srcpd als Zentrale verwenden willst sollte zunächst die Kommunikation und Funktion des Servers mit "echten" srcp-Clients geprüft werden.

Läuft der SRCP-Server unter einem Benutzer mit ausreichend Rechten/Berechtigungen (Gruppe "dialout" für Zugriff auf serielle und USB-Schnittstellen) ?
Kannst Du mit "j-man" (aus dem "srcp-Umfeld") als Client die Gleisspannung ein-/ausschalten ?
Kannst Du mit "j-man" eine Lok steuern ? Auch (Licht-)Funktionen ?
Kannst Du mit "j-man" eine Weiche schalten ?

Zum Mithören/Debuggen der SRCP-Daten bietet sich "infomode.pl" (aus dem srcp-Umfeld) an.
Weitere Möglichkeiten einen srcp-Server zu testen gibt es auch im Rocrail-Wiki.

Erst wenn der SRCP-Server/-Daemon damit funktioniert sollte Rocrail ins Spiel kommen.

Gruß,
Lothar
LDG
Site Admin
 

Re: srcpd -> Max232ECPE -> Booster - Konfiguration

Postby 206HDI » 01.10.2017, 20:30

Hallo,

Also die Lok steuern mit j-man geht Licht hat sie keines (ist eine Z-Lok)
Danach ging es, bis zu einem Serverneustart, auch mit Rocrail.

Gruss Peter
You do not have the required permissions to view the files attached to this post.
Last edited by 206HDI on 01.10.2017, 21:09, edited 1 time in total.
206HDI
 

Re: srcpd -> Max232ECPE -> Booster - Konfiguration

Postby rjversluis » 01.10.2017, 21:04

Hi 206HDI,

das man ohne Vorname hier im Forum so viel Unterstützung bekommt ist Wahnsinn.
Also ich würde dir nicht weiter helfen 206HDI.
Es gibt welche die angst für Foren und Internet haben welche im Rocrail Postfach ihre Anliegen ablegen...

MfG
R2D2
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: srcpd -> Max232ECPE -> Booster - Konfiguration

Postby rjversluis » 01.10.2017, 21:12

Beim nächste Beitrag ohne Name fliegst du raus.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: srcpd -> Max232ECPE -> Booster - Konfiguration

Postby smitt48 » 01.10.2017, 21:19

Hi R2D2,

Er hat es geaendert!

Gruss Peter
Last edited by 206HDI on 01.10.2017, 16:09, edited 1 time in total.


Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.4) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: srcpd -> Max232ECPE -> Booster - Konfiguration

Postby LDG » 01.10.2017, 22:36

Hallo Peter,

es liegt wohl am derzeit in Rocrail nicht eindeutig eingestellten Lokdekoder-Protokoll-Typ.
Bitte von "ServerDefined" auf "NMRA-DCC" umstellen (Protokollversion für kurze Adressen (bis 127) auf 1 lassen, für lange Adressen (ab 128) auf 2 stellen) und Rocrail neu starten damit die Lok beim Start bzw. bei Benutzung mit dem richtigen Protokoll am SRCP-Server angemeldet wird.

Gruß,
Lothar
LDG
Site Admin
 

Re: srcpd -> Max232ECPE -> Booster - Konfiguration

Postby 206HDI » 01.10.2017, 23:00

Hallo Lothar,

Danke vielmals das war es :thumb_up:
Nun läuft es wunderbar :D


Hallo Tom,

Dank Dir auch vielmals habe alle meine Post angepasst.

Gruss Peter
206HDI
 


Return to RaspberryPi / Odroid (DE)

cron