[erl.] FiFo: Probleme Enter und In Aktion

Re: FiFo: Probleme Enter und In Aktion

Postby rjversluis » 06.01.2018, 11:33

Zum Ablauf 1:
Auto1 hat bereits das nächste Block und FS reserviert, und bekommt plötzlich ein Rotessignal für dies Nase gestellt...
Irgendwie passt es nicht echt.

Nachtrag: Ich habe da jetzt was eingebaut und es funktioniert auch aber ich bin von diese Ablauf nicht begeistert.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: FiFo: Probleme Enter und In Aktion

Postby rjversluis » 06.01.2018, 11:48

Ablauf 1 mit ein ICE:

ICE startet mit V_max weil b1 und b2 reserviert sind und bei enter auch das Vorsignal OK zeigt.
Jetzt kommt eine und stellt das Hauptsignal auf Rot... Meinst du wirklich das der ICE da noch anhält?

Das signal kann man auch auf Rot stellen wenn der ICE kurz vor IN ist und dann bekommt es bei IN V_0 und läuft bis in b2 und nimmt alles mit was sich zwischen b1 und b2 befindet.

Es ist auch unrealistisch wenn der ICE ein Grünes Vorsignal passiert hat, das Haupsignal was der Lokführer noch nicht sehen kann, plötzlich Rot wird. Ich glaube nicht das der Lokführer Geschwindigkeit zurück nimmt.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 06.01.2018, 11:54

Rob,

zu Ablauf 1:
Auto1 soll eben nicht anhalten wie jetzt, sondern noch ausfahren (Orange Ampel hast du es neulich genannt bei Auto2), da FS schon gestellt.

Drum habe ich zu Ablauf1 geschrieben:
Auto1 soll noch ausfahren, Auto2 und 3 auf Vmid gehen und Auto2 dann am IN auf V0

Grüße Dieter
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 06.01.2018, 12:09

Rob,

wir meinen genau das gleiche.
Derzeit geht Auto1 am IN auf V0 wenn das Signal rot ist (Vollbremsung) obwohl es FS nach b2 schon gestellt hat.
Das ist schlecht, wie dein ICE Beispiel zeigt.

Also bei Abauf 1 meines Erachtens korrekt:
- Wenn das erste Auto schon FS gestellt hat, fährt es noch aus und geht nicht am IN auf V0 (nennen wir es Ampel Orange-Phase)
- Die Follower gehen auf VMid und der erste Follower hält am IN mit V0 an (da er sich keine FS aufgrund rotem Signal stellen kann).

Grüße Dieter
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

Re: FiFo: Probleme Enter und In Aktion

Postby peter&basti » 06.01.2018, 12:14

Hi Rob, Dieter,

es sind halt unterschiedliche Rahmenbedingungen bei der Bahn und bei Cars.

- bei der Bahn werden die Signale synchron zur Fahrstraße gestellt und von dieser FS oder einem Achszähler auch wieder zurückgestellt. Frei geht erst wieder wenn der Block frei gemeldet wird.

- beim Strassenverkehr werden die Ampeln asynchron gestellt. Die Regeln ob ein Autofahrer bei gelb (oder in Österreich bei grün blinken) noch stehen bleiben muss oder nicht sind in der Strassenverkehrsordnung niedergeschrieben . Hier gibt es ja auch keine Fahrstrasse im eigentlichen Sinne.

Aus meiner Sicht sind die FIFO Blöcke und Signale als Ampel bereits ein sehr guter Kompromiss, Autoverkehr mit Eisenbahntechnik abzubilden :wink:
Liebe Grüße / best regards
Peter


System: DCC 2-Leiter H0, Rocrail 64bit auf Win10 Pro 64
Traktion: OpenDCC GBM
Fahrweg: RocNetNode & GCA PI01/2/3, GCA41/Arduino RFID, GCA145 Drehscheibe, etc.
Decoder: 99% Zimo
Experimentell: MQTT & Node-Red
peter&basti
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 06.01.2018, 12:20

Hi Peter,

eben, Bahn und Cars sind anders.
Wir hatten das Thema neulich (Vorseite) genau gleich, nur war da Auto1 schon in b2 und Auto2 hatte sich schon die FS nach b2 gestellt. Ergo musste Auto2 trotz zwischenzeitlich rotem Signal noch ausfahren:


rjversluis wrote:Hi Dieter,
Rob, vielleicht wäre folgendes machbar, wenn Signal b1 auf rot geht und Auto2 hat bereits die FS nach b2 (da Auto1 schon am Enter von b2 war), Auto2 war aber selbst noch nicht am IN von b1:
- Die FS von Auto2 wieder wegnehmen, auf VMid gehen und am IN auf V0
(Bisher: Auto2 fährt über das rote Signal aus, da FS bereits gestellt)

nein, das ist nicht möglich weil Auto2 hat schon logisch IN und fährt zum nächste Ziel.
Der Ampel muss erst eine weile Orange zeigen anstatt sofort Rot. ;)


Das ist ok, das hat Rob die Orange Phase genannt.

Nun haben wir Ablauf 1, alle 3 sind noch in b1, Auto1 hat sich die FS nach b2 gestellt und sollte dementsprechend noch ausfahren, bekommt aber jetzt am IN einen V0 verpasst (Vollbremsung).
Deshalb ist es meines Erachtens richtig, daß Auto1 noch ausfährt und eben keinen V0 bekommt.

Also bei Abauf 1 meines Erachtens korrekt:
- Wenn das erste Auto schon FS gestellt hat, fährt es noch aus und geht nicht am IN auf V0 (nennen wir es Ampel Orange-Phase)
- Die Follower gehen auf VMid und der erste Follower hält am IN mit V0 an (da er sich keine FS aufgrund rotem Signal stellen kann).


Grüße Dieter
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

Re: FiFo: Probleme Enter und In Aktion

Postby rjversluis » 06.01.2018, 12:31

OK, jetzt ist Ablauf 1 abgedeckt wenn der Lok Engine type Automobile hat.
Ich habe mit Auto1 und follower Auto2 getestet.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 06.01.2018, 13:26

rjversluis wrote:OK, jetzt ist Ablauf 1 abgedeckt wenn der Lok Engine type Automobile hat.
Ich habe mit Auto1 und follower Auto2 getestet.


Hi Rob,

mit welcher Rev?
Ich habe grad gepulled und mit 13358 funktioniert es nicht, da bleiben nach Signal Rot alle auf VBlock/FS, die Follower gehen nicht auf VMid. (siehe Bild1)

Deine Änderung wird für Auto1 korrekt ausgeführt:
Code: Select all
20180106.165253.821 r9999a cmdr0504 OBlock   0116 signal [sig-b1] [red] event
...
20180106.165255.813 r9999a 00001B90 OLcDrive 0046 ignore wait in block [b1] for automobile [Auto1]

Aber die Follower Auto 2 und 3 gehen nicht (mehr) auf Vmid nach rotem Signal.

Grüße Dieter
You do not have the required permissions to view the files attached to this post.
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 06.01.2018, 23:59

Rob,

du hast das vermutlich falsch verstanden.
Mit 13358 fahren jetzt alle 3 bei rotem Signal mit VBlock/FS aus.
Es soll aber nur Auto 1 ausfahren, die Follower Auto2 und 3 sollen auf Vmid gehen wenn das Signal auf rot geht (wie vor 13358).

Drum schrieb ich:
Also bei Abauf 1 meines Erachtens korrekt:
- Wenn das erste Auto schon FS gestellt hat, fährt es noch aus und geht nicht am IN auf V0 (nennen wir es Ampel Orange-Phase)
- Die Follower gehen auf VMid und der erste Follower hält am IN mit V0 an (da er sich keine FS aufgrund rotem Signal stellen kann).


Grüße Dieter
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

Re: FiFo: Probleme Enter und In Aktion

Postby rjversluis » 07.01.2018, 08:23

Moin,

ich teste mit Auto1 und Auto2.
Beide fahren in b1 mittels Enter.
Signal geht auf Rot.
Auto1 fährt weiter über In nach b2.
Auto2 bekommt Vmid bis es In erreicht dann bekommt es V0.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 07.01.2018, 09:33

rjversluis wrote:Moin,

ich teste mit Auto1 und Auto2.
Beide fahren in b1 mittels Enter.
Signal geht auf Rot.
Auto1 fährt weiter über In nach b2.
Auto2 bekommt Vmid bis es In erreicht dann bekommt es V0.


Moin Rob,

Test mit Nightly 13359, geht bei mir nicht:
Alle 3 Autos in die Startblöcke und nacheinander starten
- 3x Enter b1 (alle sind jetzt in Block b1, noch keiner war am IN)
- Signal b1 jetzt auf Rot (alle bleiben auf VBlock/FS, im Beispiel 100)
- IN b1 für Auto1 (Auto1 und 2 bleiben auf VBlock/FS, Auto3 geht auf Vmid)

Trace anbei und dein Beispielplan.

PS: Kann es sein, daß Auto2 bei dir schon mit VMID (im Beispiel 40) einfährt wegen abzweigender Weichenstraße?
Ich habe keine Geschwindigkeitsänderung bei abzweigender Weichenstraße, dadurch sind alle mit VBlock/FS (im Beispiel 100) in b1.

Grüße Dieter
You do not have the required permissions to view the files attached to this post.
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 07.01.2018, 11:45

@Peter,

wenn du mal Zeit hast, teste bitte mal die beiden beschriebenen Abläufe mit der neuesten Rev.

Ablauf1:
-Alle 3 Autos nach b1, sind jetzt alle mit V100 in b1.
-Signal b1 jetzt auf Rot
Bei mir bleiben jetzt alle auf V100

Ablauf2:
Signal b1 auf rot
Alle 3 nach b1 starten
Alle gehen am Enter auf Vmid (40).
Auto1 geht am IN auf V0
Soweit ok.
Jetzt Signal auf grün.
Auto1 geht auf V100, die Followe nicht (sollten das aber jetzt auch).

Grüße Dieter
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 07.01.2018, 14:45

rjversluis wrote:Moin,

ich teste mit Auto1 und Auto2.
Beide fahren in b1 mittels Enter.
Signal geht auf Rot.
Auto1 fährt weiter über In nach b2.
Auto2 bekommt Vmid bis es In erreicht dann bekommt es V0.


Hi Rob,

es ist so wie du schreibst, aber sobald es mehrere Follower sind geht nur der letzte auf Vmid. Und der erste Follower geht dann am IN von b1 direkt von VBlock/FS (im Beispiel 100) auf V0.
Alle Follower sollen auf Vmid gehen und der erste Follower dann am IN von b1 von VMid auf V0 gehen.

Wenn du das korrigiertst, kannst du bitte dann auch gleich noch nach Ablauf2 (siehe oben) schauen.

Grüße Dieter
You do not have the required permissions to view the files attached to this post.
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

Re: FiFo: Probleme Enter und In Aktion

Postby rjversluis » 07.01.2018, 14:47

hast du ein Geduld...
git pull.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBUS - CANGCx ] - [ G: CBUS - CANGCx ]
rjversluis
Site Admin
 

Re: FiFo: Probleme Enter und In Aktion

Postby lordbrummi » 07.01.2018, 14:53

kann nicht pullen ;) (nur noch pullern :wink: )

remote: You are not allowed to download code from this project.
fatal: unable to access 'https://gitlab.com/rocrail/Rocrail.git/': The requested URL returned error: 403


Bin aber angemeldet...

Grüße Dieter

PS: Geht wieder, danke!
TamsMC, Servodecoder und Magnetartikeldecoder, S88 Rückmeldung, OpenCar und 3-Leiter Bahn, Win10 64bit, RR 64bit
lordbrummi
 

PreviousNext

Return to CarSystem (DE)