Fehlerhafte Kommunikation mit Intellibox II/Loconet

Post Reply
Masimo
Posts: 1
Joined: 28.03.2018, 17:18

Fehlerhafte Kommunikation mit Intellibox II/Loconet

Post by Masimo » 11.04.2018, 17:29

Hallo zusammen,

nachdem ich nun schon lange versucht habe das Problem selbst zu lösen, dies mir aber nicht gelingen will, wende ich mich nun an die Gemeinschaft. Ich hoffe es ist nur ein "Anfängerfehler" und bitte in diesem Zusammenhang, evtl. Missverständnisse zu entschuldigen. Nun aber zu meinem Problem:

Ich habe auf meinem Raspberry Rocrail installiert und mittels USB die Verbindung zur Intellibox hergestellt. Das Einrichten der Schnittstelle hat soweit auch alles geklappt und ich kann auch meine Anlage steuern. Allerdings kommen in dem Serverfenster immer wieder Fehlermeldungen wie "echo timer timed out for OPCODE 0xBB". Bereits beim Start läuft diese Meldung drei mal auf und quasi bei jedem Befehl der zur Anlage geht.

Ich hoffe man kann mit der kurzen Beschreibung etwas anfangen, ansonsten bitte einfach nachfragen. DANKE
Attachments
issue.zip
(24.75 KiB) Downloaded 7 times

smitt48
Moderator
Posts: 5844
Joined: 04.04.2014, 01:07
Location: Kralendijk, Bonaire - Dutch Caribbean

Re: Fehlerhafte Kommunikation mit Intellibox II/Loconet

Post by smitt48 » 11.04.2018, 18:05

Hi ????

Ich weiss nichts davon, aber dies hilft dir

http://wiki.rocrail.net/doku.php?id=loc ... e&s[]=0xbb

mfg Tom

jpultar
Posts: 784
Joined: 23.04.2017, 14:33

Re: Fehlerhafte Kommunikation mit Intellibox II/Loconet

Post by jpultar » 12.04.2018, 06:09

Hi Tom,

ich habe auch diverse Loconet Meldungen - auch hin und wieder auch mal solche "echo timer timed out for OPCODE ..." in der Kombination RR (aktuellste Version) an Uhlenbrock IB2 und Win 10 mit RR 64bit.
Aber - mir hilft der Link da leider nicht weiter. Was kann ich daraus ablesen / verstehen / ändern?
Da es im Betrieb bei diesen Meldungen nicht zu Fehlverhalten oder Problemen kommt, habe ich das bislang nicht weiter verfolgt.
Ich hatte nur im Hinterkopf mal eine Aussage, dass RR und Loconet auf IB2 nicht immer "beste Freunde" sind :?

rjversluis
Site Admin
Posts: 40958
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Fehlerhafte Kommunikation mit Intellibox II/Loconet

Post by rjversluis » 12.04.2018, 06:26

Moin,

0xBB wird verwendet um ein LocoNet Slot aus zu lesen vom Zentrale.
Das wird hauptsächlich für Loks gemacht und FastClock.
So wie es aussieht reagiert IB nicht auf ein 0xBB im Falle von FastClock.
Man kann es abwählen:
http://wiki.rocrail.net/doku.php?id=int ... en#details

jpultar
Posts: 784
Joined: 23.04.2017, 14:33

Re: Fehlerhafte Kommunikation mit Intellibox II/Loconet

Post by jpultar » 12.04.2018, 08:04

Hallo Rob,

ich habe mal "Fast Clock" rausgenommen.

Beim RR Start kommen bei mir immer solche Meldungen:
The support key expires in 982 days.
20180412.085448.871 r9999W 00002D7C OControl 1885 power off, freeze clock
20180412.085448.934 r9999E 000027D0 OLocoNet 1841 Could not get slot for loco addr=5. (no response...)
20180412.085448.996 r9999E 00000718 OLocoNet 1841 Could not get slot for loco addr=4. (no response...)
20180412.085449.059 r9999E 00001174 OLocoNet 1841 Could not get slot for loco addr=1. (no response...)
20180412.085449.121 r9999E 00002D98 OLocoNet 1841 Could not get slot for loco addr=6. (no response...)
20180412.085449.184 r9999E 000027D0 OLocoNet 1841 Could not get slot for loco addr=5. (no response...)
20180412.085449.246 r9999E 00000718 OLocoNet 1841 Could not get slot for loco addr=4. (no response...)
20180412.085449.605 r9999W ulniread ulni 0209 undocumented message: start=0xFC
20180412.085449.652 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085449.684 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085449.715 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085449.746 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085449.777 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085449.809 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085449.840 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085449.871 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085449.902 r9999W ulniread ulni 0209 undocumented message: start=0xF8
20180412.085449.949 r9999W ulniread ulni 0209 undocumented message: start=0xF8
20180412.085449.996 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085450.027 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085450.059 r9999E 000027D0 OLocoNet 1841 Could not get slot for loco addr=5. (no response...)
20180412.085450.059 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085450.090 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085450.121 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085450.168 r9999W ulniread ulni 0209 undocumented message: start=0xF0
20180412.085450.215 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085450.246 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085450.277 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085450.309 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085450.340 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085450.371 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085450.402 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085450.434 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.085451.059 r9999W 00000718 OLocoNet 1837 Could not get slot for loco addr=4. (un expected response 0xB2...)
20180412.085452.059 r9999W 000027D0 OLocoNet 1837 Could not get slot for loco addr=5. (un expected response 0xB2...)
Ich habe keine Idee, was mir dass alles sagen soll ...

rjversluis
Site Admin
Posts: 40958
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Fehlerhafte Kommunikation mit Intellibox II/Loconet

Post by rjversluis » 12.04.2018, 08:58

Hallo Jürgen,

versuche es mit "Auf Slot-Daten warten":
http://wiki.rocrail.net/doku.php?id=dr5 ... et-details
zu erhöhen.

Und aktualisiere Rocrail.

jpultar
Posts: 784
Joined: 23.04.2017, 14:33

Re: Fehlerhafte Kommunikation mit Intellibox II/Loconet

Post by jpultar » 12.04.2018, 09:22

Hallo Rob,

habe ich mal auf 128 (=max) hochgedreht - da ändert sich nix ...
Rocrail 13835 [53374d29de446478a42314c9f15d09852a25276b][Nightly]
Build: Apr 10 2018 06:02:19
librocs 2.0-0 build Apr 10 2018 06:00:20
processid = 9196
mac = 7427EA26D07F0000
guid = 7427EA26D07F20180412101953977000
pwd = C:\Rocrail\Rocrail_Aktiv
args = OCmdLn: key=-l value=C:\Program Files\Rocrail, key=-w value=C:\Rocrail\Rocrail_Aktiv,
--------------------------------------------------
The support key expires in 982 days.
20180412.101955.235 r9999W 00002154 OControl 1885 power off, freeze clock
20180412.101955.282 r9999E 000028B0 OLocoNet 1841 Could not get slot for loco addr=5. (no response...)
20180412.101955.345 r9999E 000028C4 OLocoNet 1841 Could not get slot for loco addr=4. (no response...)
20180412.101955.407 r9999E 00001DE0 OLocoNet 1841 Could not get slot for loco addr=1. (no response...)
20180412.101955.470 r9999E 00001E20 OLocoNet 1841 Could not get slot for loco addr=6. (no response...)
20180412.101955.532 r9999E 000028B0 OLocoNet 1841 Could not get slot for loco addr=5. (no response...)
20180412.101955.595 r9999E 000028C4 OLocoNet 1841 Could not get slot for loco addr=4. (no response...)
20180412.101955.657 r9999E 0000220C OLocoNet 1841 Could not get slot for loco addr=2. (no response...)
20180412.101955.939 r9999W ulniread ulni 0209 undocumented message: start=0xFE
20180412.101955.986 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.017 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.048 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.079 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.111 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.142 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.173 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.204 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.282 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.314 r9999W ulniread ulni 0179 undocumented message: start=0xC0
20180412.101956.345 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.376 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.407 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.439 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.470 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.501 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.501 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.532 r9999W ulniread ulni 0179 undocumented message: start=0xC0
20180412.101956.564 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.579 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.611 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101956.642 r9999W ulniread ulni 0179 undocumented message: start=0xE0
20180412.101957.579 r9999E ulniwrit ulni 0299 echo timer timed out for OPCODE 0xBA

rjversluis
Site Admin
Posts: 40958
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Fehlerhafte Kommunikation mit Intellibox II/Loconet

Post by rjversluis » 12.04.2018, 09:37

Hi Jürgen,

ich habe mal

Code: Select all

undocumented message: start
auf Trace level BYTE umgestellt weil da kann man nichts machen ohne Digitrax-LocoNet Lizenz.

Das dein IB am Anfang kein Slots liefern kann ist ein Uhlenbrock Sache; Kann ich nichts dafür.

Hast du alle Empfehlungen so übernommen wie im Wiki steht?
http://wiki.rocrail.net/doku.php?id=intellibox-basic-de

jpultar
Posts: 784
Joined: 23.04.2017, 14:33

Re: Fehlerhafte Kommunikation mit Intellibox II/Loconet

Post by jpultar » 12.04.2018, 09:51

Hi Rob,

ja, diese Einstellungen für IB2 bin ich im Detail alle schon mehrmals durch und habe da auch schon vieles probiert.
Da das ja wirklich nur beim Start passiert und keinerlei Einfluss auf Funktionalität oder Betriebssicherheit hat, habe ich das bislang auch kpl. ignoriert.
Für mich ist das kein Issue von RR - habe mich da auch nur an den Thread von Masimo rangehängt weil ich dachte, das wäre evtl. eine hilfreiche Zusatzinfo.

Also - für mich ist das alles ok so und "works as designed" :thumb_up:

jpultar
Posts: 784
Joined: 23.04.2017, 14:33

Re: Fehlerhafte Kommunikation mit Intellibox II/Loconet

Post by jpultar » 12.04.2018, 16:28

Hallo Rob,

ich greife das Thema doch noch mal auf mit folgender Ergänzung:

Unter Windows startet Rocrail Server und Rocview Client nahezu zeitgleich. Das verursacht diese Start-Meldungen.
Lasse ich den Rocrail Server jedoch laufen, beende nur Rocview und starte dann Rocview neu ist alles super - keine Meldung!

Wie bekomme ich mit der richtigen rocrail.ini den Server separat gestartet (z.B. beim Systemstart des Rechners), bevor ich dann manuell Rocview starte?

rjversluis
Site Admin
Posts: 40958
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Fehlerhafte Kommunikation mit Intellibox II/Loconet

Post by rjversluis » 12.04.2018, 16:31

Hallo Jürgen,

du kannst genau so gut die Hände für die Augen machen wenn du Rocrail startest und dann das Server Fenster löschen.
Also, die Probleme sind da, aber du möchtest diese Probleme nicht mehr sehen.

jpultar
Posts: 784
Joined: 23.04.2017, 14:33

Re: Fehlerhafte Kommunikation mit Intellibox II/Loconet

Post by jpultar » 12.04.2018, 16:36

Hi Rob,
klare Aussage, verstanden und von meiner Seite aus Funkstille :-)
Wahrscheinlich wird das Server Fenster in Rocview auf diesem Weg dann erst gestartet, wenn alle Meldungen schon durch sind ...
War nicht bis zu Ende gedacht - Anwender eben :-)

Post Reply

Return to “RaspberryPi / BananaPi (DE)”