[erl] Raspberry Pi3 - Server Crash

halakerk
Posts: 147
Joined: 25.04.2014, 20:26
Location: 47647 Kerken

Re: [Wieder] Raspberry Pi3 - Servercrash

Post by halakerk » 08.04.2017, 13:24

Hallo Rob,

ich habe den Server im Terminalfenster laufen lassen. Der Output ist im Zip-File, aber hier nochmal separat. Am Ende ist eine Fehlermeldung. Falls erforderlich, kann ich auch nochmal debuggen.

Grüße vom Niederrhein
Hartmut
Attachments
lxtermdmp.txt
(16.08 KiB) Downloaded 5 times

rjversluis
Site Admin
Posts: 39203
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: [Wieder] Raspberry Pi3 - Servercrash

Post by rjversluis » 08.04.2017, 13:46

Hi Hartmut,

gerne kann ich ein Debug Installer bereit stellen, aber es sieht wieder nach ein SD-Karte Problem aus, oder zu wenig Speicher.

rjversluis
Site Admin
Posts: 39203
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: [Wieder] Raspberry Pi3 - Servercrash

Post by rjversluis » 08.04.2017, 16:02

Hi Hartmut,

SIGABRT, 6, kommt aus der C-Library welche zu wenig Heap hat und sein Speicherblöcke Buchführung durcheinander gekommen ist...
Wieviel Speicher steht dann zur verfügung?

Beobachte mal in ein anderes Terminal Fenster mit

Code: Select all

free -h
wieviel freie Speicher noch vorhanden ist.

halakerk
Posts: 147
Joined: 25.04.2014, 20:26
Location: 47647 Kerken

Re: [Wieder] Raspberry Pi3 - Servercrash

Post by halakerk » 11.04.2017, 19:44

Hallo Rob,

ich habe jetzt noch mal mehrere Stunden Betrieb gemacht, keine Probleme.

Zum Speicher: Auf dem Raspi3 läuft nur Rocrail und der RealVNC Server.
Speicher nach "free -h":
Mem: Total: 925M Used : 365M free: 560M shared: 12M buffers: 29M cached: 136M
+/- buffers/cache: 199M 726M
Swap: 99M 0M 99M

Mir ist aufgefallen, dass der Speicherverbrauch während des Betriebs langsam, aber stetig wächst. Die angezeigten Werte haben sich nach ca. 3 Stunden Automatikbetrieb eingestellt.
Ich beobachte das noch eine Zeit und setze dann das Thema auf erledigt, wenn sich nichts Neues ergibt.

Grüße vom Niederrhein
Hartmut

halakerk
Posts: 147
Joined: 25.04.2014, 20:26
Location: 47647 Kerken

Re: [Wieder] Raspberry Pi3 - Servercrash

Post by halakerk » 14.04.2017, 20:16

Hallo Rob,
Heute konnte ich nochmal ca. 2 Stunden störungsfreien Betrieb machen, allerdings gab es 2 Falschmeldungen in Rocview, der Server sei abgestürzt. Das ließ sich dann nicht nachvollziehen, Server und Automatik liefen normal durch.
Ich setze das Thema wieder auf "erledigt".

Grüße vom Niederrhein
Hartmut

halakerk
Posts: 147
Joined: 25.04.2014, 20:26
Location: 47647 Kerken

Servercrash

Post by halakerk » 29.03.2018, 20:32

Hallo,
heute hatte ich seit längerer Zeit wieder einen Servercrash, insgesamt 3x heute, den letzten habe ich dokumentiert, inkl. gdb output. Core Datei wurde nicht erzeugt.
Stretch hatte ich am Wochenende aktualisiert, Rocrail ist der Build von gestern. Rocview läuft auf einem separaten Raspi. Die Verbindung von Rocview zum Server steht noch, es gab kein Benachrichtigungs-PopUp. Der Server reagiert allerdings nicht mehr auf Eingaben in Rocview.
Dateien sind angehängt.

Grüße vom Niederrhein
Hartmut
Attachments
crash_180329_1.zip
(48.05 KiB) Downloaded 6 times

rjversluis
Site Admin
Posts: 39203
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Raspberry Pi3 - Servercrash

Post by rjversluis » 30.03.2018, 05:46

Moin Hartmut,

alle Jahre wieder?
Ich habe die beide Server Crash Themen von dir zusammen gefügt.

Leider gibt der Backtrace kein Information.
Kannst du Trace Level Info und Automat dazu schalten?
Kommt es immer nach eine gewisse Laufzeit, oder bestimmte Umstände?

halakerk
Posts: 147
Joined: 25.04.2014, 20:26
Location: 47647 Kerken

Re: Raspberry Pi3 - Servercrash

Post by halakerk » 03.04.2018, 21:59

Hallo Rob,

in den letzten Tagen konnte ich problemlos auch längere Zeit Betrieb machen, auch mit der gestern installierten Version 13789, ohne dass ich am Plan etwas verändert hatte.
Ich gehe mal davon aus, dass mein Raspi einfach einen schlechten Tag hatte...

Grüße vom Niederrhein
Hartmut

halakerk
Posts: 147
Joined: 25.04.2014, 20:26
Location: 47647 Kerken

Servercrash - Segmentation fault

Post by halakerk » 27.06.2018, 10:28

Hallo Rob,
nachdem ich lange Zeit Ruhe hatte, treten in den letzten Tagen Probleme mit Serverabstürzen auf. Ich habe Rocrail deswegen im Debugger laufen lassen, leider ist das wohl nicht sehr aussagekräftig. Tracelevel "Monitor" hatte ich noch wegen eines anderen Problems eingeschaltet.
Wenn der Crash auftritt, war es die letzten Male immer bei der Einfahrt von Lok 221 137 in den Block h1b02. Allerdings passiert das nicht jedes Mal.
Der Server lief wohl noch irgendwie weiter, der Watchdog hatte einen Nothalt ausgelöst, das Erstellen eines Issues über Rocview funktionierte allerdings nicht.
Vielleicht siehst Du ja was in den Dateien.

Grüße vom Niederrhein
Hartmut
Attachments
segmentation_fault.zip
(51.98 KiB) Downloaded 2 times

rjversluis
Site Admin
Posts: 39203
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Servercrash - Segmentation fault

Post by rjversluis » 27.06.2018, 10:35

Hi Hartmut,

war sonnst nichts im Terminal Fenster? Die Zeilen vorher?

Hier überschlagt sich eine Aktion:

Code: Select all

0180627.110057.463 r9999W bidibrea OAction  2073 action timer for [h1m01von] is already active
2

rjversluis
Site Admin
Posts: 39203
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Servercrash - Segmentation fault

Post by rjversluis » 27.06.2018, 11:03

Hi Hartmut,

ich erstelle mal ein Raspi Build mit Debug Info für dich.

rjversluis
Site Admin
Posts: 39203
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Servercrash - Segmentation fault

Post by rjversluis » 27.06.2018, 12:00

Hallo Hartmut,

bitte folgendes Paket benutzen zum Debuggen:
https://launchpad.net/rocrail/sunrise/2 ... -armhf.deb

rjversluis
Site Admin
Posts: 39203
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Servercrash - Segmentation fault

Post by rjversluis » 28.06.2018, 07:03

Moin Hartmut,
halakerk wrote: nachdem ich lange Zeit Ruhe hatte, treten in den letzten Tagen Probleme mit Serverabstürzen auf.
was hast du geändert?

halakerk
Posts: 147
Joined: 25.04.2014, 20:26
Location: 47647 Kerken

Re: Servercrash - Segmentation fault

Post by halakerk » 28.06.2018, 17:06

Hallo Rob,

ich habe jetzt die Debug Version installiert und laufenl lassen. Nach einiger Zeit dann wieder der Absturz. Die Verbindung zu Rocview bleibt dabei erhalten, der Watchdog löst einen Nothalt aus. Dateien sind angehängt.
Was habe ich geändert?
In letzter Zeit habe ich den Plan im Bereich Kopfbahnhof ergänzt, Fahrstraßen erstellt, Adressen bei den bisher antriebslosen Weichen eingetragen, Ausgänge für die Herzstückrelais angelegt, Aktionen dafür erstellt und die bisher noch fehlenden 2 Servodecoder (Tams Multidecoder) über Bidib angeschlossen.
Die Aktion, die Dir aufgefallen war (und noch ein paar ohne Verwendung), habe ich gelöscht. Das hat aber wohl keine Besserung gebracht.
Vielleicht siehst Du ja noch was.
Falls Du es für sinnvoll hältst, könnte ich auch die SD Karte inkl. Stretch tauschen. Ich habe noch einen identischen Raspi für Rocview.

Grüße vom Niederrhein
Hartmut
Attachments
segmentation_fault3.zip
(49.13 KiB) Downloaded 3 times

rjversluis
Site Admin
Posts: 39203
Joined: 10.04.2006, 08:48
Location: Speyer, Germany
Contact:

Re: Servercrash - Segmentation fault

Post by rjversluis » 28.06.2018, 17:11

Hallo Hartmut,

Danke fürs debuggen.
Die Stelle ist klar und verlangt ein Korrektur, welche ich Morgen vornehme.
Ich berichte dann wenn es so weit ist, und wenn ein neue Debug Installer für armhf vorhanden ist.

Post Reply

Return to “RaspberryPi (DE)”