z21 detecteert geen kortsluiting als het moet

z21 detecteert geen kortsluiting als het moet

Postby Freek » 06.03.2018, 21:10

Hallo,

ik ben onlangs begonnen met rocrail, ik heb mij hiervoor een z21 aangeschaft (witte). Hierop hangt er ook een multimaus.
Momenteel ben ik aan het testen met mijn schaduwstation en ik denk dat ik de basis nu wel onder de knie heb.

In mijn schaduwstation gebruik ik op sommige plaatsen nog van die oude lima wissels die soms al eens kortsluiting durven geven als er een lok of wagon over rijdt.
In de meeste gevallen gaat de centrale dan in error en gaat de rode led knipperen en er verschijnt een bliksem op het scherm van de multimaus. In rocrail zie je dan ook dat de centrale af staat.
Of alles blijft gewoon werken.

Maar soms gebeurd het dat als er een lok over zo'n wissel rijdt dat de spanning wordt afgezet. Maar er komt geen enkele melding van, de centrale geeft gewoon een blauwe led (niet knipperend) geen melding op de multimaus en rocrail denkt ook nog altijd dat er spanning op de rails staat. Als ik dan de de spanning af en op zet vanuit rocrail of op de multimaus (2x op stop drukken), dan werkt alles weer normaal.
Als ik de treinen manueel bestuur, (dus rocrail staat aan maar niet op automatisch) met de multimaus dan kan ik dit fenomeen niet reproduceren. Dan blijven ofwel de treinen gewoon doorrijden ook al kwam er een vonk van onder de wielen uit, ofwel gaat de centrale in de fout.
Dus ik denk dat het iets met rocrail te maken heeft?

Ik heb gezien dat er een mogelijkheid is om een sensor te gebruiken om aan rocrail door te geven als er kortsluiting is, maar dit heb ik nog niet getest.
Het is wel de bedoeling dat die wissels geen kortsluiting meer geven, maar het is zeer vervelend als alles ineens stil staat en er komt nergens een melding van wat er mis is.
Enig idee waar ik moet zoeken?
Freek
 

Re: z21 geeft geen fout als het moet

Postby smitt48 » 06.03.2018, 21:27

Hi ???,

Probeer het probleem te herhalen. Als het gebeurt doe het volgende: http://wiki.rocrail.net/doku.php?id=issue-nl
Voor je dat doet moet je de trace level zetten"info, monitor en automaat (als je automatisch rijdt).

Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.4) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: z21 geeft geen fout als het moet

Postby Freek » 06.03.2018, 22:38

Ik heb het terug kunnen reproduceren.
Ik weet niet of het de vorige keren ook zo was, maar om het probleem sneller te kunnen reproduceren heb ik de lok een beetje geholpen door hem richting kortsluiting te sturen (duwen).
De eerste keer gaf dit dan wel een error op de centrale en in rocrail, maar de 2e keer niet.
In de issue.zip zit ook een screenshot van het moment dat de centrale de spanning heeft afgezet, maar toch geen melding van geeft.
Rechts onderaan staan alle bollen in het groen, maar spanning en stroom staan wel degelijk op 0.

Hoe gaat het eigenlijk in het werk in het geval van zo'n kortsluiting? beslist de centrale zelf om alles af te zetten of stuurt de centrale een commando naar rocrail die dan een commando terug stuurt om de centrale af te zetten?
You do not have the required permissions to view the files attached to this post.
Freek
 

Re: z21 geeft geen fout als het moet

Postby rjversluis » 07.03.2018, 07:58

Hallo,

de centrale is daarvoor verantwoordelijk om een kortsluiting vast te stellen.
Als de draden naar deze plek dun en lang zijn dan kan de centrale geen kortsluiting vaststellen.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: z21 detecteert geen kortsluiting als het moet

Postby Freek » 07.03.2018, 20:38

De centrale stelt wel degelijk een kortsluiting vast en zet de spanning ook echt wel af, maar dit wordt soms nergens terug gegeven. De led op de z21 blijft dan gewoon blauw branden, op het scherm staat dan ook niets.
Dus er is iets dat er voor zorgt dat de centrale geen fout geeft hoewel ze wel in fout staat. Ik kan dit alleen reproduceren als ik de treinen laat rijden vanuit rocrail.

Het gaat mij er vooral over dat de centrale soms de spanning afzet na een kortsluiting maar hier geen feedback van geeft. Al de rest is zoals ik het verwacht.
IK weet niet of je iets kan afleiden uit de trace van vorige reactie?
Freek
 

Re: z21 detecteert geen kortsluiting als het moet

Postby rjversluis » 07.03.2018, 22:08

Code: Select all
20180306.222006.018 r9999c z21reade OZ21     1365 LAN_X_BC_TRACK_SHORT_CIRCUIT (192.168.0.111)
20180306.222006.018 r9999c z21reade OZ21     1355 LAN_X_BC_TRACK_POWER_OFF (192.168.0.111)
20180306.222006.018 r9999W 00001FD0 OControl 1865 power off, freeze clock
20180306.222006.018 r9999I 00001FD0 OControl 0925 freeze/resume clock not possible with real time
20180306.222006.127 r9999I transact OXpressN 1039 Sensor 522=off
20180306.222006.174 r9999I transact OXpressN 1039 Sensor 572=off

20180306.222019.165 r9999c 00001554 OZ21     0401 LAN_X_SET_TRACK_POWER_ON
20180306.222019.165 r9999c 00001554 OXpressN 0645 Power ON

de kortsluiting wordt gemeld en na 13 seconden wordt deze weer opgeheven.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: z21 detecteert geen kortsluiting als het moet

Postby Freek » 07.03.2018, 22:17

Ik heb eerst een echte melding gekregen van een kortsluiting, ik heb de spanning terug aan gezet en daarna opnieuw geprobeerd.
OP het moment dat ik voor had dat de baan zonder spanning stond heb ik de trace genomen.
In de screenshot die bij in de zip zit kan je zien dat volgens rocview de baan nog aan staat, maar rechts onderaan staat wel degelijk 0 volt , 0 Ampere maar toch 5 groene bollen.
Freek
 

Re: z21 detecteert geen kortsluiting als het moet

Postby rjversluis » 08.03.2018, 08:11

Hallo,

ik heb het maar even met mijn test Z21 uitgeprobeerd.
Bij kortsluiting gaat er op de Z21 een rode LED knipperen, en in Rocview is daarna de spanning uit.
Dus: Werkt juist.

Hoe snel de Z21 reageert kun je hier instellen:
z21-maintenance.png


Met de normale instelling komt eerst na een aantal seconden echte sluiting een melding van de centrale. Alles wat er tussen ligt wordt niet aan Rocrail doorgegeven behalve natuurlijk de spanning die naar nul gaat.

Ik zou die leuke 'oude lima' wissels eruit gooien en wat beters daarvoor in de plaats inbouwen.
You do not have the required permissions to view the files attached to this post.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: z21 detecteert geen kortsluiting als het moet

Postby Freek » 08.03.2018, 21:13

Hallo,

meestal is het bij mij ook zo dat de centrale in de fout gaat (dus de rode led gaat knipperen) en dit komt ook zo door in rocrail.
Ik ga dus niet zeggen dat het niet werkt. Maar soms gebeurt het toch dat de centrale de spanning af zet en hier geen melding van geeft.
Ik heb in de maintenance tool de reactie tijd al zo kort mogelijk en zo lang mogelijk gezet, maar het maakt geen verschil.

Heb je de screenshot bekeken die ook in de ZIP zit? Daar zie je dat alle bollen rechts onderaan groen zijn, maar de spanning staat toch af. Rocrail geeft daar ook 0volt aan, dus daaraan zie je dat de spanning af staat maar de software denkt van niet.

Ik ben er volledig mee akkoord dat die kortsluitingen niet mogen voorkomen, maar als het toch voorvalt wil ik er zeker van zijn dat ik daar een melding van krijg in de software.
Ik ga eerst nog is proberen of ik het kan reproduceren zonder rocrail, dat is mij tot nu toe nog niet gelukt.
Als dat niet lukt ga ik het proberen met een extra sensor die de spanning op de baan detecteert om zeker te zijn.

Als ik nog iets tegen kom, kom ik hier nog op terug.
Freek
 

Re: z21 detecteert geen kortsluiting als het moet

Postby Freek » 08.03.2018, 22:35

Het is mij gelukt om het te reproduceren zonder rocrail, het zit dus in de centrale zelf.
Dus mijn excuses voor het valselijk beschuldigen.
Bedankt voor het mee denken en de tips.
Freek
 


Return to Centrales (NL)