[gelöst] Multi Window Start findet Lizenz-File nicht

[gelöst] Multi Window Start findet Lizenz-File nicht

Postby Thagu » 13.07.2018, 23:10

Servus

ich habe kürzlich Rocview so eingerichtet, dass es in zwei Fenster und somit zwei Instanzen startet, wie im Wiki beschrieben.
Das klappt wunderbar, auch Betrieb und Verbindung mit Server.

Das einzige Problem, dass ich momentan habe, ist dass beide Instanzen nach der Lizenz fragen. Beim Aufruf direkt von rocview.exe ohne zweite Instanz ist dies nicht der Fall; der Pfad ist korrekt hinterlegt.

Ich habe bei den beiden Instanzen auch schon jeweils den Pfad erneut hinterlegt, und alles gespeichert, leider ohne Wirkung.

Files vom Problemfall hänge ich an (die haben zwar einen anderen Namen, weil ich eben noch ein zweites Problem melden wollte, welches sich bereits gelöst hat... hoffe das stört nicht).
Und auch das .bat file für den Aufruf..

issue.zip
You do not have the required permissions to view the files attached to this post.
Last edited by Thagu on 13.08.2018, 20:58, edited 1 time in total.
======================================
Märklin H0 K-Gleis
Tams Redbox Booster, B-3 Booster
Laptop Lenovo als Client/Server mit Win10
======================================
Anlagenbau
Anlagenplanung
Thagu
 

Re: Multi Window Start findet Lizenz-File nicht

Postby rjversluis » 14.07.2018, 06:51

Moin,

Rocview sucht lic.dat unter Windows im Arbeitsverzeichnis.

PS: Es gibt kein Lizenz, und Rocview fragt auch nicht nach eins...
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Multi Window Start findet Lizenz-File nicht

Postby GeSchu » 14.07.2018, 10:07

Moin <Thagu>
Code: Select all
cd\
c:
cd program files
cd rocrail
start rocview.exe -s 0 -i "C:\Users\thagu.NB110\Documents\Rocrail\rocview.ini"
ping -n 6 127.0.0.1 >NUL
start rocview.exe -s 1 -i "C:\Users\thagu.NB110\Documents\Rocrail\rocview 2nd Monitor.ini"

Bist Du dir sicher, das dein Code überhaupt grundsätzlich so funktioniert? Warum frage ich das?
Das erste Kommando läuft schon gleich auf einen Fehler. das zweite Kommando hat welchen Sinn? Das dritte Kommando läuft auf einen Fehler and so on.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Multi Window Start findet Lizenz-File nicht

Postby Schorse » 14.07.2018, 11:24

Moin Gerd,

Bist Du dir sicher, das dein Code überhaupt grundsätzlich so funktioniert?
Warum sollte er nicht funktionieren?
Der erste Befehl wechselt zum Haupt- oder Wurzelverzeichnis, der zweite auf Laufwerk C:, der dritte in den Ordner "program files" usw.
Alles gültige Befehle unter Win.
Viele Grüße Gerd
Schorse
 

Re: Multi Window Start findet Lizenz-File nicht

Postby GeSchu » 14.07.2018, 12:23

Moin Gerd,
Schorse wrote:Moin Gerd,
Warum sollte er nicht funktionieren?
Der erste Befehl wechselt zum Haupt- oder Wurzelverzeichnis, der zweite auf Laufwerk C:, der dritte in den Ordner "program files" usw.

Weil:
Code: Select all
cd\

falsch ist. Richtig wäre :
Code: Select all
cd \

weil
Code: Select all
 cd program files
nicht funktioniert, wohl aber
Code: Select all
 cd "program files"

gerade auf win7 nochmal probiert. Win10 habe ich zur Zeit nicht.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Multi Window Start findet Lizenz-File nicht

Postby Schorse » 14.07.2018, 12:58

Moin Gerd,
was hast Du genau probiert: "cd\" oder "cd \"
Bei meinem Win7 funktionieren die Befehle von "Thagu". Benutzt Du ein "richtiges" Win oder die VM?
Viele Grüße Gerd
Schorse
 

Re: Multi Window Start findet Lizenz-File nicht

Postby RainerK » 14.07.2018, 13:06

Hallo Gerd (GeSchu)

unter Win 10 funktionieren cd\ und cd.. auch ohne Leerzeichen zwischen cd und Parameter.

IMHO war das aber auch unter XP schon so.
Best Regards, es grüßt RainerK

Win10 64Bit / DCC++ with Arduino Uno / Motor shield and LocoNet GCA85, 50, 93 and 136.
Special interests: DIY electronic assemblies. http://www.rainermoba.blogspot.com
Planning replace the coincidence by the mistake
RainerK
 

Re: Multi Window Start findet Lizenz-File nicht

Postby rjversluis » 14.07.2018, 13:24

Moin,
RainerK wrote:unter Win 10 funktionieren cd\ und cd.. auch ohne Leerzeichen zwischen cd und Parameter.

das sollte man sich schnellst wieder abgewöhnen.
Postleitzahl und Ortschaft schreibt man auch nicht zusammen.
Also: Befehl, Leerzeichen, Parameter.

PS: "cdUnterverzeichnis" funktioniert leider nicht ohne Leerzeichen. Finde ich nicht konsequent. "formatc:" auch nicht.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Re: Multi Window Start findet Lizenz-File nicht

Postby RainerK » 14.07.2018, 13:59

Hallo Rob,

angewöhnt hatte ich mir das nie.
Ich war da nur mal zufällig durch ein verschludertes Leerzeichen drauf gestoßen
und mich gewundert, dass es trotzdem ging.
Best Regards, es grüßt RainerK

Win10 64Bit / DCC++ with Arduino Uno / Motor shield and LocoNet GCA85, 50, 93 and 136.
Special interests: DIY electronic assemblies. http://www.rainermoba.blogspot.com
Planning replace the coincidence by the mistake
RainerK
 

Re: Multi Window Start findet Lizenz-File nicht

Postby GeSchu » 14.07.2018, 14:37

Moin Gerd,

Schorse wrote:.. Benutzt Du ein "richtiges" Win oder die VM?

Ein richtiges Win in einer VM auf einem MAC :lol:

Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Multi Window Start findet Lizenz-File nicht

Postby Schorse » 14.07.2018, 15:22

Mon Gerd,

Ein richtiges Win in einer VM auf einem MAC
Dann schmeiß' es weg wenn es die Befehle nicht verarbeitet... :)
Viele Grüße Gerd
Schorse
 

Re: Multi Window Start findet Lizenz-File nicht

Postby GeSchu » 14.07.2018, 21:39

Moin Gerd,
[ot]
Schorse wrote:.......
Dann schmeiß' es weg wenn es die Befehle nicht verarbeitet... :)

Nur weil ein OS es zulässt, werde ich mir keinen unsauberen Programmierstil angewöhnen. Es ist gut, das mein Windows, warum auch immer, diesen Stil nicht zulässt und z.B. cd\ als Fehler anzeigt.
Es ja doch auch so: Hauptaugenmerk meiner Tätigkeiten sind andere Systeme. Manchmal benötigt man auch die Sicht auf andere Systeme. Also: Wegschmeißen geht nicht.
[/ot]
Zurück zum Thema:
@<Thagu>:Ist das Problem mittlerweile behoben? Wurde das lic File eingebunden?
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Multi Window Start findet Lizenz-File nicht

Postby GeSchu » 14.07.2018, 22:08

Moin <Thagu>
du meinst mit Sicherheit den Unterstützungsschlüssel.
stimmt die Pfadangabe in den Rocrail Eigenschaften -> Allgemein -> Unterstützungsschlüsselpfad ? Bitte kontrollieren, event. neu setzen und alles neu starten.

PS: Es wäre nett und höflich, wenn man Dich wie hier üblich mit Vornamen anreden könnte.
Gruß
Gerd(GeSchu)
Anlage 1 : H0 C-Gleis; Tams MC; Tams B-2; Tams S88-3; Tams WD-34/Esu SwitchPilot
Server : rocrail auf raspberry/Debian stretch Client : OS X high Sierra / UBUNTU 16.04 .
Werkstatt : H0 C-Gleis; rocrail Softwarezentrale dcc32; DELTA 6604
GeSchu
 

Re: Multi Window Start findet Lizenz-File nicht

Postby JeanClaude » 15.07.2018, 20:07

Moin,

hatte das Problem auch mit 2 Rocview Instanzen aud dem selben Windows 64bit PC. Dabei hatte ich den Lizenschlüssel in das Installationsverzeichnis und ebenfalls in das Arbeitsverzeichnis kopiert. Trotzdem wurde der Key nicht gefunden. Abhilfe war ganz einfach: Lizenzschlüssel beim Programmstart von Rocview neu importieren (bei jeder Instanz).

Schöne Grüße,

Jean-Claude
JeanClaude
 

Re: Multi Window Start findet Lizenz-File nicht

Postby rjversluis » 16.07.2018, 06:31

Moin,

es gibt kein Lizenzschlüssel...
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Next

Return to Basisfunktionalität (DE)