[SOLVED] Big Problemwith some points

[SOLVED] Big Problemwith some points

Postby richard » 13.09.2018, 20:34

Hello,

I've set up a small track (attached) on a table to test automation and rocrail and I have an isue with some points.
Everytime a loco passes over the points on the outer track, they switch position which causes no-end of short-circuits (long locos) and crashes( short loco with wagons).
Any idea what I can do to solve it?
Thanks
You do not have the required permissions to view the files attached to this post.
Last edited by richard on 15.09.2018, 16:29, edited 1 time in total.
HO, 2 rails, Roco geoLine
z21, r-Bus + S88N
GNU/Linux (x64), Rocrail
richard
 

Re: Big Problemwith some points

Postby peter&basti » 13.09.2018, 21:00

Hi Richard,

first of all, it will be very useful to post a "issue" to help to resolve your problem:
https://wiki.rocrail.net/doku.php?id=issue-en
Liebe Grüße / best regards
Peter


System: DCC 2-Leiter H0, Rocrail 64bit auf Win10 Pro 64
Traktion: OpenDCC GBM
Fahrweg: RocNetNode & GCA PI01/2/3, GCA41/Arduino RFID, GCA145 Drehscheibe, etc.
Decoder: 99% Zimo
Experimentell: MQTT & Node-Red
peter&basti
 

Re: Big Problemwith some points

Postby Donald » 13.09.2018, 21:02

Hallo Richard

Please attach the usual files: https://wiki.rocrail.net/doku.php?id=issue-en

Regards
Donald
Spur 0: Modelleisenbahn der schönsten Art
Donald Roschi
Donald
 

Re: Big Problemwith some points

Postby richard » 14.09.2018, 06:46

Guten Tag Peter and Hello Donald,

I think I've managed to create the incident report (I ran it over the points so that it would trigger the problem before creating it).

Thank you for your help,

Richard
You do not have the required permissions to view the files attached to this post.
HO, 2 rails, Roco geoLine
z21, r-Bus + S88N
GNU/Linux (x64), Rocrail
richard
 

Re: Big Problemwith some points

Postby peter&basti » 14.09.2018, 07:21

Good Morning RIchard,

the switches sw1 and sw2 have the same address. It seems to be a mistake.
sw1sw2.PNG
You do not have the required permissions to view the files attached to this post.
Liebe Grüße / best regards
Peter


System: DCC 2-Leiter H0, Rocrail 64bit auf Win10 Pro 64
Traktion: OpenDCC GBM
Fahrweg: RocNetNode & GCA PI01/2/3, GCA41/Arduino RFID, GCA145 Drehscheibe, etc.
Decoder: 99% Zimo
Experimentell: MQTT & Node-Red
peter&basti
 

Re: Big Problemwith some points

Postby richard » 14.09.2018, 16:41

Hello Peter,

I gave those two points the same address because I hadn't at first but rocrail would switch one set of points but not the other which led to short circuits.
Do you think changing it back will solve the issue?

Thanks
HO, 2 rails, Roco geoLine
z21, r-Bus + S88N
GNU/Linux (x64), Rocrail
richard
 

Re: Big Problemwith some points

Postby cds » 14.09.2018, 17:09

Hello Richard,

I was wondering if you could present a specific case of your problems (which loco, start block, direction, route, etc.).

I've already determined a couple of deficiencies in your plan. E. g. in your route "[bk007+]-[bk006-]" point "sw001" is missing.
Beste Grüße/Kind regards
Claus

M* H0 M
HW: TAMS MC, B-2 & B-4, WD-34, VIESSMANN 5211(1), LITTFINSKY & TAMS S88-3
Decoder: Mä & TAMS (MM2)
SW: Win7 64, RR 64, andRoc
cds
 

Re: Big Problemwith some points

Postby richard » 14.09.2018, 17:32

Guten Tag Cds,

The problem is only on the points located on the outer track, all the others behave normally by staying in position and only switching when an itinerary is reserved by a loco.

Everytime one of my two locos drives over it and reaches the next block (bk001) the points switch. This doesn't seem to happen when the point is set towards the inner track but only when it is straight (When I want the train to stay on the outter track).

It happens with both locos with different results. I have a Moyse Type 32 TDE, which is very short, so it has already passed the points when they switch (however any wagon or car behind it will derail, as the loco has gone straight on and the wagons have veered. My second loco is an East-German BR 132 which is a lot longer, so the front axle hasn't even gone completely over the points when they change and since the "heart" (I don't know the English word so I'm translating from French) of the points is polarised, I get a short cirtcuit.
This happens in manual aswell as automatic modes.

This is my first track (basically a big test on a table before creating the real one) so I'vé only tested going counter-clockwise, I haven't yet tried taking a train out of the fiddle yard in the middle and bringing it to a track. So the error is always (for the time being) when going from bloc 6 to bloc 1 (if it's that exact itinerary or one longer that contains this itinerary changes nothing, the switch always happens, every time the first wheels reach the "enter" detector of bk001
HO, 2 rails, Roco geoLine
z21, r-Bus + S88N
GNU/Linux (x64), Rocrail
richard
 

Re: Big Problemwith some points

Postby cds » 14.09.2018, 18:56

Hello!

BR 132 which is a lot longer, so the front axle hasn't even gone completely over the points when they change
BR132, counter-clockwise, point sw001 :arrow: route from "bk006-" to "bk007+" :arrow: problem with sw001, right?
Beste Grüße/Kind regards
Claus

M* H0 M
HW: TAMS MC, B-2 & B-4, WD-34, VIESSMANN 5211(1), LITTFINSKY & TAMS S88-3
Decoder: Mä & TAMS (MM2)
SW: Win7 64, RR 64, andRoc
cds
 

Re: Big Problemwith some points

Postby richard » 14.09.2018, 19:08

No, I never have a problem when the sw01 points are set for the diverging track so that route isn't an issue. (bk07 to BK06)
It's when the points are straight and the loco goes from bk006 to bk001. As soon as the first axle of the loco enters bk001 (I use current sensing modules) the points switch to the diverging track.
HO, 2 rails, Roco geoLine
z21, r-Bus + S88N
GNU/Linux (x64), Rocrail
richard
 

Re: Big Problem with some points

Postby smitt48 » 14.09.2018, 19:15

Hi Richard,

Please delete all your routes (also so the one that you modified) and let the analyser re-generate them all.
Try to run again. If the problem exists, try to change sw002 on a different address. Your z21 might not be able to switch 2 turnouts with the same decoder, or it delays the second turnout, so that the turnouts switches again, causing derailment.

https://wiki.rocrail.net/doku.php?id=sw ... der_output
Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.4) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: Big Problemwith some points

Postby richard » 14.09.2018, 19:54

Hi Tom,

I've done what you suggested and set sw02 on the address 2 and then reran the analyser after deleting all routes, but nothing changed. I ran an automatic session but it changed the points the instant the Moyse reached bk01 (which starts right after the points)
I'm also getting a weird new problem with bk002. The system triggers an unexpected in event in bk002 for Moyse (missing enter event) so I joined a new incident report.
Last edited by richard on 14.09.2018, 20:46, edited 1 time in total.
HO, 2 rails, Roco geoLine
z21, r-Bus + S88N
GNU/Linux (x64), Rocrail
richard
 

Re: Big Problemwith some points

Postby smitt48 » 14.09.2018, 20:31

Hi Richard,

It runs OK with the virtual controller. :mad:

Try changing the sw001 setting in the route see picture.
richard01.png


On top you have straight, bottom right you have thrown. I am not sure it makes a difference, but it can't hurt.

Tom
You do not have the required permissions to view the files attached to this post.
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.4) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Re: Big Problemwith some points

Postby richard » 14.09.2018, 20:46

Hi Tom,

The route add already set the points to straight and they were locked.

It seems that just putting a loco on bk01 whenever rocrail is started, makes the points switch to turnout position. (It's never from turnout to straight)

I've run a new troubleshooter and found this in the .trc


20180914.212257.998 r9999I B0867700 OSwitch 1982 switch [sw001] field event: state=turnout(field:turnout) gatevalue=2 inv=0 fieldstate=turnout
20180914.212257.998 r9999a B0867700 OModel 3632 no more switches found by address [1,0]
You do not have the required permissions to view the files attached to this post.
HO, 2 rails, Roco geoLine
z21, r-Bus + S88N
GNU/Linux (x64), Rocrail
richard
 

Re: Big Problemwith some points

Postby smitt48 » 14.09.2018, 20:59

Hi Richard,

Please change the "thrown" to "straight" on route bk006- to bk001+, as requested by me earlier.
And test again.

Tom
Kind regards,
Tom Smit
Kralendijk, Bonaire - Dutch Caribbean

Märklin M & K-rails with ECoS2 (4.2.4) - Win10
RoSoft: S88n & WDD switch & SDD signal decoders
Display: Tri-ang from 1950's, Märklin from early 1960's
In build phase
smitt48
 

Next

Return to General