Rocrail in the raspberry!

Questions and discussions around compiling of Rocrail, usage of wxWidgets etc.

Moderators: dadolphs, Moderators

Rocrail in the raspberry!

Postby mserrano » 07.10.2012, 18:06

I have been following some posts on how to make rocrail running on the raspberry pi.

Finally, I have been able to compile and make rocrail run.

My "rocpi" seems to be quite stable, though I have not been able to test yet the serail port and ddx.

For newbies in linux like me, I have created a step by step manual. It is mainly coming from this forum, the website and the rpi wiki... but it also contains some customisation features for the rpi. The document was built for my own use as repository of the ideas and steps I was following, so sometimes it is not really structured.

Hope it is useful to someone.

PS: It is also available at
http://tren.enmicasa.net/2012/10/07/roc ... spberrypi/
You do not have the required permissions to view the files attached to this post.
Last edited by mserrano on 10.03.2013, 23:21, edited 1 time in total.
mserrano
 

Postby derookamer » 07.10.2012, 21:04

Hi

look at the place where you can download the rocrail nightly builds, you will find there also a compiled Rocrail version for the raspberry Pi

BR

Fred Jansen
derookamer
 

Postby Pirat-Kapitan » 07.10.2012, 21:18

Hi Fred,
sorry, I did not find a RasPi Rocrail.
How to identify a RasRoc?

best regards
Johannes
Clearasilfahrer auf Spur G&H0m, Lenz LZV (3.6), ORD-20, Manhart-Funki und WLM, RS-Bus Rückmelder (Reedkontakte/GBM),
Rocrail auf RasPi mit mobilen Geräten (andRoc). Details auf http://wiki.rocrail.net/doku.php?id=use ... at-kapitan.
Pirat-Kapitan
 

Postby rjversluis » 07.10.2012, 21:24

Hi Johannes,

http://rocrail.saturnus.it
the debian weezy file.
Best Regards, Rob.
:!: PS: Do not forget to attach the usual files.
:!: PS: Nicht vergessen die übliche Dateien an zu hängen.
[ macOS - Linux] - [ N: CBus - CAN-GCA ] - [ 0: RocNetNode - GCA-Pi ]
rjversluis
Site Admin
 

Postby mserrano » 07.10.2012, 22:33

H Fred,

Thanks, but I already tried the night build - actually it was the first think I tried (I was following the post where you posted it).

For the last version of debian with hard float (wheezy raspbian) it does not seem to work. I have no idea why, I am new to linux.

The deb, package refuses to be installed, saying it is not the rigth platform.

Br,

Manolo
mserrano
 

Raspberry Rocrail Problem

Postby cbegg50 » 08.10.2012, 08:11

I too have had to build the Raspberry Pi Rocrail from sources, and thought I had a workable solution. But I use an Ubuntu based netbook as a remote client (also built from sources) and tried to use it for editing plans (and routes, sensors etc). I ended up with multiple copies of routes and random server crashes when saving the track plan. None of this happens when I run up X on the RasPi and edit there. Is there and endian problem in the editing interface between remote client and server?

Regards,
Colin Begg
cbegg50
 

I spoke too soon

Postby cbegg50 » 09.10.2012, 08:45

Further to my last email, even running Rocview on the RasPi, the database still corrupts. It may be only Intel builds work successfully or it may be the nightly build isn't stable. I'm running build 3933 on the Ubuntu netbook and have not experienced the problem. My demo tonight at a model railway electronics group meeting was supposed to show off Rocrail on the Raspi but it will have to be Rocrail on the netbook. I was up till 2:15am switching the demo over to the notebook! Wish me luck!

Regards,
Colin Begg
cbegg50
 

Installation Problems with .deb package

Postby boejoemoe » 18.11.2012, 12:46

Hi guys,
I would love to have rocrail runnning on my raspberry pi, and therefore tried to install the "rocrail-setup-rev3668-debian-weezy-armel.deb" from here http://rocrail.saturnus.it/ .

However, when using dpkg , I get an error stating :

dpkg: error processing /path/rocrail-setup-rev3668-debian-weezy-armel.deb
package architecture (armel) does not match system (armhf)

As I understand (after some googling) those two are incompatible, and therfore the --force architecture option won't work either. I actually tried it and get some more errors.

Does anybody have a .deb package for the armhf architecture, or did get rocraill running under the latest "wheezy raspian" OS ?
Is there no other way than to compile it on my own? (I've never done that before and am kinda new to linux)

Thanks for your help!

Ben
boejoemoe
 

Postby mserrano » 18.11.2012, 18:41

Hi Ben,

Here you have a .deb package compile for wheezy raspian -armhf:

http://tren.enmicasa.net/wp-content/upl ... -armhf.zip

Sorry but I do not have an updated package.

Here you have some hints on how to compile:
http://tren.enmicasa.net/wp-content/upl ... i_v1.1.pdf

It is more a set fo notes for myself... but hopefully it should help you.

Br,
Manolo
mserrano
 

Thanks Manolo

Postby boejoemoe » 22.11.2012, 13:15

Thanks Manolo,
I'm gonna try it out this weekend, and tell you how it went.

Regards

Ben
boejoemoe
 

It works fine

Postby boejoemoe » 26.11.2012, 16:05

Thanks again,
I installed the package this weekend and configured the deamon to start automatically during power up of the raspberry. Everything seems to work fine.
Thanks for the excellent documentation.

Ben
boejoemoe
 

Postby Pirat-Kapitan » 28.11.2012, 22:04

Hi Manolo,
I got a "ready to use" RasPi with a special installation (no demon, rocrail starts at power on).
I have to study Your making of too (and to learn linux).

I made a picture "all You need for mobile railroading in the garden".
The biggest part is my 10" ipad (below). The little box at the right hand side is the PC in a box.

best regards
Johannes
You do not have the required permissions to view the files attached to this post.
Clearasilfahrer auf Spur G&H0m, Lenz LZV (3.6), ORD-20, Manhart-Funki und WLM, RS-Bus Rückmelder (Reedkontakte/GBM),
Rocrail auf RasPi mit mobilen Geräten (andRoc). Details auf http://wiki.rocrail.net/doku.php?id=use ... at-kapitan.
Pirat-Kapitan
 

Postby mserrano » 31.12.2012, 10:51

Hi everyone,

Just a short post to inform about the last tests with the raspbery pi.

I finally got sime time to build the HW to adapt the voltage levels from the rpi to the ORD-3.

And it works!!

Rocrail (wiith ddx)+ord (from Peter Gilling)+raspberry

I have a video here:
http://tren.enmicasa.net/2012/12/30/ras ... 2-adapter/

It is just a test with a single loco... I still want to stress the testbed launching rocview (coming in the next days).

Happy new year to everyone.

Manolo
mserrano
 

Postby mserrano » 01.01.2013, 20:40

Some extra information:

The serial port in the rpi ttyAMA0 does not seem to be able to generate the dcc signals. The tests I made where with a Motorola loco.

I will make some more tests with other decoders tomorrow. So far:

TAMS (motorola) OK
Loksound (dcc) Not OK
DIY acc decoder Not OK

The work around so far is to make use of a USB-Serial adaptor:

TAMS (motorola) OK
Loksound (dcc) OK
DIY acc decoder OK

I will post if I found out more...at this point it seems the ttyAMA0 is not capable of changing the baudrate.
mserrano
 

Rocrail in the raspberry!

Postby Erikje3105 » 03.01.2013, 07:21

Hi,

It is possible to change the baudrate of the rpi ttyAMA0, look here http://www.andremiller.net/content/raspberry-pi-and-arduino-via-gpio-uart. Please let me know if it works

Erik
Erikje3105
 

Next

Return to Building & Compiling